mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
Mk/bsd.commands.mk: Use absolute path to define GMAKE
Same as BSDMAKE variable. It is needed by some ports. Some ports needed fixes: - devel/rcs57: Regenerate configure with newer autoconf so it can deal with MAKE set to an absolute path. While here fix issues with (un)escaping double quotes. The warnings about this were in WRKSRC/src/conf.err. - lang/gnu-cobol: Patch configure.ac so the MAKE environment variable can contain an absolute path, and define MAKE before it is used in AM_INIT_AUTOMAKE. Remove post-patch patching of configure. It appears to have been fixed upstream. - math/unuran: Remove post-patch, fixed upstream. - net-mgmt/kismet: Fix post-patch. PR: 283534 Exp-run by: antoine
This commit is contained in:
parent
4d94dadbda
commit
624b8729fc
18 changed files with 133 additions and 44 deletions
|
@ -13,7 +13,7 @@ IGNORE= Incorrect 'USES+= gmake:${gmake_ARGS}' gmake takes no arguments
|
|||
. endif
|
||||
|
||||
BUILD_DEPENDS+= gmake>=4.4.1:devel/gmake
|
||||
CONFIGURE_ENV+= MAKE=gmake
|
||||
MAKE_CMD= gmake
|
||||
CONFIGURE_ENV+= MAKE=${GMAKE}
|
||||
MAKE_CMD= ${GMAKE}
|
||||
|
||||
.endif
|
||||
|
|
|
@ -45,7 +45,7 @@ FIND?= /usr/bin/find
|
|||
FLEX?= /usr/bin/flex
|
||||
FMT?= /usr/bin/fmt
|
||||
FMT_80?= ${FMT} 75 79
|
||||
GMAKE?= gmake
|
||||
GMAKE?= ${LOCALBASE}/bin/gmake
|
||||
GREP?= /usr/bin/grep
|
||||
GUNZIP_CMD?= /usr/bin/gunzip -f
|
||||
GZCAT?= /usr/bin/gzcat
|
||||
|
|
|
@ -73,7 +73,7 @@ do-configure:
|
|||
@(cd ${WRKSRC32} && ${AUTORECONF} -f -i && ${SETENV} \
|
||||
PATH=${LINUXBASE}/usr/bin ./configure CPPFLAGS="${CPPFLAGS}" \
|
||||
CFLAGS="${CFLAGS:N-march=*} ${COMPAT32_CFLAGS_${ARCH}}" \
|
||||
LDFLAGS="${LDFLAGS}" MAKE="${LOCALBASE}/bin/gmake" \
|
||||
LDFLAGS="${LDFLAGS}" MAKE="${MAKE_CMD}" \
|
||||
MKDIR_P="${MKDIR}" PKG_CONFIG="${LOCALBASE}/bin/pkgconf" \
|
||||
PKG_CONFIG_PATH=${LINUXBASE}/usr/lib/pkgconfig \
|
||||
${CONFIG_ARGS})
|
||||
|
@ -81,29 +81,25 @@ do-configure:
|
|||
@(cd ${WRKSRC} && ${AUTORECONF} -f -i && ${SETENV} \
|
||||
PATH=${LINUXBASE}/usr/bin ./configure CPPFLAGS="${CPPFLAGS}" \
|
||||
CFLAGS="${CFLAGS:N-march=*}" LDFLAGS="${LDFLAGS}" \
|
||||
MAKE="${LOCALBASE}/bin/gmake" MKDIR_P="${MKDIR}" \
|
||||
MAKE="${MAKE_CMD}" MKDIR_P="${MKDIR}" \
|
||||
PKG_CONFIG="${LOCALBASE}/bin/pkgconf" \
|
||||
PKG_CONFIG_PATH=${LINUXBASE}${LIBDIR_${ARCH}}/pkgconfig \
|
||||
--libdir ${LIBDIR_${ARCH}} ${CONFIG_ARGS})
|
||||
|
||||
do-build:
|
||||
.if !empty(COMPAT32_CFLAGS_${ARCH})
|
||||
@(cd ${WRKSRC32} && ${SETENV} PATH=${LINUXBASE}/usr/bin \
|
||||
${LOCALBASE}/bin/gmake)
|
||||
@(cd ${WRKSRC32} && ${SETENV} PATH=${LINUXBASE}/usr/bin ${MAKE_CMD})
|
||||
.endif
|
||||
@(cd ${WRKSRC} && ${SETENV} PATH=${LINUXBASE}/usr/bin \
|
||||
${LOCALBASE}/bin/gmake)
|
||||
@(cd ${WRKSRC} && ${SETENV} PATH=${LINUXBASE}/usr/bin ${MAKE_CMD})
|
||||
|
||||
do-install:
|
||||
.if !empty(COMPAT32_CFLAGS_${ARCH})
|
||||
@(cd ${WRKSRC32} && ${SETENV} PATH=${LINUXBASE}/usr/bin \
|
||||
${LOCALBASE}/bin/gmake install-strip \
|
||||
DESTDIR=${STAGEDIR}${LINUXBASE})
|
||||
${MAKE_CMD} install-strip DESTDIR=${STAGEDIR}${LINUXBASE})
|
||||
${RM} -r ${STAGEDIR}${LINUXBASE}/usr/lib/alsa-lib/*.la
|
||||
.endif
|
||||
@(cd ${WRKSRC} && ${SETENV} PATH=${LINUXBASE}/usr/bin \
|
||||
${LOCALBASE}/bin/gmake install-strip \
|
||||
DESTDIR=${STAGEDIR}${LINUXBASE})
|
||||
${MAKE_CMD} install-strip DESTDIR=${STAGEDIR}${LINUXBASE})
|
||||
${RM} -r ${STAGEDIR}${LINUXBASE}${LIBDIR_${ARCH}}/alsa-lib/*.la
|
||||
${LN} -sf ../../../usr/share/alsa/alsa.conf.d/50-oss.conf \
|
||||
${STAGEDIR}${LINUXBASE}/etc/alsa/conf.d
|
||||
|
|
|
@ -29,7 +29,7 @@ GH_ACCOUNT= bcgsc
|
|||
SHEBANG_FILES= bin/${PORTNAME}-* DataBase/abyss-db-txt
|
||||
SHEBANG_LANG= make
|
||||
make_OLD_CMD= /usr/bin/make
|
||||
make_CMD= ${PREFIX}/bin/gmake
|
||||
make_CMD= ${GMAKE}
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --without-sparsehash # configure fails to find std::hash, reported to the ML: https://groups.google.com/forum/#!topic/trans-abyss/SZDBKR5bKxs
|
||||
|
|
|
@ -28,7 +28,7 @@ SHEBANG_FILES= tools/pycocci scripts/cpptests.sh
|
|||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= PYTHON="${PYTHON_CMD}" PYVER="${PYTHON_VER}"
|
||||
MAKE_ARGS= PYTHON_VERSION="${PYTHON_VER}"
|
||||
BINARY_ALIAS= make=${LOCALBASE}/bin/gmake
|
||||
BINARY_ALIAS= make=${GMAKE}
|
||||
TEST_TARGET= check check-cpp
|
||||
|
||||
OPTIONS_DEFINE= EMACS VIM
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
PORTNAME= rcs
|
||||
PORTVERSION= 5.7
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= GNU
|
||||
PKGNAMESUFFIX= 57
|
||||
|
@ -17,7 +17,8 @@ OPTIONS_DEFINE= FREEBSD
|
|||
OPTIONS_DEFAULT= FREEBSD
|
||||
FREEBSD_DESC= Apply FreeBSD patches
|
||||
|
||||
USES= desthack gmake
|
||||
USES= autoreconf desthack gmake
|
||||
USE_CSTD= gnu89
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
FREEBSD_EXTRA_PATCHES+= ${FILESDIR}/freebsd-src-ident.c \
|
||||
|
|
12
devel/rcs57/files/patch-configure.in
Normal file
12
devel/rcs57/files/patch-configure.in
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- configure.in.orig 1995-06-16 06:19:24 UTC
|
||||
+++ configure.in
|
||||
@@ -246,9 +246,6 @@ PATH=$ac_save_path
|
||||
PATH=/usr/lib:/usr/bin:/bin:/usr/sbin:/sbin:$PATH
|
||||
AC_PATH_PROGS(SENDMAIL, sendmail mail mailx)
|
||||
PATH=$ac_save_path
|
||||
-case $SENDMAIL in
|
||||
-?*) SENDMAIL=\"$SENDMAIL\"
|
||||
-esac
|
||||
|
||||
# Use the GNU pic -n option if available; it avoids GNU extensions,
|
||||
# which is need for proper operation to generate a portable man page.
|
|
@ -1,6 +1,15 @@
|
|||
--- src/conf.sh.orig 1995-06-15 23:19:24.000000000 -0700
|
||||
+++ src/conf.sh 2013-10-05 20:29:37.323219649 -0700
|
||||
@@ -73,17 +73,6 @@
|
||||
--- src/conf.sh.orig 1995-06-16 06:19:24 UTC
|
||||
+++ src/conf.sh
|
||||
@@ -43,7 +43,7 @@ Id='$Id: conf.sh,v 5.25 1995/06/16 06:19:24 eggert Exp
|
||||
: ${DIFF_L=1}
|
||||
: ${DIFF_SUCCESS=0} ${DIFF_FAILURE=1} ${DIFF_TROUBLE=2}
|
||||
: ${ED=/bin/ed}
|
||||
-: ${SENDMAIL='"/usr/lib/sendmail"'}
|
||||
+: ${SENDMAIL=/usr/lib/sendmail}
|
||||
# : ${LDFLAGS=} ${LIBS=} tickles old shell bug
|
||||
|
||||
C="$CC $ALL_CFLAGS"
|
||||
@@ -73,17 +73,6 @@ esac
|
||||
ech='echo -n' dots='... '
|
||||
esac
|
||||
|
||||
|
@ -18,3 +27,12 @@
|
|||
$ech >&3 "$0: testing compiler for plausibility $dots"
|
||||
echo 'main() { return 0; }' >a.c
|
||||
rm -f a.exe a.out || exit
|
||||
@@ -2053,7 +2042,7 @@ esac
|
||||
'') a='/* ' z='*/ ';;
|
||||
*) a= z=
|
||||
esac
|
||||
-echo "$a#define SENDMAIL $SENDMAIL $z/* how to send mail */"
|
||||
+echo "$a#define SENDMAIL \"$SENDMAIL\" $z/* how to send mail */"
|
||||
|
||||
: configuring TZ_must_be_set
|
||||
echo "#define TZ_must_be_set 0 /* Must TZ be set for gmtime() to work? */"
|
||||
|
|
44
devel/rcs57/files/patch-src_Makefile.in
Normal file
44
devel/rcs57/files/patch-src_Makefile.in
Normal file
|
@ -0,0 +1,44 @@
|
|||
--- src/Makefile.in.orig 1995-06-16 06:19:24 UTC
|
||||
+++ src/Makefile.in
|
||||
@@ -125,8 +125,8 @@ RCSTEST = \
|
||||
# Install RCS and (if applicable) GNU diff before running these tests.
|
||||
# To test RCS before installing it, see the file INSTALL.RCS.
|
||||
RCSTEST = \
|
||||
- ALL_CFLAGS='$(ALL_CFLAGS)' CC='$(CC)' DIFF='$(DIFF)' \
|
||||
- LDFLAGS='$(LDFLAGS)' LIBS='$(LIBS)' \
|
||||
+ ALL_CFLAGS="$(ALL_CFLAGS)" CC="$(CC)" DIFF="$(DIFF)" \
|
||||
+ LDFLAGS="$(LDFLAGS)" LIBS="$(LIBS)" \
|
||||
PATH=$(bindir):$$PATH \
|
||||
sh $(srcdir)/rcstest
|
||||
installcheck ::
|
||||
@@ -153,18 +153,18 @@ conf.h : conf.sh Makefile
|
||||
#(Unix
|
||||
conf.h : conf.sh Makefile
|
||||
$(REMOVE) a.*
|
||||
- ALL_CFLAGS='$(ALL_CFLAGS)' \
|
||||
- CC='$(CC)' \
|
||||
- COMPAT2='$(COMPAT2)' \
|
||||
- DIFF3='$(DIFF3)' DIFF3_BIN='$(DIFF3_BIN)' \
|
||||
- DIFF='$(DIFF)' DIFFFLAGS='$(DIFFFLAGS)' DIFF_L='$(DIFF_L)' \
|
||||
- DIFF_SUCCESS='$(DIFF_SUCCESS)' \
|
||||
- DIFF_FAILURE='$(DIFF_FAILURE)' \
|
||||
- DIFF_TROUBLE='$(DIFF_TROUBLE)' \
|
||||
- ED='$(ED)' \
|
||||
- LDFLAGS='$(LDFLAGS)' LIBS='$(LIBS)' \
|
||||
- RCSPREFIX='$(RCSPREFIX)' \
|
||||
- SENDMAIL='$(SENDMAIL)' \
|
||||
+ ALL_CFLAGS="$(ALL_CFLAGS)" \
|
||||
+ CC="$(CC)" \
|
||||
+ COMPAT2="$(COMPAT2)" \
|
||||
+ DIFF3="$(DIFF3)" DIFF3_BIN="$(DIFF3_BIN)" \
|
||||
+ DIFF="$(DIFF)" DIFFFLAGS="$(DIFFFLAGS)" DIFF_L="$(DIFF_L)" \
|
||||
+ DIFF_SUCCESS="$(DIFF_SUCCESS)" \
|
||||
+ DIFF_FAILURE="$(DIFF_FAILURE)" \
|
||||
+ DIFF_TROUBLE="$(DIFF_TROUBLE)" \
|
||||
+ ED="$(ED)" \
|
||||
+ LDFLAGS="$(LDFLAGS)" LIBS="$(LIBS)" \
|
||||
+ RCSPREFIX="$(RCSPREFIX)" \
|
||||
+ SENDMAIL="$(SENDMAIL)" \
|
||||
$(SHELL) -x $(srcdir)/conf.sh 3>&1 >a.h 2>conf.err
|
||||
mv a.h $@
|
||||
$(REMOVE) a.* core core.* *.core
|
|
@ -11,14 +11,14 @@ WWW= https://www.gnu.org/software/gnucobol/
|
|||
LICENSE= GPLv3 LGPL3
|
||||
LICENSE_COMB= multi
|
||||
|
||||
BUILD_DEPENDS= help2man:misc/help2man
|
||||
LIB_DEPENDS= libgmp.so:math/gmp \
|
||||
libcjson.so:devel/libcjson
|
||||
|
||||
USES= bdb gmake gnome libtool ncurses tar:xz
|
||||
USES= autoreconf bdb gmake gnome libtool ncurses tar:xz
|
||||
USE_GNOME= libxml2
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
|
||||
CONFIGURE_ENV= MATH_LIBS=-lm
|
||||
|
||||
TEST_TARGET= check
|
||||
|
@ -37,8 +37,4 @@ OPTIONS_SUB= yes
|
|||
NLS_USES= gettext
|
||||
NLS_CONFIGURE_ENABLE=nls
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-lcurses|-lncurses|g ; \
|
||||
s|-R$$found_dir|-Wl,-rpath,$$found_dir|g' ${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
34
lang/gnu-cobol/files/patch-configure.ac
Normal file
34
lang/gnu-cobol/files/patch-configure.ac
Normal file
|
@ -0,0 +1,34 @@
|
|||
--- configure.ac.orig 2023-07-28 17:16:37 UTC
|
||||
+++ configure.ac
|
||||
@@ -54,6 +54,8 @@ AC_CONFIG_FILES([tests/run_prog_manual.sh],
|
||||
AC_CONFIG_FILES([tests/run_prog_manual.sh],
|
||||
[chmod +x tests/run_prog_manual.sh])
|
||||
|
||||
+AC_PATH_PROGS([MAKE], [gmake gnumake make])
|
||||
+
|
||||
# In general: don't export/setenv but pass as option to configure
|
||||
# this has the benefit that re-runs will take the same and "sudo"
|
||||
# or later "make" (possibly as different user) will use the same
|
||||
@@ -291,22 +293,6 @@ AC_DEFINE_UNQUOTED([MAX_CALL_FIELD_PARAMS], [$with_max
|
||||
|
||||
|
||||
# Basic capability tests
|
||||
-
|
||||
-configured_make=""
|
||||
-if test -z "$MAKE"; then
|
||||
- AC_CHECK_PROGS([configured_make], [make gmake gnumake])
|
||||
- if test -z "$configured_make"; then
|
||||
- AC_MSG_ERROR([make not found])
|
||||
- else
|
||||
- MAKE=$configured_make
|
||||
- AC_SUBST(MAKE)
|
||||
- fi
|
||||
-else
|
||||
- AC_CHECK_PROG([configured_make], [$MAKE], [$MAKE])
|
||||
- if test -z "$configured_make"; then
|
||||
- AC_MSG_ERROR([make, configured as "$MAKE", was not found])
|
||||
- fi
|
||||
-fi
|
||||
|
||||
AC_MSG_CHECKING([whether ${MAKE} can handle common constructs])
|
||||
rm -f confmake.out
|
|
@ -73,8 +73,7 @@ PICFLAG?= -fPIC
|
|||
CFLAGS+= ${PICFLAG}
|
||||
CONFIGURE_ENV+= PATH="${WRKDIR}/.bin:${PATH}"
|
||||
MAKE_ENV+= MAKE=${GMAKE} PATH="${WRKDIR}/.bin:${PATH}"
|
||||
BINARY_ALIAS= make=${LOCALBASE}/bin/gmake \
|
||||
gcc=${CC} gfortran=${FC} f77=${FC}
|
||||
BINARY_ALIAS= make=${GMAKE} gcc=${CC} gfortran=${FC} f77=${FC}
|
||||
|
||||
pre-everything::
|
||||
@${CAT} ${FILESDIR}/tuning-message
|
||||
|
|
|
@ -16,7 +16,6 @@ USES= gmake libtool localbase:ldflags
|
|||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-shared --with-urng-rngstream --with-urng-default=rngstream \
|
||||
--enable-info
|
||||
MAKE_ENV= MAKE="${MAKE_CMD}"
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
INFO= unuran
|
||||
|
@ -24,10 +23,6 @@ PORTDOCS= unuran.pdf unuran.txt
|
|||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/UNURANFULLCHECK=true make check/s/make/${MAKE_CMD}/' \
|
||||
${WRKSRC}/Makefile.in
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for DD in ${PORTDOCS}
|
||||
|
|
|
@ -60,8 +60,7 @@ post-patch:
|
|||
${WRKSRC}/conf/kismet.conf.in \
|
||||
${WRKSRC}/conf/kismet_drone.conf
|
||||
@${REINPLACE_CMD} -e "s/plugin-/plugin-[aps]/" \
|
||||
-e "s/make/${MAKE_CMD}/" \
|
||||
-e "s/\$$(MAKE)/${MAKE_CMD}/" \
|
||||
-e 's/make/$$(MAKE)/' \
|
||||
${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e "s/CXXFLAGS/CPPFLAGS/" \
|
||||
${WRKSRC}/plugin-alertsyslog/Makefile
|
||||
|
|
|
@ -23,7 +23,7 @@ USE_LDCONFIG= yes
|
|||
|
||||
CMAKE_OFF= ENABLE_POSIX_RUNTIME ENABLE_UNIT_TESTS ENABLE_SYSTEM_TESTS
|
||||
CMAKE_ARGS= -DLLVM_CONFIG_BINARY=${LOCALBASE}/bin/${LLVM_CONFIG} \
|
||||
-DMAKE_BINARY=${LOCALBASE}/bin/gmake
|
||||
-DMAKE_BINARY=${GMAKE}
|
||||
|
||||
OPTIONS_DEFINE= TCMALLOC
|
||||
OPTIONS_DEFAULT= TCMALLOC Z3 STP
|
||||
|
|
|
@ -38,11 +38,6 @@ BASH_SHARED_RUN_DEPENDS=bash:shells/bash
|
|||
BASH_STATIC_RUN_DEPENDS=bash:shells/bash-static
|
||||
FREEBSD_RUN_DEPENDS= bash-completion-freebsd>=0:shells/bash-completion-freebsd
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
# See PR 248829 for details
|
||||
MAKE_CMD= ${LOCALBASE}/bin/gmake
|
||||
|
||||
post-configure:
|
||||
@${REINPLACE_CMD} \
|
||||
-e 's|/etc/ssl/openssl.cnf|${PREFIX}& &|g' \
|
||||
|
@ -62,4 +57,4 @@ do-test:
|
|||
-cd ${WRKSRC}/test && bash ${test}
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -42,7 +42,7 @@ GH_TUPLE= tianocore:edk2-platforms:${PLATFORM_TAG}:platforms \
|
|||
.include <bsd.port.pre.mk>
|
||||
|
||||
# Heavily dependent on bsd.port.pre.mk definitions for lang/gcc* details:
|
||||
BINARY_ALIAS= make=${LOCALBASE}/bin/gmake \
|
||||
BINARY_ALIAS= make=${GMAKE} \
|
||||
dtc=${LOCALBASE}/bin/dtc \
|
||||
ar=${AR} \
|
||||
gcc=${LOCALBASE}/bin/${CC} \
|
||||
|
|
|
@ -50,7 +50,7 @@ NO_ARCH= yes
|
|||
GLIB_SCHEMAS= org.freedesktop.ibus.engine.typing-booster.gschema.xml
|
||||
|
||||
TEST_TARGET= check
|
||||
TEST_ENV= MAKE_CMD=${LOCALBASE}/bin/gmake LC_ALL=en_US.UTF-8 \
|
||||
TEST_ENV= ${MAKE_ENV} \
|
||||
IBUS_TYPING_BOOSTER_DEBUG_LEVEL=1
|
||||
|
||||
OPTIONS_DEFINE= HUNSPELL
|
||||
|
|
Loading…
Add table
Reference in a new issue