mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 17:46:38 -04:00
Same as BSDMAKE variable. It is needed by some ports. Some ports needed fixes: - devel/rcs57: Regenerate configure with newer autoconf so it can deal with MAKE set to an absolute path. While here fix issues with (un)escaping double quotes. The warnings about this were in WRKSRC/src/conf.err. - lang/gnu-cobol: Patch configure.ac so the MAKE environment variable can contain an absolute path, and define MAKE before it is used in AM_INIT_AUTOMAKE. Remove post-patch patching of configure. It appears to have been fixed upstream. - math/unuran: Remove post-patch, fixed upstream. - net-mgmt/kismet: Fix post-patch. PR: 283534 Exp-run by: antoine
44 lines
1.5 KiB
Text
44 lines
1.5 KiB
Text
--- src/Makefile.in.orig 1995-06-16 06:19:24 UTC
|
|
+++ src/Makefile.in
|
|
@@ -125,8 +125,8 @@ RCSTEST = \
|
|
# Install RCS and (if applicable) GNU diff before running these tests.
|
|
# To test RCS before installing it, see the file INSTALL.RCS.
|
|
RCSTEST = \
|
|
- ALL_CFLAGS='$(ALL_CFLAGS)' CC='$(CC)' DIFF='$(DIFF)' \
|
|
- LDFLAGS='$(LDFLAGS)' LIBS='$(LIBS)' \
|
|
+ ALL_CFLAGS="$(ALL_CFLAGS)" CC="$(CC)" DIFF="$(DIFF)" \
|
|
+ LDFLAGS="$(LDFLAGS)" LIBS="$(LIBS)" \
|
|
PATH=$(bindir):$$PATH \
|
|
sh $(srcdir)/rcstest
|
|
installcheck ::
|
|
@@ -153,18 +153,18 @@ conf.h : conf.sh Makefile
|
|
#(Unix
|
|
conf.h : conf.sh Makefile
|
|
$(REMOVE) a.*
|
|
- ALL_CFLAGS='$(ALL_CFLAGS)' \
|
|
- CC='$(CC)' \
|
|
- COMPAT2='$(COMPAT2)' \
|
|
- DIFF3='$(DIFF3)' DIFF3_BIN='$(DIFF3_BIN)' \
|
|
- DIFF='$(DIFF)' DIFFFLAGS='$(DIFFFLAGS)' DIFF_L='$(DIFF_L)' \
|
|
- DIFF_SUCCESS='$(DIFF_SUCCESS)' \
|
|
- DIFF_FAILURE='$(DIFF_FAILURE)' \
|
|
- DIFF_TROUBLE='$(DIFF_TROUBLE)' \
|
|
- ED='$(ED)' \
|
|
- LDFLAGS='$(LDFLAGS)' LIBS='$(LIBS)' \
|
|
- RCSPREFIX='$(RCSPREFIX)' \
|
|
- SENDMAIL='$(SENDMAIL)' \
|
|
+ ALL_CFLAGS="$(ALL_CFLAGS)" \
|
|
+ CC="$(CC)" \
|
|
+ COMPAT2="$(COMPAT2)" \
|
|
+ DIFF3="$(DIFF3)" DIFF3_BIN="$(DIFF3_BIN)" \
|
|
+ DIFF="$(DIFF)" DIFFFLAGS="$(DIFFFLAGS)" DIFF_L="$(DIFF_L)" \
|
|
+ DIFF_SUCCESS="$(DIFF_SUCCESS)" \
|
|
+ DIFF_FAILURE="$(DIFF_FAILURE)" \
|
|
+ DIFF_TROUBLE="$(DIFF_TROUBLE)" \
|
|
+ ED="$(ED)" \
|
|
+ LDFLAGS="$(LDFLAGS)" LIBS="$(LIBS)" \
|
|
+ RCSPREFIX="$(RCSPREFIX)" \
|
|
+ SENDMAIL="$(SENDMAIL)" \
|
|
$(SHELL) -x $(srcdir)/conf.sh 3>&1 >a.h 2>conf.err
|
|
mv a.h $@
|
|
$(REMOVE) a.* core core.* *.core
|