mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 17:46:38 -04:00
Same as BSDMAKE variable. It is needed by some ports. Some ports needed fixes: - devel/rcs57: Regenerate configure with newer autoconf so it can deal with MAKE set to an absolute path. While here fix issues with (un)escaping double quotes. The warnings about this were in WRKSRC/src/conf.err. - lang/gnu-cobol: Patch configure.ac so the MAKE environment variable can contain an absolute path, and define MAKE before it is used in AM_INIT_AUTOMAKE. Remove post-patch patching of configure. It appears to have been fixed upstream. - math/unuran: Remove post-patch, fixed upstream. - net-mgmt/kismet: Fix post-patch. PR: 283534 Exp-run by: antoine
34 lines
1.1 KiB
Text
34 lines
1.1 KiB
Text
--- configure.ac.orig 2023-07-28 17:16:37 UTC
|
|
+++ configure.ac
|
|
@@ -54,6 +54,8 @@ AC_CONFIG_FILES([tests/run_prog_manual.sh],
|
|
AC_CONFIG_FILES([tests/run_prog_manual.sh],
|
|
[chmod +x tests/run_prog_manual.sh])
|
|
|
|
+AC_PATH_PROGS([MAKE], [gmake gnumake make])
|
|
+
|
|
# In general: don't export/setenv but pass as option to configure
|
|
# this has the benefit that re-runs will take the same and "sudo"
|
|
# or later "make" (possibly as different user) will use the same
|
|
@@ -291,22 +293,6 @@ AC_DEFINE_UNQUOTED([MAX_CALL_FIELD_PARAMS], [$with_max
|
|
|
|
|
|
# Basic capability tests
|
|
-
|
|
-configured_make=""
|
|
-if test -z "$MAKE"; then
|
|
- AC_CHECK_PROGS([configured_make], [make gmake gnumake])
|
|
- if test -z "$configured_make"; then
|
|
- AC_MSG_ERROR([make not found])
|
|
- else
|
|
- MAKE=$configured_make
|
|
- AC_SUBST(MAKE)
|
|
- fi
|
|
-else
|
|
- AC_CHECK_PROG([configured_make], [$MAKE], [$MAKE])
|
|
- if test -z "$configured_make"; then
|
|
- AC_MSG_ERROR([make, configured as "$MAKE", was not found])
|
|
- fi
|
|
-fi
|
|
|
|
AC_MSG_CHECKING([whether ${MAKE} can handle common constructs])
|
|
rm -f confmake.out
|