ports/net/mosquitto/files/patch-src_CMakeLists.txt
Craig Leres a8712b4aa0 net/mosquitto: Update to 2.0.20
Changes since 2.0.18:

 - Fix mismatched subscribe/unsubscribe with normal/shared topics.

 - Fix crash on bridge using remapped topic being sent a crafted
   packet.

 - Fix assert failure when loading a persistence file that contains
   subscriptions with no client id.

 - Fix local bridges being incorrectly expired when
   persistent_client_expiration is in use.

 - Fix use of CLOCK_BOOTTIME for getting time.

 - Fix mismatched subscribe/unsubscribe with normal/shared topics.

 - Fix crash on bridge using remapped topic being sent a crafted
   packet.

 - Fix some error codes being converted to string as "unknown".

 - Clear SSL error state to avoid spurious error reporting.

 - Fix "payload format invalid" not being allowed as a PUBREC reason
   code.

 - Don't allow SUBACK with missing reason codes.

 - Fix QoS 1 / QoS 2 publish incorrectly returning "no subscribers".

 - Don't allow invalid response topic values.

 - Fix some strict protocol compliance issues.

PR:		283395
Reported by:	ari@stonepile.fi
Approved by:	joe@thrallingpenguin.com (maintainer timeout, 5 weeks)
2025-01-25 10:22:30 -08:00

11 lines
387 B
Text

--- src/CMakeLists.txt.orig 2024-12-18 09:43:22.511844000 +0200
+++ src/CMakeLists.txt 2024-12-18 09:45:34.368783000 +0200
@@ -194,7 +194,7 @@
if (WITH_WEBSOCKETS)
if (STATIC_WEBSOCKETS)
- set (MOSQ_LIBS ${MOSQ_LIBS} websockets_static)
+ set (MOSQ_LIBS ${MOSQ_LIBS} websockets)
if (WIN32)
set (MOSQ_LIBS ${MOSQ_LIBS} iphlpapi)
link_directories(${mosquitto_SOURCE_DIR})