mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
net/mosquitto: Update to 2.0.20
Changes since 2.0.18: - Fix mismatched subscribe/unsubscribe with normal/shared topics. - Fix crash on bridge using remapped topic being sent a crafted packet. - Fix assert failure when loading a persistence file that contains subscriptions with no client id. - Fix local bridges being incorrectly expired when persistent_client_expiration is in use. - Fix use of CLOCK_BOOTTIME for getting time. - Fix mismatched subscribe/unsubscribe with normal/shared topics. - Fix crash on bridge using remapped topic being sent a crafted packet. - Fix some error codes being converted to string as "unknown". - Clear SSL error state to avoid spurious error reporting. - Fix "payload format invalid" not being allowed as a PUBREC reason code. - Don't allow SUBACK with missing reason codes. - Fix QoS 1 / QoS 2 publish incorrectly returning "no subscribers". - Don't allow invalid response topic values. - Fix some strict protocol compliance issues. PR: 283395 Reported by: ari@stonepile.fi Approved by: joe@thrallingpenguin.com (maintainer timeout, 5 weeks)
This commit is contained in:
parent
883fdf4c76
commit
a8712b4aa0
3 changed files with 7 additions and 14 deletions
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= mosquitto
|
||||
DISTVERSION= 2.0.18
|
||||
DISTVERSION= 2.0.20
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= https://mosquitto.org/files/source/
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1697355630
|
||||
SHA256 (mosquitto-2.0.18.tar.gz) = d665fe7d0032881b1371a47f34169ee4edab67903b2cd2b4c083822823f4448a
|
||||
SIZE (mosquitto-2.0.18.tar.gz) = 796351
|
||||
TIMESTAMP = 1734507485
|
||||
SHA256 (mosquitto-2.0.20.tar.gz) = ebd07d89d2a446a7f74100ad51272e4a8bf300b61634a7812e19f068f2759de8
|
||||
SIZE (mosquitto-2.0.20.tar.gz) = 799972
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- src/CMakeLists.txt.orig 2023-02-13 19:40:35 UTC
|
||||
+++ src/CMakeLists.txt
|
||||
@@ -194,13 +194,13 @@ endif (WIN32)
|
||||
--- src/CMakeLists.txt.orig 2024-12-18 09:43:22.511844000 +0200
|
||||
+++ src/CMakeLists.txt 2024-12-18 09:45:34.368783000 +0200
|
||||
@@ -194,7 +194,7 @@
|
||||
|
||||
if (WITH_WEBSOCKETS)
|
||||
if (STATIC_WEBSOCKETS)
|
||||
|
@ -9,10 +9,3 @@
|
|||
if (WIN32)
|
||||
set (MOSQ_LIBS ${MOSQ_LIBS} iphlpapi)
|
||||
link_directories(${mosquitto_SOURCE_DIR})
|
||||
endif (WIN32)
|
||||
else (STATIC_WEBSOCKETS)
|
||||
- set (MOSQ_LIBS ${MOSQ_LIBS} websockets)
|
||||
+ set (MOSQ_LIBS ${MOSQ_LIBS} websockets_shared)
|
||||
endif (STATIC_WEBSOCKETS)
|
||||
endif (WITH_WEBSOCKETS)
|
||||
|
||||
|
|
Loading…
Add table
Reference in a new issue