ports/science/pulseview/files/patch-CMakeLists.txt
Andriy Gapon 9ada3310f7 science/pulseview: unbreak the build
The root cause of build failures was forcing -std=c++11 option on the
compiler while boost really requires at least C++14.
Boost was recently upgarded to version 1.87, see a4245a4c6c.

This change reverts 338914f96f and adds a patch to suppress -std=c++11.
2025-02-21 08:06:49 +02:00

18 lines
612 B
Text

--- CMakeLists.txt.orig 2020-03-31 23:41:18.000000000 +0300
+++ CMakeLists.txt 2025-02-17 08:49:34.073618000 +0200
@@ -146,7 +146,6 @@
include(CheckCXXSourceCompiles)
include(CMakePushCheckState)
cmake_push_check_state()
- set(CMAKE_REQUIRED_FLAGS "-std=c++11")
set(CMAKE_REQUIRED_LIBRARIES "${additional_lib}")
set(CMAKE_REQUIRED_QUIET 1)
CHECK_CXX_SOURCE_COMPILES("
@@ -445,7 +444,6 @@
add_definitions(-DQT_NO_KEYWORDS)
add_definitions(-D__STDC_LIMIT_MACROS)
add_definitions(-Wall -Wextra)
-add_definitions(-std=c++11)
add_definitions(-DBOOST_MATH_DISABLE_FLOAT128=1)
if(ENABLE_FLOW)