mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
science/pulseview: unbreak the build
The root cause of build failures was forcing -std=c++11 option on the compiler while boost really requires at least C++14. Boost was recently upgarded to version 1.87, seea4245a4c6c
. This change reverts338914f96f
and adds a patch to suppress -std=c++11.
This commit is contained in:
parent
921529d30f
commit
9ada3310f7
2 changed files with 18 additions and 2 deletions
|
@ -15,8 +15,6 @@ WWW= https://sigrok.org/
|
|||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BROKEN= fails to build with Boost>=1.87
|
||||
|
||||
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
|
||||
libsigrok.so:devel/libsigrok \
|
||||
libsigrokdecode.so:devel/libsigrokdecode
|
||||
|
|
18
science/pulseview/files/patch-CMakeLists.txt
Normal file
18
science/pulseview/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- CMakeLists.txt.orig 2020-03-31 23:41:18.000000000 +0300
|
||||
+++ CMakeLists.txt 2025-02-17 08:49:34.073618000 +0200
|
||||
@@ -146,7 +146,6 @@
|
||||
include(CheckCXXSourceCompiles)
|
||||
include(CMakePushCheckState)
|
||||
cmake_push_check_state()
|
||||
- set(CMAKE_REQUIRED_FLAGS "-std=c++11")
|
||||
set(CMAKE_REQUIRED_LIBRARIES "${additional_lib}")
|
||||
set(CMAKE_REQUIRED_QUIET 1)
|
||||
CHECK_CXX_SOURCE_COMPILES("
|
||||
@@ -445,7 +444,6 @@
|
||||
add_definitions(-DQT_NO_KEYWORDS)
|
||||
add_definitions(-D__STDC_LIMIT_MACROS)
|
||||
add_definitions(-Wall -Wextra)
|
||||
-add_definitions(-std=c++11)
|
||||
add_definitions(-DBOOST_MATH_DISABLE_FLOAT128=1)
|
||||
|
||||
if(ENABLE_FLOW)
|
Loading…
Add table
Reference in a new issue