ports/lang/quickjs-ng/files/patch-CMakeLists.txt
Sergey A. Osokin 31bf272f72 lang/quickjs-ng: update the port to fix several issues (+)
- usage GITHUB* family variables
- remove needless options from the USES variable
- add a quick patch to fix a build issue on some platform

Reported by:	diizzy
Reviewed by:	diizzy
Fixes:		6c458c3785

Bump PORTREVISION.
2025-01-28 19:01:31 -05:00

11 lines
366 B
Text

--- CMakeLists.txt.orig 2025-01-28 23:42:03 UTC
+++ CMakeLists.txt
@@ -28,8 +28,6 @@ if(NOT MSVC AND NOT IOS)
xcheck_add_c_compiler_flag(-Wall)
if(NOT MSVC AND NOT IOS)
- xcheck_add_c_compiler_flag(-Werror)
- xcheck_add_c_compiler_flag(-Wextra)
endif()
xcheck_add_c_compiler_flag(-Wno-implicit-fallthrough)
xcheck_add_c_compiler_flag(-Wno-sign-compare)