lang/quickjs-ng: update the port to fix several issues (+)

- usage GITHUB* family variables
- remove needless options from the USES variable
- add a quick patch to fix a build issue on some platform

Reported by:	diizzy
Reviewed by:	diizzy
Fixes:		6c458c3785

Bump PORTREVISION.
This commit is contained in:
Sergey A. Osokin 2025-01-28 18:56:24 -05:00
parent 350c6366d2
commit 31bf272f72
2 changed files with 14 additions and 2 deletions

View file

@ -1,6 +1,7 @@
PORTNAME= quickjs
PORTVERSION= 0.8.0
DISTVERSION= 0.8.0
DISTVERSIONPREFIX= v
PORTREVISION= 1
CATEGORIES= lang devel
PKGNAMESUFFIX= -ng
@ -11,7 +12,7 @@ WWW= https://quickjs-ng.github.io/quickjs/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= compiler:c11 cmake:testing,noninja cmake cpe tar:xz
USES= cmake:testing,noninja compiler:c11 cpe
USE_LDCONFIG= yes
USE_GITHUB= yes

View file

@ -0,0 +1,11 @@
--- CMakeLists.txt.orig 2025-01-28 23:42:03 UTC
+++ CMakeLists.txt
@@ -28,8 +28,6 @@ if(NOT MSVC AND NOT IOS)
xcheck_add_c_compiler_flag(-Wall)
if(NOT MSVC AND NOT IOS)
- xcheck_add_c_compiler_flag(-Werror)
- xcheck_add_c_compiler_flag(-Wextra)
endif()
xcheck_add_c_compiler_flag(-Wno-implicit-fallthrough)
xcheck_add_c_compiler_flag(-Wno-sign-compare)