mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
Changes: https://github.com/pylint-dev/pylint/releases https://pylint.readthedocs.io/en/latest/whatsnew/3/
21 lines
691 B
TOML
21 lines
691 B
TOML
--- pyproject.toml.orig 2025-03-20 11:25:02 UTC
|
|
+++ pyproject.toml
|
|
@@ -1,15 +1,15 @@ build-backend = "setuptools.build_meta"
|
|
[build-system]
|
|
build-backend = "setuptools.build_meta"
|
|
|
|
-requires = [ "setuptools>=71.0.4" ]
|
|
+requires = [ "setuptools>=62.6" ]
|
|
|
|
[project]
|
|
name = "pylint"
|
|
description = "python code static checker"
|
|
readme = "README.rst"
|
|
keywords = [ "lint", "linter", "python", "static code analysis" ]
|
|
-license = "GPL-2.0-or-later"
|
|
-license-files = [ "LICENSE", "CONTRIBUTORS.txt" ]
|
|
+license = { text="GPL-2.0-or-later" }
|
|
+# license-files = [ "LICENSE", "CONTRIBUTORS.txt" ]
|
|
authors = [
|
|
{ name = "Python Code Quality Authority", email = "code-quality@python.org" },
|
|
]
|