mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
devel/pylint: Update to 3.3.6
Changes: https://github.com/pylint-dev/pylint/releases https://pylint.readthedocs.io/en/latest/whatsnew/3/
This commit is contained in:
parent
186a8781b0
commit
1ca18e2505
3 changed files with 22 additions and 10 deletions
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= pylint
|
||||
PORTVERSION= 3.3.5
|
||||
PORTVERSION= 3.3.6
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= PYPI
|
||||
PKGNAMESUFFIX= ${PYTHON_PKGNAMESUFFIX}
|
||||
|
@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astroid>=3.3.8<3.4.0:devel/py-astroid@${PY_F
|
|||
${PYTHON_PKGNAMEPREFIX}dill>=0.3.7:devel/py-dill@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}isort>=4.2.5<7:devel/py-isort@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}mccabe>=0.6<0.8:devel/py-mccabe@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}platformdirs>=2.2.0:devel/py-platformdirs@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}platformdirs>=2.2:devel/py-platformdirs@${PY_FLAVOR} \
|
||||
${PY_TOMLI} \
|
||||
${PYTHON_PKGNAMEPREFIX}tomlkit>=0.10.1:textproc/py-tomlkit@${PY_FLAVOR}
|
||||
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
|
||||
|
@ -32,7 +32,7 @@ NO_ARCH= yes
|
|||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PYTHON_REL} < 31000
|
||||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.10.0:devel/py-typing-extensions@${PY_FLAVOR}
|
||||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.10:devel/py-typing-extensions@${PY_FLAVOR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1742070250
|
||||
SHA256 (pylint-3.3.5.tar.gz) = 38d0f784644ed493d91f76b5333a0e370a1c1bc97c22068a77523b4bf1e82c31
|
||||
SIZE (pylint-3.3.5.tar.gz) = 1519168
|
||||
TIMESTAMP = 1744288718
|
||||
SHA256 (pylint-3.3.6.tar.gz) = b634a041aac33706d56a0d217e6587228c66427e20ec21a019bc4cdee48c040a
|
||||
SIZE (pylint-3.3.6.tar.gz) = 1519586
|
||||
|
|
|
@ -1,9 +1,21 @@
|
|||
--- pyproject.toml.orig 2023-12-11 13:19:57 UTC
|
||||
--- pyproject.toml.orig 2025-03-20 11:25:02 UTC
|
||||
+++ pyproject.toml
|
||||
@@ -1,5 +1,5 @@
|
||||
@@ -1,15 +1,15 @@ build-backend = "setuptools.build_meta"
|
||||
[build-system]
|
||||
-requires = ["setuptools>=71.0.4"]
|
||||
+requires = ["setuptools>=62.6"]
|
||||
build-backend = "setuptools.build_meta"
|
||||
|
||||
-requires = [ "setuptools>=71.0.4" ]
|
||||
+requires = [ "setuptools>=62.6" ]
|
||||
|
||||
[project]
|
||||
name = "pylint"
|
||||
description = "python code static checker"
|
||||
readme = "README.rst"
|
||||
keywords = [ "lint", "linter", "python", "static code analysis" ]
|
||||
-license = "GPL-2.0-or-later"
|
||||
-license-files = [ "LICENSE", "CONTRIBUTORS.txt" ]
|
||||
+license = { text="GPL-2.0-or-later" }
|
||||
+# license-files = [ "LICENSE", "CONTRIBUTORS.txt" ]
|
||||
authors = [
|
||||
{ name = "Python Code Quality Authority", email = "code-quality@python.org" },
|
||||
]
|
||||
|
|
Loading…
Add table
Reference in a new issue