games/liblcf: update 0.8 → 0.8.1

This commit is contained in:
Dmitry Marakasov 2025-04-09 23:03:14 +03:00
parent c56b74b6f6
commit fd5495fe8a
5 changed files with 9 additions and 34 deletions

View file

@ -1,6 +1,5 @@
PORTNAME= liblcf PORTNAME= liblcf
PORTVERSION= 0.8 PORTVERSION= 0.8.1
PORTREVISION= 2
CATEGORIES= games CATEGORIES= games
MAINTAINER= amdmi3@FreeBSD.org MAINTAINER= amdmi3@FreeBSD.org
@ -12,7 +11,8 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libicui18n.so:devel/icu \ LIB_DEPENDS= libicui18n.so:devel/icu \
libexpat.so:textproc/expat2 libexpat.so:textproc/expat2 \
libinih.so:devel/inih
USE_GITHUB= yes USE_GITHUB= yes
GH_ACCOUNT= EasyRPG GH_ACCOUNT= EasyRPG

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1683027953 TIMESTAMP = 1744034573
SHA256 (EasyRPG-liblcf-0.8_GH0.tar.gz) = aa5664145842a39442e9bbf178273e91816d6d6bf6db7347196bde518dfb431e SHA256 (EasyRPG-liblcf-0.8.1_GH0.tar.gz) = 5ec89082d54f1a29d23fed54de70acab4375036d57828ff0fc7a88b81833d40f
SIZE (EasyRPG-liblcf-0.8_GH0.tar.gz) = 305885 SIZE (EasyRPG-liblcf-0.8.1_GH0.tar.gz) = 310671

View file

@ -1,11 +0,0 @@
--- CMakeLists.txt.orig 2023-04-29 15:40:07 UTC
+++ CMakeLists.txt
@@ -21,7 +21,7 @@ include(ConfigureWindows)
include(ConfigureWindows)
# C++14 is required
-set(CMAKE_CXX_STANDARD 14)
+set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_CXX_EXTENSIONS ON)

View file

@ -1,15 +0,0 @@
--- src/reader_util.cpp.orig 2015-09-14 08:49:23 UTC
+++ src/reader_util.cpp
@@ -310,11 +310,7 @@ std::string ReaderUtil::Recode(const std
size_t dst_size = str_to_encode.size() * 5 + 10;
char *dst = new char[dst_size];
size_t dst_left = dst_size;
-# ifdef ICONV_CONST
- char ICONV_CONST *p = src;
-# else
- char *p = src;
-# endif
+ char const *p = src;
char *q = dst;
size_t status = iconv(cd, &p, &src_left, &q, &dst_left);
iconv_close(cd);

View file

@ -9,7 +9,6 @@ include/lcf/dbstring.h
include/lcf/encoder.h include/lcf/encoder.h
include/lcf/enum_tags.h include/lcf/enum_tags.h
include/lcf/flag_set.h include/lcf/flag_set.h
include/lcf/ini.h
include/lcf/inireader.h include/lcf/inireader.h
include/lcf/ldb/chunks.h include/lcf/ldb/chunks.h
include/lcf/ldb/reader.h include/lcf/ldb/reader.h
@ -17,6 +16,7 @@ include/lcf/lmt/chunks.h
include/lcf/lmt/reader.h include/lcf/lmt/reader.h
include/lcf/lmu/chunks.h include/lcf/lmu/chunks.h
include/lcf/lmu/reader.h include/lcf/lmu/reader.h
include/lcf/log_handler.h
include/lcf/lsd/chunks.h include/lcf/lsd/chunks.h
include/lcf/lsd/reader.h include/lcf/lsd/reader.h
include/lcf/reader_lcf.h include/lcf/reader_lcf.h
@ -80,6 +80,7 @@ include/lcf/rpg/skill.h
include/lcf/rpg/sound.h include/lcf/rpg/sound.h
include/lcf/rpg/start.h include/lcf/rpg/start.h
include/lcf/rpg/state.h include/lcf/rpg/state.h
include/lcf/rpg/stringvariable.h
include/lcf/rpg/switch.h include/lcf/rpg/switch.h
include/lcf/rpg/system.h include/lcf/rpg/system.h
include/lcf/rpg/terms.h include/lcf/rpg/terms.h
@ -96,9 +97,9 @@ include/lcf/scope_guard.h
include/lcf/span.h include/lcf/span.h
include/lcf/string_view.h include/lcf/string_view.h
include/lcf/third_party/span.h include/lcf/third_party/span.h
include/lcf/third_party/string_view.h
include/lcf/writer_lcf.h include/lcf/writer_lcf.h
include/lcf/writer_xml.h include/lcf/writer_xml.h
lib/cmake/liblcf/Findinih.cmake
lib/cmake/liblcf/liblcf-config-version.cmake lib/cmake/liblcf/liblcf-config-version.cmake
lib/cmake/liblcf/liblcf-config.cmake lib/cmake/liblcf/liblcf-config.cmake
lib/cmake/liblcf/liblcf-targets-%%CMAKE_BUILD_TYPE%%.cmake lib/cmake/liblcf/liblcf-targets-%%CMAKE_BUILD_TYPE%%.cmake