mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
accessibility/hyprsunset: add new port
hyprsunset is a small utility to provide a blue light filter for your system. This method is preferred to screen shaders as it will not be captured via recording / screenshots. Requires hyprland >= 0.45.0 for hyprland-ctm-control-v1 protocol. https://github.com/hyprwm/hyprsunset
This commit is contained in:
parent
fbc1b9f699
commit
ee80f3761f
5 changed files with 58 additions and 0 deletions
|
@ -9,6 +9,7 @@
|
|||
SUBDIR += feedbackd
|
||||
SUBDIR += gammastep
|
||||
SUBDIR += gammy
|
||||
SUBDIR += hyprsunset
|
||||
SUBDIR += kdeaccessibility
|
||||
SUBDIR += kmag
|
||||
SUBDIR += kmousetool
|
||||
|
|
24
accessibility/hyprsunset/Makefile
Normal file
24
accessibility/hyprsunset/Makefile
Normal file
|
@ -0,0 +1,24 @@
|
|||
PORTNAME= hyprsunset
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.1.0
|
||||
CATEGORIES= accessibility wayland
|
||||
|
||||
MAINTAINER= jbeich@FreeBSD.org
|
||||
COMMENT= Blue light filter on Hyprland
|
||||
WWW= https://github.com/hyprwm/hyprsunset
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= hyprwayland-scanner>=0.4.0:devel/hyprwayland-scanner \
|
||||
wayland-protocols>0:graphics/wayland-protocols
|
||||
LIB_DEPENDS= libhyprutils.so:devel/hyprutils \
|
||||
libwayland-client.so:graphics/wayland
|
||||
|
||||
USES= cmake compiler:c++11-lib localbase:ldflags pkgconfig
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= hyprwm
|
||||
GH_TUPLE= hyprwm:hyprland-protocols:v0.4.0:hyprland_protocols/subprojects/hyprland-protocols
|
||||
PLIST_FILES= bin/${PORTNAME}
|
||||
|
||||
.include <bsd.port.mk>
|
5
accessibility/hyprsunset/distinfo
Normal file
5
accessibility/hyprsunset/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
TIMESTAMP = 1728415425
|
||||
SHA256 (hyprwm-hyprsunset-v0.1.0_GH0.tar.gz) = 88c9fb2c3efb3ccb398c66a90658765312faf818678a6a8e0e727cfba5f13a9b
|
||||
SIZE (hyprwm-hyprsunset-v0.1.0_GH0.tar.gz) = 8571
|
||||
SHA256 (hyprwm-hyprland-protocols-v0.4.0_GH0.tar.gz) = ab3525d8bad576db911d4ba1b586f303dd988660b3b8980022c1795fd574b165
|
||||
SIZE (hyprwm-hyprland-protocols-v0.4.0_GH0.tar.gz) = 8131
|
23
accessibility/hyprsunset/files/patch-CMakeLists.txt
Normal file
23
accessibility/hyprsunset/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,23 @@
|
|||
-- Checking for module 'hyprland-protocols>=0.4.0'
|
||||
-- Package 'hyprland-protocols' not found
|
||||
CMake Error at /usr/local/share/cmake/Modules/FindPkgConfig.cmake:645 (message):
|
||||
The following required packages were not found:
|
||||
|
||||
- hyprland-protocols>=0.4.0
|
||||
|
||||
--- CMakeLists.txt.orig 2024-10-08 19:23:45 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -98,8 +98,12 @@ protocolwayland()
|
||||
|
||||
protocolwayland()
|
||||
|
||||
-pkg_check_modules(hyprland_protocols_dep REQUIRED IMPORTED_TARGET hyprland-protocols>=0.4.0)
|
||||
+pkg_check_modules(hyprland_protocols_dep IMPORTED_TARGET hyprland-protocols>=0.4.0)
|
||||
+if(hyprland_protocols_dep_FOUND)
|
||||
pkg_get_variable(HYPRLAND_PROTOCOLS hyprland-protocols pkgdatadir)
|
||||
+else()
|
||||
+set(HYPRLAND_PROTOCOLS "${CMAKE_SOURCE_DIR}/subprojects/hyprland-protocols")
|
||||
+endif()
|
||||
message(STATUS "hyprland-protocols dependency set to ${HYPRLAND_PROTOCOLS}")
|
||||
|
||||
protocolnew("${HYPRLAND_PROTOCOLS}/protocols" "hyprland-ctm-control-v1" true)
|
5
accessibility/hyprsunset/pkg-descr
Normal file
5
accessibility/hyprsunset/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
hyprsunset is a small utility to provide a blue light filter for your
|
||||
system. This method is preferred to screen shaders as it will not be
|
||||
captured via recording / screenshots.
|
||||
|
||||
Requires hyprland >= 0.45.0 for hyprland-ctm-control-v1 protocol.
|
Loading…
Add table
Reference in a new issue