mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
emulators/yuzu: unbreak build after 33d6f548e6
In file included from src/core/debugger/debugger.cpp:8: In file included from /usr/local/include/boost/asio.hpp:69: /usr/local/include/boost/asio/co_composed.hpp:849:13: error: unknown type name 'async_operation' 849 | template <async_operation Op> | ^ /usr/local/include/boost/asio/co_composed.hpp:850:24: error: unknown type name 'Op' 850 | auto await_transform(Op&& op | ^ /usr/local/include/boost/asio/co_composed.hpp:862:17: error: unknown type name 'Op' 862 | awaitable(Op&& op, co_composed_promise& promise | ^ /usr/local/include/boost/asio/co_composed.hpp:915:7: error: unknown type name 'Op' 915 | Op&& op_; | ^ /usr/local/include/boost/asio/co_composed.hpp:869:27: error: unknown type name 'Op' 869 | : op_(static_cast<Op&&>(op)), | ^ /usr/local/include/boost/asio/co_composed.hpp:900:27: error: unknown type name 'Op' 900 | static_cast<Op&&>(static_cast<awaitable*>(p)->op_)( | ^ /usr/local/include/boost/asio/co_composed.hpp:902:55: error: template argument for template type parameter must be a type 902 | Return, completion_signature_of_t<Op>>( | ^~ /usr/local/include/boost/asio/async_result.hpp:939:20: note: template parameter is declared here 939 | template <typename T, typename... Args> | ^ In file included from src/core/debugger/debugger.cpp:8: In file included from /usr/local/include/boost/asio.hpp:69: /usr/local/include/boost/asio/co_composed.hpp:911:37: error: template argument for template type parameter must be a type 911 | completion_signature_of_t<Op>>::on_resume(promise_.result_); | ^~ /usr/local/include/boost/asio/async_result.hpp:939:20: note: template parameter is declared here 939 | template <typename T, typename... Args> | ^ In file included from src/core/debugger/debugger.cpp:8: In file included from /usr/local/include/boost/asio.hpp:69: /usr/local/include/boost/asio/co_composed.hpp:925:34: error: unknown type name 'Op' 925 | return awaitable{static_cast<Op&&>(op), *this | ^ Reported by: pkg-fallout
This commit is contained in:
parent
5f7081f4b8
commit
fbc1b9f699
1 changed files with 13 additions and 0 deletions
13
emulators/yuzu/files/patch-boost-1.86
Normal file
13
emulators/yuzu/files/patch-boost-1.86
Normal file
|
@ -0,0 +1,13 @@
|
|||
https://github.com/boostorg/asio/issues/437
|
||||
https://github.com/boostorg/asio/commit/6ca7c4726e05
|
||||
|
||||
--- CMakeLists.txt.orig 2024-03-01 07:57:00 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -275,6 +275,7 @@ add_definitions(-DBOOST_ASIO_DISABLE_CONCEPTS)
|
||||
|
||||
# boost asio's concept usage doesn't play nicely with some compilers yet.
|
||||
add_definitions(-DBOOST_ASIO_DISABLE_CONCEPTS)
|
||||
+add_definitions(-Dasync_operation=typename) # XXX Remove after Boost 1.87 upgrade
|
||||
if (MSVC)
|
||||
add_compile_options($<$<COMPILE_LANGUAGE:CXX>:/std:c++20>)
|
||||
|
Loading…
Add table
Reference in a new issue