mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
www/cpp-httplib: update 0.19.0 → 0.20.0
Reported by: portscout
This commit is contained in:
parent
debf2aedce
commit
dc341e95ac
3 changed files with 18 additions and 13 deletions
|
@ -1,6 +1,6 @@
|
|||
PORTNAME= cpp-httplib
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.19.0
|
||||
DISTVERSION= 0.20.0
|
||||
CATEGORIES= www devel
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1739614311
|
||||
SHA256 (yhirose-cpp-httplib-v0.19.0_GH0.tar.gz) = c9b9e0524666e1cd088f0874c57c1ce7c0eaa8552f9f4e15c755d5201fc8c608
|
||||
SIZE (yhirose-cpp-httplib-v0.19.0_GH0.tar.gz) = 1331045
|
||||
TIMESTAMP = 1742197116
|
||||
SHA256 (yhirose-cpp-httplib-v0.20.0_GH0.tar.gz) = 18064587e0cc6a0d5d56d619f4cbbcaba47aa5d84d86013abbd45d95c6653866
|
||||
SIZE (yhirose-cpp-httplib-v0.20.0_GH0.tar.gz) = 1408009
|
||||
|
|
|
@ -1,18 +1,12 @@
|
|||
--- test/Makefile.orig 2025-02-14 19:42:29 UTC
|
||||
--- test/Makefile.orig 2025-03-17 01:24:53 UTC
|
||||
+++ test/Makefile
|
||||
@@ -1,5 +1,5 @@ CXX = clang++
|
||||
CXX = clang++
|
||||
-CXXFLAGS = -g -std=c++11 -I. -Wall -Wextra -Wtype-limits -Wconversion -Wshadow # -fno-exceptions -DCPPHTTPLIB_NO_EXCEPTIONS -fsanitize=address
|
||||
+CXXFLAGS += -g -std=c++11 -I. -Wall -Wextra -Wtype-limits -Wconversion -Wshadow # -fno-exceptions -DCPPHTTPLIB_NO_EXCEPTIONS -fsanitize=address
|
||||
|
||||
PREFIX ?= $(shell brew --prefix)
|
||||
|
||||
@@ -35,18 +35,18 @@ test : test.cc include_httplib.cc ../httplib.h Makefil
|
||||
@@ -43,13 +43,13 @@ test : test.cc include_httplib.cc ../httplib.h Makefil
|
||||
./test_proxy
|
||||
|
||||
test : test.cc include_httplib.cc ../httplib.h Makefile cert.pem
|
||||
- $(CXX) -o $@ -I.. $(CXXFLAGS) test.cc include_httplib.cc $(TEST_ARGS)
|
||||
+ $(CXX) -o $@ -I.. $(CXXFLAGS) test.cc include_httplib.cc ${LDFLAGS} $(TEST_ARGS)
|
||||
@file $@
|
||||
|
||||
# Note: The intention of test_split is to verify that it works to compile and
|
||||
# link the split httplib.h, so there is normally no need to execute it.
|
||||
|
@ -22,6 +16,8 @@
|
|||
|
||||
check_abi:
|
||||
@./check-shared-library-abi-compatibility.sh
|
||||
@@ -77,7 +77,7 @@ test_proxy : test_proxy.cc ../httplib.h Makefile cert.
|
||||
fi
|
||||
|
||||
test_proxy : test_proxy.cc ../httplib.h Makefile cert.pem
|
||||
- $(CXX) -o $@ -I.. $(CXXFLAGS) test_proxy.cc $(TEST_ARGS)
|
||||
|
@ -29,3 +25,12 @@
|
|||
|
||||
# Runs server_fuzzer.cc based on value of $(LIB_FUZZING_ENGINE).
|
||||
# Usage: make fuzz_test LIB_FUZZING_ENGINE=/path/to/libFuzzer
|
||||
@@ -86,7 +86,7 @@ server_fuzzer : fuzzing/server_fuzzer.cc ../httplib.h
|
||||
|
||||
# Fuzz target, so that you can choose which $(LIB_FUZZING_ENGINE) to use.
|
||||
server_fuzzer : fuzzing/server_fuzzer.cc ../httplib.h standalone_fuzz_target_runner.o
|
||||
- $(CXX) -o $@ -I.. $(CXXFLAGS) $< $(OPENSSL_SUPPORT) $(ZLIB_SUPPORT) $(BROTLI_SUPPORT) $(LIB_FUZZING_ENGINE) -pthread
|
||||
+ $(CXX) -o $@ -I.. $(CXXFLAGS) $< $(OPENSSL_SUPPORT) $(ZLIB_SUPPORT) $(BROTLI_SUPPORT) $(LIB_FUZZING_ENGINE) ${LDFLAGS} -pthread
|
||||
@file $@
|
||||
|
||||
# Standalone fuzz runner, which just reads inputs from fuzzing/corpus/ dir and
|
||||
|
|
Loading…
Add table
Reference in a new issue