mirror of
https://git.freebsd.org/ports.git
synced 2025-04-30 18:46:38 -04:00
36 lines
1.7 KiB
Text
36 lines
1.7 KiB
Text
--- test/Makefile.orig 2025-03-17 01:24:53 UTC
|
|
+++ test/Makefile
|
|
@@ -43,13 +43,13 @@ test : test.cc include_httplib.cc ../httplib.h Makefil
|
|
./test_proxy
|
|
|
|
test : test.cc include_httplib.cc ../httplib.h Makefile cert.pem
|
|
- $(CXX) -o $@ -I.. $(CXXFLAGS) test.cc include_httplib.cc $(TEST_ARGS)
|
|
+ $(CXX) -o $@ -I.. $(CXXFLAGS) test.cc include_httplib.cc ${LDFLAGS} $(TEST_ARGS)
|
|
@file $@
|
|
|
|
# Note: The intention of test_split is to verify that it works to compile and
|
|
# link the split httplib.h, so there is normally no need to execute it.
|
|
test_split : test.cc ../httplib.h httplib.cc Makefile cert.pem
|
|
- $(CXX) -o $@ $(CXXFLAGS) test.cc httplib.cc $(TEST_ARGS)
|
|
+ $(CXX) -o $@ $(CXXFLAGS) test.cc httplib.cc ${LDFLAGS} $(TEST_ARGS)
|
|
|
|
check_abi:
|
|
@./check-shared-library-abi-compatibility.sh
|
|
@@ -77,7 +77,7 @@ test_proxy : test_proxy.cc ../httplib.h Makefile cert.
|
|
fi
|
|
|
|
test_proxy : test_proxy.cc ../httplib.h Makefile cert.pem
|
|
- $(CXX) -o $@ -I.. $(CXXFLAGS) test_proxy.cc $(TEST_ARGS)
|
|
+ $(CXX) -o $@ -I.. $(CXXFLAGS) test_proxy.cc ${LDFLAGS} $(TEST_ARGS)
|
|
|
|
# Runs server_fuzzer.cc based on value of $(LIB_FUZZING_ENGINE).
|
|
# Usage: make fuzz_test LIB_FUZZING_ENGINE=/path/to/libFuzzer
|
|
@@ -86,7 +86,7 @@ server_fuzzer : fuzzing/server_fuzzer.cc ../httplib.h
|
|
|
|
# Fuzz target, so that you can choose which $(LIB_FUZZING_ENGINE) to use.
|
|
server_fuzzer : fuzzing/server_fuzzer.cc ../httplib.h standalone_fuzz_target_runner.o
|
|
- $(CXX) -o $@ -I.. $(CXXFLAGS) $< $(OPENSSL_SUPPORT) $(ZLIB_SUPPORT) $(BROTLI_SUPPORT) $(LIB_FUZZING_ENGINE) -pthread
|
|
+ $(CXX) -o $@ -I.. $(CXXFLAGS) $< $(OPENSSL_SUPPORT) $(ZLIB_SUPPORT) $(BROTLI_SUPPORT) $(LIB_FUZZING_ENGINE) ${LDFLAGS} -pthread
|
|
@file $@
|
|
|
|
# Standalone fuzz runner, which just reads inputs from fuzzing/corpus/ dir and
|