mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
databases/opendbviewer: Update to 1.2.0
- Switch to DISTVERSION - Drop compiler from USES - Pet Q/A check - Take maintainership ChangeLog: https://github.com/Seek-One/opendbviewer/blob/master/ChangeLog
This commit is contained in:
parent
8dcee581b8
commit
d24b33e19b
6 changed files with 46 additions and 33 deletions
|
@ -1,28 +1,27 @@
|
||||||
PORTNAME= opendbviewer
|
PORTNAME= opendbviewer
|
||||||
PORTVERSION= 1.1.1
|
|
||||||
PORTREVISION= 1
|
|
||||||
DISTVERSIONPREFIX= v
|
DISTVERSIONPREFIX= v
|
||||||
|
DISTVERSION= 1.2.0
|
||||||
CATEGORIES= databases
|
CATEGORIES= databases
|
||||||
|
|
||||||
MAINTAINER= ports@FreeBSD.org
|
MAINTAINER= eduardo@FreeBSD.org
|
||||||
COMMENT= Simple database explorer
|
COMMENT= Simple database explorer
|
||||||
WWW= https://github.com/Jet1oeil/opendbviewer
|
WWW= https://github.com/Jet1oeil/opendbviewer
|
||||||
|
|
||||||
LICENSE= GPLv3
|
LICENSE= GPLv3
|
||||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||||
|
|
||||||
USES= cmake compiler:c++11-lang magick:6,build qt:5
|
USES= cmake gl magick:build qt:5 xorg
|
||||||
USE_GITHUB= yes
|
USE_GITHUB= yes
|
||||||
GH_ACCOUNT= Jet1oeil
|
GH_ACCOUNT= Jet1oeil
|
||||||
USE_QT= core gui network sql sql-sqlite3 testlib widgets \
|
USE_GL= egl
|
||||||
|
USE_QT= core dbus gui network sql sql-sqlite3 testlib widgets \
|
||||||
buildtools:build linguisttools:build qmake:build
|
buildtools:build linguisttools:build qmake:build
|
||||||
|
USE_XORG= x11 xcb
|
||||||
|
|
||||||
OPTIONS_DEFINE= DOCS PGSQL MYSQL
|
OPTIONS_DEFINE= DOCS MYSQL PGSQL
|
||||||
OPTIONS_DEFAULT= PGSQL
|
OPTIONS_DEFAULT= PGSQL
|
||||||
|
|
||||||
PGSQL_USE= QT=sql-pgsql
|
|
||||||
MYSQL_USE= QT=sql-mysql
|
MYSQL_USE= QT=sql-mysql
|
||||||
|
PGSQL_USE= QT=sql-pgsql
|
||||||
CMAKE_ARGS+= -DCMAKE_CXX_STANDARD=11
|
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1563900989
|
TIMESTAMP = 1718958859
|
||||||
SHA256 (Jet1oeil-opendbviewer-v1.1.1_GH0.tar.gz) = 15b90b4a864de10b729b0d4b393aba5d221378399798d77bfa38f6e03e1cf34a
|
SHA256 (Jet1oeil-opendbviewer-v1.2.0_GH0.tar.gz) = ffdc02216d9fae56ea3a74e23e506f1677b2615476cbe743a8f2ef1c67575deb
|
||||||
SIZE (Jet1oeil-opendbviewer-v1.1.1_GH0.tar.gz) = 2082740
|
SIZE (Jet1oeil-opendbviewer-v1.2.0_GH0.tar.gz) = 2114830
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- CMakeLists.txt.orig 2019-07-23 17:03:09 UTC
|
|
||||||
+++ CMakeLists.txt
|
|
||||||
@@ -58,7 +58,7 @@ elseif(APPLE)
|
|
||||||
else(WIN32)
|
|
||||||
set(INSTALL_PATH_BIN "bin/")
|
|
||||||
set(INSTALL_PATH_SHARE "share/${APPLICATION_PACKAGE_NAME}")
|
|
||||||
- set(INSTALL_PATH_DOC "share/${APPLICATION_PACKAGE_NAME}/doc")
|
|
||||||
+ set(INSTALL_PATH_DOC "share/doc/${APPLICATION_PACKAGE_NAME}")
|
|
||||||
set(INSTALL_PATH_APPLICATIONS "share/applications")
|
|
||||||
set(INSTALL_PATH_ICONS "share/icons/")
|
|
||||||
endif(WIN32)
|
|
|
@ -0,0 +1,17 @@
|
||||||
|
--- CMakeModules/ProjectCommonConfig.cmake.orig 2024-06-18 16:17:49 UTC
|
||||||
|
+++ CMakeModules/ProjectCommonConfig.cmake
|
||||||
|
@@ -48,12 +48,12 @@ else()
|
||||||
|
set(INSTALL_PATH_ICONS ".")
|
||||||
|
set(INSTALL_PATH_ETC "../etc")
|
||||||
|
else()
|
||||||
|
- set(INSTALL_PATH_BIN "share/${APPLICATION_PACKAGE_NAME}/bin")
|
||||||
|
+ set(INSTALL_PATH_BIN "bin")
|
||||||
|
set(INSTALL_PATH_SHARE "share/${APPLICATION_PACKAGE_NAME}")
|
||||||
|
set(INSTALL_PATH_LIB "share/${APPLICATION_PACKAGE_NAME}/lib")
|
||||||
|
set(INSTALL_PATH_INCLUDE "share/${APPLICATION_PACKAGE_NAME}/include")
|
||||||
|
set(INSTALL_PATH_PLUGIN "share/${APPLICATION_PACKAGE_NAME}/plugins")
|
||||||
|
- set(INSTALL_PATH_DOC "share/${APPLICATION_PACKAGE_NAME}/doc")
|
||||||
|
+ set(INSTALL_PATH_DOC "share/doc/${APPLICATION_PACKAGE_NAME}")
|
||||||
|
set(INSTALL_PATH_LICENSE "share/${APPLICATION_PACKAGE_NAME}/license")
|
||||||
|
set(INSTALL_PATH_APPLICATIONS "share/applications")
|
||||||
|
set(INSTALL_PATH_ICONS "share/icons")
|
|
@ -1,10 +0,0 @@
|
||||||
--- src/Widget/QDropAreaWidget.cpp.orig 2020-05-21 08:16:02 UTC
|
|
||||||
+++ src/Widget/QDropAreaWidget.cpp
|
|
||||||
@@ -6,6 +6,7 @@
|
|
||||||
*/
|
|
||||||
|
|
||||||
#include <QPainter>
|
|
||||||
+#include <QPainterPath>
|
|
||||||
|
|
||||||
#include "QDropAreaWidget.h"
|
|
||||||
|
|
|
@ -10,14 +10,26 @@ share/icons/hicolor/32x32/apps/opendbviewer.png
|
||||||
share/icons/hicolor/48x48/apps/opendbviewer.png
|
share/icons/hicolor/48x48/apps/opendbviewer.png
|
||||||
share/icons/hicolor/64x64/apps/opendbviewer.png
|
share/icons/hicolor/64x64/apps/opendbviewer.png
|
||||||
share/icons/opendbviewer.png
|
share/icons/opendbviewer.png
|
||||||
|
%%DATADIR%%/icons_themes/app_default/actions/112x70/database-add.png
|
||||||
|
%%DATADIR%%/icons_themes/app_default/actions/112x70/database.png
|
||||||
|
%%DATADIR%%/icons_themes/app_default/actions/112x70/folder.png
|
||||||
|
%%DATADIR%%/icons_themes/app_default/actions/112x70/history.png
|
||||||
%%DATADIR%%/icons_themes/app_default/actions/128/database-add.png
|
%%DATADIR%%/icons_themes/app_default/actions/128/database-add.png
|
||||||
%%DATADIR%%/icons_themes/app_default/actions/128/database.png
|
%%DATADIR%%/icons_themes/app_default/actions/128/database.png
|
||||||
%%DATADIR%%/icons_themes/app_default/actions/128/folder.png
|
%%DATADIR%%/icons_themes/app_default/actions/128/folder.png
|
||||||
%%DATADIR%%/icons_themes/app_default/actions/128/history.png
|
%%DATADIR%%/icons_themes/app_default/actions/128/history.png
|
||||||
|
%%DATADIR%%/icons_themes/app_default/actions/144x90/database-add.png
|
||||||
|
%%DATADIR%%/icons_themes/app_default/actions/144x90/database.png
|
||||||
|
%%DATADIR%%/icons_themes/app_default/actions/144x90/folder.png
|
||||||
|
%%DATADIR%%/icons_themes/app_default/actions/144x90/history.png
|
||||||
%%DATADIR%%/icons_themes/app_default/actions/16/database-add.png
|
%%DATADIR%%/icons_themes/app_default/actions/16/database-add.png
|
||||||
%%DATADIR%%/icons_themes/app_default/actions/16/database.png
|
%%DATADIR%%/icons_themes/app_default/actions/16/database.png
|
||||||
%%DATADIR%%/icons_themes/app_default/actions/16/folder.png
|
%%DATADIR%%/icons_themes/app_default/actions/16/folder.png
|
||||||
%%DATADIR%%/icons_themes/app_default/actions/16/history.png
|
%%DATADIR%%/icons_themes/app_default/actions/16/history.png
|
||||||
|
%%DATADIR%%/icons_themes/app_default/actions/192x120/database-add.png
|
||||||
|
%%DATADIR%%/icons_themes/app_default/actions/192x120/database.png
|
||||||
|
%%DATADIR%%/icons_themes/app_default/actions/192x120/folder.png
|
||||||
|
%%DATADIR%%/icons_themes/app_default/actions/192x120/history.png
|
||||||
%%DATADIR%%/icons_themes/app_default/actions/22/database-add.png
|
%%DATADIR%%/icons_themes/app_default/actions/22/database-add.png
|
||||||
%%DATADIR%%/icons_themes/app_default/actions/22/database.png
|
%%DATADIR%%/icons_themes/app_default/actions/22/database.png
|
||||||
%%DATADIR%%/icons_themes/app_default/actions/22/folder.png
|
%%DATADIR%%/icons_themes/app_default/actions/22/folder.png
|
||||||
|
@ -38,5 +50,11 @@ share/icons/opendbviewer.png
|
||||||
%%DATADIR%%/icons_themes/app_default/actions/64/database.png
|
%%DATADIR%%/icons_themes/app_default/actions/64/database.png
|
||||||
%%DATADIR%%/icons_themes/app_default/actions/64/folder.png
|
%%DATADIR%%/icons_themes/app_default/actions/64/folder.png
|
||||||
%%DATADIR%%/icons_themes/app_default/actions/64/history.png
|
%%DATADIR%%/icons_themes/app_default/actions/64/history.png
|
||||||
|
%%DATADIR%%/icons_themes/app_default/actions/svg/database-add.svg
|
||||||
|
%%DATADIR%%/icons_themes/app_default/actions/svg/database.svg
|
||||||
|
%%DATADIR%%/icons_themes/app_default/actions/svg/folder.svg
|
||||||
|
%%DATADIR%%/icons_themes/app_default/actions/svg/history.svg
|
||||||
%%DATADIR%%/icons_themes/app_default/author
|
%%DATADIR%%/icons_themes/app_default/author
|
||||||
%%DATADIR%%/icons_themes/app_default/index.theme
|
%%DATADIR%%/icons_themes/app_default/index.theme
|
||||||
|
%%DATADIR%%/plugins/xcbglintegrations/libqxcb-egl-integration.so
|
||||||
|
%%DATADIR%%/plugins/xcbglintegrations/libqxcb-glx-integration.so
|
||||||
|
|
Loading…
Add table
Reference in a new issue