mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
audio/umurmur: Switch to CMake and OpenSSL
* Removes autoreconf gmake libtool dependencies * Switch to OpenSSL instead of Mbed TLS * Fix version reporting within application Reviewed by: bofh (via matrix)
This commit is contained in:
parent
dfc35ba82f
commit
ba156e3b60
3 changed files with 11 additions and 17 deletions
|
@ -1,6 +1,7 @@
|
|||
PORTNAME= umurmur
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.3.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= audio net
|
||||
|
||||
MAINTAINER= bofh@FreeBSD.org
|
||||
|
@ -11,21 +12,17 @@ LICENSE= BSD3CLAUSE
|
|||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
LIB_DEPENDS= libconfig.so:devel/libconfig \
|
||||
libmbedtls.so:security/mbedtls3 \
|
||||
libprotobuf-c.so:devel/protobuf-c
|
||||
|
||||
USES= autoreconf gmake libtool localbase
|
||||
USES= cmake ssl
|
||||
USE_GITHUB= yes
|
||||
USE_RC_SUBR= umurmur
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-ssl=mbedtls
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/configure.ac
|
||||
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/src/conf.c
|
||||
@${REINPLACE_CMD} \
|
||||
-e 's|/etc/|${PREFIX}/etc/|g' ${WRKSRC}/umurmur.conf.example
|
||||
@${REINPLACE_CMD} -e 's|0.3.0|0.3.1|g' ${WRKSRC}/src/version.h
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/umurmur
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- configure.ac.orig 2021-03-21 20:49:04 UTC
|
||||
+++ configure.ac
|
||||
@@ -118,7 +118,7 @@ AS_IF([test "x$enable_shmapi" != xno],
|
||||
AM_CONDITIONAL(USE_SHAREDMEMORY_API, false)
|
||||
])
|
||||
|
||||
-AC_DEFINE([DEFAULT_CONFIG], ["/etc/umurmur.conf"], [Default config])
|
||||
+AC_DEFINE([DEFAULT_CONFIG], ["%%PREFIX%%/etc/umurmur.conf"], [Default config])
|
||||
|
||||
# Checks for header files.
|
||||
AC_FUNC_ALLOCA
|
8
audio/umurmur/files/patch-src_CMakeLists.txt
Normal file
8
audio/umurmur/files/patch-src_CMakeLists.txt
Normal file
|
@ -0,0 +1,8 @@
|
|||
--- src/CMakeLists.txt.orig 2025-04-18 15:18:32 UTC
|
||||
+++ src/CMakeLists.txt
|
||||
@@ -48,4 +48,4 @@ target_link_libraries(${PROJECT_NAME}
|
||||
${LIBRT}
|
||||
${CRYPTO_LIBRARIES})
|
||||
|
||||
-install(TARGETS ${PROJECT_NAME} RUNTIME DESTINATION "sbin")
|
||||
+install(TARGETS ${PROJECT_NAME} RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
|
Loading…
Add table
Reference in a new issue