audio/faust: update 2.75.7 → 2.77.3

This commit is contained in:
Yuri Victorovich 2025-01-09 21:24:48 -08:00
parent 699cd623b6
commit b79128146e
6 changed files with 48 additions and 18 deletions

View file

@ -1,10 +1,11 @@
PORTNAME= faust PORTNAME= faust
DISTVERSION= 2.75.7 DISTVERSION= 2.77.3
CATEGORIES= audio devel CATEGORIES= audio devel
MAINTAINER= yuri@FreeBSD.org MAINTAINER= yuri@FreeBSD.org
COMMENT= Functional programming language for realtime audio signal processing COMMENT= Functional programming language for realtime audio signal processing
WWW= https://faust.grame.fr/ WWW= https://faust.grame.fr/ \
https://github.com/grame-cncm/faust
LICENSE= GPLv2 LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING.txt LICENSE_FILE= ${WRKSRC}/COPYING.txt
@ -15,17 +16,21 @@ LIB_DEPENDS= libLLVM-${LLVM_VERSION}.so:devel/llvm${LLVM_VERSION} \
libzstd.so:archivers/zstd libzstd.so:archivers/zstd
RUN_DEPENDS= bash:shells/bash RUN_DEPENDS= bash:shells/bash
USES= compiler:c++14-lang cmake localbase:ldflags llvm:min=15,lib ncurses python pkgconfig shebangfix # llvm: versions <11 lacked dump() function(s) that cause unresolved symbols in libfaust.so USES= compiler:c++17-lang cmake localbase:ldflags llvm:min=${LLVM_VER},lib ncurses python pkgconfig shebangfix # llvm: versions <11 lacked dump() function(s) that cause unresolved symbols in libfaust.so
USE_LDCONFIG= yes USE_LDCONFIG= yes
USE_CXXSTD= c++17
USE_GITHUB= yes USE_GITHUB= yes
GH_ACCOUNT= grame-cncm GH_ACCOUNT= grame-cncm
GH_TUPLE= \ GH_TUPLE= \
grame-cncm:faustlibraries:3e74c39:grame_cncm_faustlibraries/libraries \ grame-cncm:faustlibraries:ef8dbf7:grame_cncm_faustlibraries/libraries \
ccrma:faust2ck:db879cb:faust2ck/tools/faust2ck \ ccrma:faust2ck:db879cb:faust2ck/tools/faust2ck \
shakfu:py2max:3aaa8ca:py2max/architecture/max-msp/py2max \ shakfu:py2max:3aaa8ca:py2max/architecture/max-msp/py2max \
yixuan:spectra:8c7242e:spectra/tools/physicalModeling/mesh2faust/spectra yixuan:spectra:8c7242e:spectra/tools/physicalModeling/mesh2faust/spectra
#LLVM_VER= 15 # not c++17 by default
LLVM_VER= 19
SHEBANG_FILES= tools/faust-config \ SHEBANG_FILES= tools/faust-config \
tools/faust2appls/* \ tools/faust2appls/* \
tools/benchmark/faustbench \ tools/benchmark/faustbench \
@ -86,7 +91,10 @@ post-install-HIGHLIGHT-on:
do-test: do-test:
@${CP} ${FILESDIR}/example-freeverb_demo.dsp ${TEST_WRKSRC} @${CP} ${FILESDIR}/example-freeverb_demo.dsp ${TEST_WRKSRC}
@cd ${TEST_WRKSRC} && \ @cd ${TEST_WRKSRC} && \
${SETENV} ${TEST_ENV} faust2jaqt example-freeverb_demo.dsp && \ ${SETENV} ${MAKE_ENV} ${TEST_ENV} faust2jaqt example-freeverb_demo.dsp && \
${SETENV} ${TEST_ENV} ./example-freeverb_demo ${SETENV} ${TEST_ENV} ./example-freeverb_demo
# test fails to build with Qt6 because of wrong C++11 option written into Makefile: https://github.com/grame-cncm/faust/issues/1109
# once this is corrected, test builds and works fine
.include <bsd.port.mk> .include <bsd.port.mk>

View file

@ -1,8 +1,8 @@
TIMESTAMP = 1726895188 TIMESTAMP = 1736467606
SHA256 (grame-cncm-faust-2.75.7_GH0.tar.gz) = 7ef21d3e5af0113a7a872efd5886294dbd0085b2dc7c6f0b42e417dbf4490193 SHA256 (grame-cncm-faust-2.77.3_GH0.tar.gz) = 41950a896ce12147fcacab3edf58232e308e9beaf687dce3f9460c16b81c44b3
SIZE (grame-cncm-faust-2.75.7_GH0.tar.gz) = 70182927 SIZE (grame-cncm-faust-2.77.3_GH0.tar.gz) = 70946118
SHA256 (grame-cncm-faustlibraries-3e74c39_GH0.tar.gz) = 1dd8b9ad189e1d4d892c4c5d8df7a4ba8636c175e5d732f2d7aa8221744bf618 SHA256 (grame-cncm-faustlibraries-ef8dbf7_GH0.tar.gz) = dc9242161d82cb7ee4f3272984ab5481719eff0ca9e5751e094a1c322b569446
SIZE (grame-cncm-faustlibraries-3e74c39_GH0.tar.gz) = 7893902 SIZE (grame-cncm-faustlibraries-ef8dbf7_GH0.tar.gz) = 7910998
SHA256 (ccrma-faust2ck-db879cb_GH0.tar.gz) = 78a4ca3deef0940122c68cb4872b9423778177ddf02d113f8f01d0e37351f816 SHA256 (ccrma-faust2ck-db879cb_GH0.tar.gz) = 78a4ca3deef0940122c68cb4872b9423778177ddf02d113f8f01d0e37351f816
SIZE (ccrma-faust2ck-db879cb_GH0.tar.gz) = 328939 SIZE (ccrma-faust2ck-db879cb_GH0.tar.gz) = 328939
SHA256 (shakfu-py2max-3aaa8ca_GH0.tar.gz) = cfa77756965481a65baa265bef850b2dd0d557622ead2d895d557187d7e78bf7 SHA256 (shakfu-py2max-3aaa8ca_GH0.tar.gz) = cfa77756965481a65baa265bef850b2dd0d557622ead2d895d557187d7e78bf7

View file

@ -1,4 +1,4 @@
--- architecture/faust/dsp/dsp-adapter.h.orig 2021-02-16 21:19:00 UTC --- architecture/faust/dsp/dsp-adapter.h.orig 2024-12-26 11:33:55 UTC
+++ architecture/faust/dsp/dsp-adapter.h +++ architecture/faust/dsp/dsp-adapter.h
@@ -26,7 +26,11 @@ @@ -26,7 +26,11 @@
#define __dsp_adapter__ #define __dsp_adapter__
@ -12,4 +12,4 @@
+# endif +# endif
#endif #endif
#include <string.h> #include <string.h>
#include <iostream> #include <cmath>

View file

@ -1,6 +1,6 @@
--- build/CMakeLists.txt.orig 2021-01-14 11:18:56 UTC --- build/CMakeLists.txt.orig 2024-12-26 11:33:55 UTC
+++ build/CMakeLists.txt +++ build/CMakeLists.txt
@@ -53,7 +53,7 @@ endif() @@ -50,7 +50,7 @@ endif()
#################################### ####################################
# source and headers files # source and headers files
@ -9,17 +9,17 @@
file (GLOB HH ${SRCDIR}/*.hh ${SRCDIR}/*/*.hh ${SRCDIR}/generator/fir/*.hh) file (GLOB HH ${SRCDIR}/*.hh ${SRCDIR}/*/*.hh ${SRCDIR}/generator/fir/*.hh)
#################################### ####################################
@@ -352,13 +352,15 @@ install ( @@ -439,13 +439,15 @@ install (
#################################### ####################################
# install examples # install examples
+if (FREEBSD_INSTALL_EXAMPLES) +if (FREEBSD_INSTALL_EXAMPLES)
install ( install (
- DIRECTORY ${ROOT}/examples DESTINATION ${CMAKE_INSTALL_PREFIX}//share/faust - DIRECTORY ${ROOT}/examples DESTINATION ${CMAKE_INSTALL_PREFIX}//share/faust
+ DIRECTORY ${ROOT}/examples DESTINATION share/examples/faust # TODO flatten "examples" from the hierarchy + DIRECTORY ${ROOT}/examples DESTINATION share/examples/faust
FILE_PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ FILE_PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ
DIRECTORY_PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE DIRECTORY_PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE
GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
PATTERN ".DS_Store" EXCLUDE PATTERN ".DS_Store" EXCLUDE
) )
+endif() +endif()

View file

@ -0,0 +1,15 @@
--- compiler/errors/exception.hh.orig 2025-01-10 00:10:01 UTC
+++ compiler/errors/exception.hh
@@ -25,8 +25,11 @@ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, U
#include <stdexcept>
#ifndef WIN32
#include <unistd.h>
+# if !defined(__FreeBSD__)
#include <alloca.h>
-#else
+# else
+#include <stdlib.h>
+# endif
// #include <io.h>
#endif

View file

@ -45,6 +45,7 @@ bin/faust2juce
bin/faust2ladspa bin/faust2ladspa
bin/faust2linuxunity bin/faust2linuxunity
bin/faust2lv2 bin/faust2lv2
bin/faust2magtk
bin/faust2mathdoc bin/faust2mathdoc
bin/faust2mathviewer bin/faust2mathviewer
bin/faust2max6 bin/faust2max6
@ -117,6 +118,7 @@ include/faust/audio/esp32-dsp.h
include/faust/audio/fpe.h include/faust/audio/fpe.h
include/faust/audio/jack-dsp.h include/faust/audio/jack-dsp.h
include/faust/audio/juce-dsp.h include/faust/audio/juce-dsp.h
include/faust/audio/miniaudio-dsp.h
include/faust/audio/netjack-dsp.h include/faust/audio/netjack-dsp.h
include/faust/audio/oboe-dsp.h include/faust/audio/oboe-dsp.h
include/faust/audio/ofaudio-dsp.h include/faust/audio/ofaudio-dsp.h
@ -167,6 +169,7 @@ include/faust/dsp/poly-wasm-dsp.h
include/faust/dsp/proxy-dsp.h include/faust/dsp/proxy-dsp.h
include/faust/dsp/proxy-osc-dsp.h include/faust/dsp/proxy-osc-dsp.h
include/faust/dsp/rnbo-dsp.h include/faust/dsp/rnbo-dsp.h
include/faust/dsp/signal-dsp.h
include/faust/dsp/sound-player.h include/faust/dsp/sound-player.h
include/faust/dsp/timed-dsp.h include/faust/dsp/timed-dsp.h
include/faust/dsp/timed-dsp.h.orig include/faust/dsp/timed-dsp.h.orig
@ -204,6 +207,7 @@ include/faust/gui/MapUI.h
include/faust/gui/MemoryReader.h include/faust/gui/MemoryReader.h
include/faust/gui/MetaDataUI.h include/faust/gui/MetaDataUI.h
include/faust/gui/MidiUI.h include/faust/gui/MidiUI.h
include/faust/gui/MiniaudioReader.h
include/faust/gui/OCVUI.h include/faust/gui/OCVUI.h
include/faust/gui/OSCControler.h include/faust/gui/OSCControler.h
include/faust/gui/OSCIO.h include/faust/gui/OSCIO.h
@ -250,6 +254,7 @@ include/faust/midi/juce-midi.h
include/faust/midi/midi.h include/faust/midi/midi.h
include/faust/midi/rt-midi.h include/faust/midi/rt-midi.h
include/faust/midi/teensy-midi.h include/faust/midi/teensy-midi.h
include/faust/miniaudio.h
include/faust/misc.h include/faust/misc.h
include/faust/osc/FaustFactory.h include/faust/osc/FaustFactory.h
include/faust/osc/FaustNode.h include/faust/osc/FaustNode.h
@ -271,7 +276,7 @@ lib/ios-libsndfile.a
lib/libOSCFaust.a lib/libOSCFaust.a
lib/libfaust.so lib/libfaust.so
lib/libfaust.so.2 lib/libfaust.so.2
lib/libfaust.so.2.75.7 lib/libfaust.so.2.77.3
%%HIGHLIGHT%%share/apps/katepart/syntax/faust.xml %%HIGHLIGHT%%share/apps/katepart/syntax/faust.xml
%%DATADIR%%/AU/AUPublic/AUBase/AUBase.cpp %%DATADIR%%/AU/AUPublic/AUBase/AUBase.cpp
%%DATADIR%%/AU/AUPublic/AUBase/AUBase.h %%DATADIR%%/AU/AUPublic/AUBase/AUBase.h
@ -676,9 +681,11 @@ lib/libfaust.so.2.75.7
%%DATADIR%%/julia/portaudio-gtk.jl %%DATADIR%%/julia/portaudio-gtk.jl
%%DATADIR%%/ladspa.cpp %%DATADIR%%/ladspa.cpp
%%DATADIR%%/latexheader.tex %%DATADIR%%/latexheader.tex
%%DATADIR%%/linearalgebra.lib
%%DATADIR%%/lv2.cpp %%DATADIR%%/lv2.cpp
%%DATADIR%%/lv2qtgui.h %%DATADIR%%/lv2qtgui.h
%%DATADIR%%/lv2ui.cpp %%DATADIR%%/lv2ui.cpp
%%DATADIR%%/ma-gtk.cpp
%%DATADIR%%/math.lib %%DATADIR%%/math.lib
%%DATADIR%%/mathdoctexts-de.txt %%DATADIR%%/mathdoctexts-de.txt
%%DATADIR%%/mathdoctexts-default.txt %%DATADIR%%/mathdoctexts-default.txt