mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
28 lines
1.2 KiB
Text
28 lines
1.2 KiB
Text
--- build/CMakeLists.txt.orig 2024-12-26 11:33:55 UTC
|
|
+++ build/CMakeLists.txt
|
|
@@ -50,7 +50,7 @@ endif()
|
|
|
|
####################################
|
|
# source and headers files
|
|
-file (GLOB SRC ${SRCDIR}/*.cpp ${SRCDIR}/*/*.cpp ${SRCDIR}/draw/*/*.cpp ${SRCDIR}/generator/fir/*.cpp)
|
|
+file (GLOB SRC ${SRCDIR}/*.cpp ${SRCDIR}/*/*.cpp ${SRCDIR}/draw/*/*.cpp ${SRCDIR}/generator/fir/*.cpp ${SRCDIR}/generator/cpp/*.cpp ${SRCDIR}/generator/llvm/*.cpp)
|
|
file (GLOB HH ${SRCDIR}/*.hh ${SRCDIR}/*/*.hh ${SRCDIR}/generator/fir/*.hh)
|
|
|
|
####################################
|
|
@@ -439,13 +439,15 @@ install (
|
|
|
|
####################################
|
|
# install examples
|
|
+if (FREEBSD_INSTALL_EXAMPLES)
|
|
install (
|
|
- DIRECTORY ${ROOT}/examples DESTINATION ${CMAKE_INSTALL_PREFIX}//share/faust
|
|
+ DIRECTORY ${ROOT}/examples DESTINATION share/examples/faust
|
|
FILE_PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ
|
|
DIRECTORY_PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE
|
|
GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
|
|
PATTERN ".DS_Store" EXCLUDE
|
|
)
|
|
+endif()
|
|
|
|
# install faust libraries
|
|
file (GLOB FAUSTDSPLIBS ${ROOT}/libraries/*.lib ${ROOT}/libraries/old/*.lib)
|