mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
sysutils/triton: update 0.9 → 0.9-597
This commit is contained in:
parent
80af6e6a6c
commit
87391fb244
4 changed files with 16 additions and 18 deletions
|
@ -1,7 +1,7 @@
|
||||||
PORTNAME= triton
|
PORTNAME= triton
|
||||||
DISTVERSIONPREFIX= v
|
DISTVERSIONPREFIX= v
|
||||||
DISTVERSION= 0.9
|
DISTVERSION= 0.9-597
|
||||||
PORTREVISION= 1
|
DISTVERSIONSUFFIX= -gafb28564
|
||||||
CATEGORIES= sysutils
|
CATEGORIES= sysutils
|
||||||
|
|
||||||
MAINTAINER= yuri@FreeBSD.org
|
MAINTAINER= yuri@FreeBSD.org
|
||||||
|
@ -18,7 +18,7 @@ BUILD_DEPENDS= boost-libs>0:devel/boost-libs
|
||||||
LIB_DEPENDS= libcapstone.so:devel/capstone4 \
|
LIB_DEPENDS= libcapstone.so:devel/capstone4 \
|
||||||
libz3.so:math/z3
|
libz3.so:math/z3
|
||||||
|
|
||||||
USES= cmake compiler:c++14-lang shebangfix
|
USES= cmake:testing compiler:c++17-lang shebangfix
|
||||||
USE_LDCONFIG= yes
|
USE_LDCONFIG= yes
|
||||||
|
|
||||||
SHEBANG_GLOB= *.py
|
SHEBANG_GLOB= *.py
|
||||||
|
@ -27,6 +27,8 @@ USE_GITHUB= yes
|
||||||
GH_ACCOUNT= JonathanSalwan
|
GH_ACCOUNT= JonathanSalwan
|
||||||
GH_PROJECT= Triton
|
GH_PROJECT= Triton
|
||||||
|
|
||||||
|
CMAKE_TESTING_ON= ENABLE_TEST
|
||||||
|
|
||||||
OPTIONS_DEFINE= PYTHON
|
OPTIONS_DEFINE= PYTHON
|
||||||
OPTIONS_DEFAULT= PYTHON
|
OPTIONS_DEFAULT= PYTHON
|
||||||
OPTIONS_SUB= yes
|
OPTIONS_SUB= yes
|
||||||
|
@ -34,6 +36,8 @@ OPTIONS_SUB= yes
|
||||||
PYTHON_USES= python
|
PYTHON_USES= python
|
||||||
PYTHON_USES_OFF= python:build
|
PYTHON_USES_OFF= python:build
|
||||||
PYTHON_CMAKE_BOOL= PYTHON_BINDINGS
|
PYTHON_CMAKE_BOOL= PYTHON_BINDINGS
|
||||||
|
PYTHON_CMAKE_ON= -DPYTHON_EXECUTABLE=${PYTHON_CMD}
|
||||||
|
PYTHON_TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lief>0:devel/py-lief@${PY_FLAVOR}
|
||||||
|
|
||||||
post-install-PYTHON-on:
|
post-install-PYTHON-on:
|
||||||
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/triton.so
|
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/triton.so
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1647827649
|
TIMESTAMP = 1717601879
|
||||||
SHA256 (JonathanSalwan-Triton-v0.9_GH0.tar.gz) = fea82146a6952c8cf6335e5c2ee68581729611e7b4aa853b09e5a5459bc643f7
|
SHA256 (JonathanSalwan-Triton-v0.9-597-gafb28564_GH0.tar.gz) = 6f058ce6be7c54d9a6ad51b13af3e040000336e66571492500db16c097877d80
|
||||||
SIZE (JonathanSalwan-Triton-v0.9_GH0.tar.gz) = 19433967
|
SIZE (JonathanSalwan-Triton-v0.9-597-gafb28564_GH0.tar.gz) = 40696298
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- src/CMakeLists.txt.orig 2020-02-22 23:42:18 UTC
|
|
||||||
+++ src/CMakeLists.txt
|
|
||||||
@@ -4,7 +4,7 @@ add_subdirectory(tracer)
|
|
||||||
if(NOT ${CMAKE_SYSTEM_NAME} MATCHES "Windows")
|
|
||||||
# Disable exemples for windows as linkage doesn't work. Exported function should
|
|
||||||
# be marked as exported on windows.
|
|
||||||
- add_subdirectory(examples)
|
|
||||||
+ #add_subdirectory(examples)
|
|
||||||
else()
|
|
||||||
enable_testing()
|
|
||||||
add_test(DummyTest echo "Windows is awesome")
|
|
|
@ -2,7 +2,6 @@ include/triton/aarch64.spec
|
||||||
include/triton/aarch64Cpu.hpp
|
include/triton/aarch64Cpu.hpp
|
||||||
include/triton/aarch64Semantics.hpp
|
include/triton/aarch64Semantics.hpp
|
||||||
include/triton/aarch64Specifications.hpp
|
include/triton/aarch64Specifications.hpp
|
||||||
include/triton/api.hpp
|
|
||||||
include/triton/archEnums.hpp
|
include/triton/archEnums.hpp
|
||||||
include/triton/architecture.hpp
|
include/triton/architecture.hpp
|
||||||
include/triton/arm32.spec
|
include/triton/arm32.spec
|
||||||
|
@ -13,16 +12,19 @@ include/triton/armOperandProperties.hpp
|
||||||
include/triton/ast.hpp
|
include/triton/ast.hpp
|
||||||
include/triton/astContext.hpp
|
include/triton/astContext.hpp
|
||||||
include/triton/astEnums.hpp
|
include/triton/astEnums.hpp
|
||||||
|
include/triton/astPcodeRepresentation.hpp
|
||||||
include/triton/astPythonRepresentation.hpp
|
include/triton/astPythonRepresentation.hpp
|
||||||
include/triton/astRepresentation.hpp
|
include/triton/astRepresentation.hpp
|
||||||
include/triton/astRepresentationInterface.hpp
|
include/triton/astRepresentationInterface.hpp
|
||||||
include/triton/astSmtRepresentation.hpp
|
include/triton/astSmtRepresentation.hpp
|
||||||
|
include/triton/basicBlock.hpp
|
||||||
include/triton/bitsVector.hpp
|
include/triton/bitsVector.hpp
|
||||||
include/triton/bitwuzlaSolver.hpp
|
include/triton/bitwuzlaSolver.hpp
|
||||||
include/triton/callbacks.hpp
|
include/triton/callbacks.hpp
|
||||||
include/triton/callbacksEnums.hpp
|
include/triton/callbacksEnums.hpp
|
||||||
include/triton/comparableFunctor.hpp
|
include/triton/comparableFunctor.hpp
|
||||||
include/triton/config.hpp
|
include/triton/config.hpp
|
||||||
|
include/triton/context.hpp
|
||||||
include/triton/coreUtils.hpp
|
include/triton/coreUtils.hpp
|
||||||
include/triton/cpuInterface.hpp
|
include/triton/cpuInterface.hpp
|
||||||
include/triton/cpuSize.hpp
|
include/triton/cpuSize.hpp
|
||||||
|
@ -33,6 +35,7 @@ include/triton/immediate.hpp
|
||||||
include/triton/instruction.hpp
|
include/triton/instruction.hpp
|
||||||
include/triton/irBuilder.hpp
|
include/triton/irBuilder.hpp
|
||||||
include/triton/liftingEngine.hpp
|
include/triton/liftingEngine.hpp
|
||||||
|
include/triton/liftingToDot.hpp
|
||||||
include/triton/liftingToLLVM.hpp
|
include/triton/liftingToLLVM.hpp
|
||||||
include/triton/liftingToPython.hpp
|
include/triton/liftingToPython.hpp
|
||||||
include/triton/liftingToSMT.hpp
|
include/triton/liftingToSMT.hpp
|
||||||
|
@ -51,6 +54,7 @@ include/triton/solverEngine.hpp
|
||||||
include/triton/solverEnums.hpp
|
include/triton/solverEnums.hpp
|
||||||
include/triton/solverInterface.hpp
|
include/triton/solverInterface.hpp
|
||||||
include/triton/solverModel.hpp
|
include/triton/solverModel.hpp
|
||||||
|
include/triton/stubs.hpp
|
||||||
include/triton/symbolicEngine.hpp
|
include/triton/symbolicEngine.hpp
|
||||||
include/triton/symbolicEnums.hpp
|
include/triton/symbolicEnums.hpp
|
||||||
include/triton/symbolicExpression.hpp
|
include/triton/symbolicExpression.hpp
|
||||||
|
@ -63,6 +67,7 @@ include/triton/tritonToBitwuzla.hpp
|
||||||
include/triton/tritonToLLVM.hpp
|
include/triton/tritonToLLVM.hpp
|
||||||
include/triton/tritonToZ3.hpp
|
include/triton/tritonToZ3.hpp
|
||||||
include/triton/tritonTypes.hpp
|
include/triton/tritonTypes.hpp
|
||||||
|
include/triton/uintwide_t.h
|
||||||
include/triton/version.hpp
|
include/triton/version.hpp
|
||||||
include/triton/x86.spec
|
include/triton/x86.spec
|
||||||
include/triton/x8664Cpu.hpp
|
include/triton/x8664Cpu.hpp
|
||||||
|
|
Loading…
Add table
Reference in a new issue