mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
emulators/citra: fix build after devel/boost-libs update
- also roll a post-patch item into an existing patch file PR: 284855
This commit is contained in:
parent
bbd0c30538
commit
864d4c7e6d
3 changed files with 22 additions and 5 deletions
|
@ -1,6 +1,6 @@
|
||||||
PORTNAME= citra
|
PORTNAME= citra
|
||||||
PORTVERSION= s20220902
|
PORTVERSION= s20220902
|
||||||
PORTREVISION?= 3
|
PORTREVISION?= 4
|
||||||
CATEGORIES= emulators
|
CATEGORIES= emulators
|
||||||
.if make(makesum)
|
.if make(makesum)
|
||||||
MASTER_SITES= https://api.citra-emu.org/gamedb/?dummy=/:gamedb
|
MASTER_SITES= https://api.citra-emu.org/gamedb/?dummy=/:gamedb
|
||||||
|
@ -95,8 +95,6 @@ QT5_PLIST_FILES=bin/${PORTNAME}-qt \
|
||||||
.include <bsd.port.pre.mk>
|
.include <bsd.port.pre.mk>
|
||||||
|
|
||||||
post-patch:
|
post-patch:
|
||||||
@${REINPLACE_CMD} -e '/check_submodules_present()/d' \
|
|
||||||
${WRKSRC}/CMakeLists.txt
|
|
||||||
@${REINPLACE_CMD} -e 's/@GIT_BRANCH@/master/' \
|
@${REINPLACE_CMD} -e 's/@GIT_BRANCH@/master/' \
|
||||||
-e 's/@GIT_DESC@/${GH_TAGNAME}/' \
|
-e 's/@GIT_DESC@/${GH_TAGNAME}/' \
|
||||||
${WRKSRC}/src/common/scm_rev.cpp.in
|
${WRKSRC}/src/common/scm_rev.cpp.in
|
||||||
|
|
|
@ -1,8 +1,16 @@
|
||||||
citra-qt currently needs SDL for audio and input
|
citra-qt currently needs SDL for audio and input
|
||||||
|
|
||||||
--- CMakeLists.txt.orig 2017-08-09 15:54:29 UTC
|
--- CMakeLists.txt.orig 2022-09-01 18:37:46 UTC
|
||||||
+++ CMakeLists.txt
|
+++ CMakeLists.txt
|
||||||
@@ -207,15 +207,15 @@ if (ENABLE_SDL2)
|
@@ -71,7 +71,6 @@ endfunction()
|
||||||
|
endif()
|
||||||
|
endforeach()
|
||||||
|
endfunction()
|
||||||
|
-check_submodules_present()
|
||||||
|
|
||||||
|
configure_file(${PROJECT_SOURCE_DIR}/dist/compatibility_list/compatibility_list.qrc
|
||||||
|
${PROJECT_BINARY_DIR}/dist/compatibility_list/compatibility_list.qrc
|
||||||
|
@@ -168,15 +167,15 @@ if (ENABLE_SDL2)
|
||||||
else()
|
else()
|
||||||
find_package(SDL2 REQUIRED)
|
find_package(SDL2 REQUIRED)
|
||||||
endif()
|
endif()
|
||||||
|
|
11
emulators/citra/files/patch-src_input__common_udp_client.cpp
Normal file
11
emulators/citra/files/patch-src_input__common_udp_client.cpp
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- src/input_common/udp/client.cpp.orig 2025-02-16 22:55:21 UTC
|
||||||
|
+++ src/input_common/udp/client.cpp
|
||||||
|
@@ -109,7 +109,7 @@ class Socket { (private)
|
||||||
|
}
|
||||||
|
|
||||||
|
SocketCallback callback;
|
||||||
|
- boost::asio::io_service io_service;
|
||||||
|
+ boost::asio::io_context io_service;
|
||||||
|
boost::asio::basic_waitable_timer<clock> timer;
|
||||||
|
udp::socket socket;
|
||||||
|
|
Loading…
Add table
Reference in a new issue