ports/emulators/citra/files/patch-CMakeLists.txt
Kevin Reinholz 864d4c7e6d emulators/citra: fix build after devel/boost-libs update
- also roll a post-patch item into an existing patch file

PR:		284855
2025-02-21 00:27:23 +01:00

36 lines
1.1 KiB
Text

citra-qt currently needs SDL for audio and input
--- CMakeLists.txt.orig 2022-09-01 18:37:46 UTC
+++ CMakeLists.txt
@@ -71,7 +71,6 @@ endfunction()
endif()
endforeach()
endfunction()
-check_submodules_present()
configure_file(${PROJECT_SOURCE_DIR}/dist/compatibility_list/compatibility_list.qrc
${PROJECT_BINARY_DIR}/dist/compatibility_list/compatibility_list.qrc
@@ -168,15 +167,15 @@ if (ENABLE_SDL2)
else()
find_package(SDL2 REQUIRED)
endif()
-
- if (SDL2_FOUND)
- # TODO(yuriks): Make FindSDL2.cmake export an IMPORTED library instead
- add_library(SDL2 INTERFACE)
- target_link_libraries(SDL2 INTERFACE "${SDL2_LIBRARY}")
- target_include_directories(SDL2 INTERFACE "${SDL2_INCLUDE_DIR}")
- endif()
else()
- set(SDL2_FOUND NO)
+ find_package(SDL2)
+endif()
+
+if (SDL2_FOUND)
+ # TODO(yuriks): Make FindSDL2.cmake export an IMPORTED library instead
+ add_library(SDL2 INTERFACE)
+ target_link_libraries(SDL2 INTERFACE "${SDL2_LIBRARY}")
+ target_include_directories(SDL2 INTERFACE "${SDL2_INCLUDE_DIR}")
endif()
if (ENABLE_QT)