mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
36 lines
1.1 KiB
Text
36 lines
1.1 KiB
Text
citra-qt currently needs SDL for audio and input
|
|
|
|
--- CMakeLists.txt.orig 2022-09-01 18:37:46 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -71,7 +71,6 @@ endfunction()
|
|
endif()
|
|
endforeach()
|
|
endfunction()
|
|
-check_submodules_present()
|
|
|
|
configure_file(${PROJECT_SOURCE_DIR}/dist/compatibility_list/compatibility_list.qrc
|
|
${PROJECT_BINARY_DIR}/dist/compatibility_list/compatibility_list.qrc
|
|
@@ -168,15 +167,15 @@ if (ENABLE_SDL2)
|
|
else()
|
|
find_package(SDL2 REQUIRED)
|
|
endif()
|
|
-
|
|
- if (SDL2_FOUND)
|
|
- # TODO(yuriks): Make FindSDL2.cmake export an IMPORTED library instead
|
|
- add_library(SDL2 INTERFACE)
|
|
- target_link_libraries(SDL2 INTERFACE "${SDL2_LIBRARY}")
|
|
- target_include_directories(SDL2 INTERFACE "${SDL2_INCLUDE_DIR}")
|
|
- endif()
|
|
else()
|
|
- set(SDL2_FOUND NO)
|
|
+ find_package(SDL2)
|
|
+endif()
|
|
+
|
|
+if (SDL2_FOUND)
|
|
+ # TODO(yuriks): Make FindSDL2.cmake export an IMPORTED library instead
|
|
+ add_library(SDL2 INTERFACE)
|
|
+ target_link_libraries(SDL2 INTERFACE "${SDL2_LIBRARY}")
|
|
+ target_include_directories(SDL2 INTERFACE "${SDL2_INCLUDE_DIR}")
|
|
endif()
|
|
|
|
if (ENABLE_QT)
|