audio/gstreamer1-plugins-alsa: Add port

GStreamer ALSA plugin.

If multimedia/qt6-multimedia is built with both the GSTREAMER and ALSA
options enabled, certain applications like multimedia/mkvtoolnix may
crash if this plugin is not installed.

PR:		282078
This commit is contained in:
Jason E. Hale 2024-12-22 00:47:12 -05:00
parent b43ab3b7f7
commit 7fac7b6b62
5 changed files with 35 additions and 1 deletions

View file

@ -54,7 +54,7 @@ _GST1_SOVERSION= 0.${_GST1_VERSION:R:E}${${_GST1_VERSION:E} > 9:?:0}${_GST1_VERS
_GST1_CATEGORIES= audio comms devel ftp graphics multimedia net security \ _GST1_CATEGORIES= audio comms devel ftp graphics multimedia net security \
sysutils textproc www x11 x11-toolkits sysutils textproc www x11 x11-toolkits
_GST1_PLUGINS_audio= a52dec amrnb amrwbdec bs2b cdparanoia chromaprint faac \ _GST1_PLUGINS_audio= a52dec alsa amrnb amrwbdec bs2b cdparanoia chromaprint faac \
faad flac flite gme gsm jack ladspa lame lv2 modplug \ faad flac flite gme gsm jack ladspa lame lv2 modplug \
mpg123 ogg openmpt opus pulse shout2 sidplay \ mpg123 ogg openmpt opus pulse shout2 sidplay \
sndfile sndio soundtouch speex taglib twolame vorbis \ sndfile sndio soundtouch speex taglib twolame vorbis \
@ -121,6 +121,9 @@ gst-libgstreamer_PORT= multimedia/gstreamer${_GST_VER}
gst-a52dec_PORT= audio/gstreamer${_GST_VER}-plugins-a52dec gst-a52dec_PORT= audio/gstreamer${_GST_VER}-plugins-a52dec
gst-a52dec_IMPL= ugly gst-a52dec_IMPL= ugly
gst-alsa_PORT= audio/gstreamer${_GST_VER}-plugins-alsa
gst-alsa_IMPL= #
gst-amrnb_PORT= audio/gstreamer${_GST_VER}-plugins-amrnb gst-amrnb_PORT= audio/gstreamer${_GST_VER}-plugins-amrnb
gst-amrnb_IMPL= ugly gst-amrnb_IMPL= ugly

View file

@ -226,6 +226,7 @@
SUBDIR += gsm SUBDIR += gsm
SUBDIR += gsound SUBDIR += gsound
SUBDIR += gstreamer1-plugins-a52dec SUBDIR += gstreamer1-plugins-a52dec
SUBDIR += gstreamer1-plugins-alsa
SUBDIR += gstreamer1-plugins-amrnb SUBDIR += gstreamer1-plugins-amrnb
SUBDIR += gstreamer1-plugins-amrwbdec SUBDIR += gstreamer1-plugins-amrwbdec
SUBDIR += gstreamer1-plugins-bs2b SUBDIR += gstreamer1-plugins-bs2b

View file

@ -0,0 +1,16 @@
PORTREVISION= 0
CATEGORIES= audio
COMMENT= GStreamer ALSA plugin
LIB_DEPENDS= libasound.so:audio/alsa-lib
RUN_DEPENDS= alsa-plugins>=0:audio/alsa-plugins
MASTERDIR= ${.CURDIR:H:H}/multimedia/gstreamer1-plugins
PLIST= ${.CURDIR}/pkg-plist
DIST= base
GST_PLUGIN= alsa
.include "${MASTERDIR}/Makefile"

View file

@ -0,0 +1 @@
lib/gstreamer-%%VERSION%%/libgstalsa.so

View file

@ -0,0 +1,13 @@
--- ext/alsa/meson.build.orig 2024-12-03 23:29:07 UTC
+++ ext/alsa/meson.build
@@ -15,7 +15,9 @@ if alsa_dep.found()
alsa_sources,
c_args : gst_plugins_base_args,
include_directories: [configinc, libsinc],
- dependencies : [alsa_dep, audio_dep, tag_dep, gst_dep, gst_base_dep],
+ dependencies : [alsa_dep, dependency('gstreamer-audio-1.0'),
+ dependency('gstreamer-audio-1.0'), dependency('gstreamer-tag-1.0'),
+ gst_dep, gst_base_dep],
install : true,
install_dir : plugins_install_dir,
)