mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
GStreamer ALSA plugin. If multimedia/qt6-multimedia is built with both the GSTREAMER and ALSA options enabled, certain applications like multimedia/mkvtoolnix may crash if this plugin is not installed. PR: 282078
13 lines
534 B
Text
13 lines
534 B
Text
--- ext/alsa/meson.build.orig 2024-12-03 23:29:07 UTC
|
|
+++ ext/alsa/meson.build
|
|
@@ -15,7 +15,9 @@ if alsa_dep.found()
|
|
alsa_sources,
|
|
c_args : gst_plugins_base_args,
|
|
include_directories: [configinc, libsinc],
|
|
- dependencies : [alsa_dep, audio_dep, tag_dep, gst_dep, gst_base_dep],
|
|
+ dependencies : [alsa_dep, dependency('gstreamer-audio-1.0'),
|
|
+ dependency('gstreamer-audio-1.0'), dependency('gstreamer-tag-1.0'),
|
|
+ gst_dep, gst_base_dep],
|
|
install : true,
|
|
install_dir : plugins_install_dir,
|
|
)
|