math/oink: update g20210710 → g20250105

This commit is contained in:
Yuri Victorovich 2025-03-27 22:25:30 -07:00
parent 1ca576e4b3
commit 7f69520286
5 changed files with 28 additions and 48 deletions

View file

@ -1,6 +1,5 @@
PORTNAME= oink
DISTVERSION= g20210710
PORTREVISION= 7
DISTVERSION= g20250105
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@ -10,18 +9,20 @@ WWW= https://github.com/trolando/oink
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN= fails to build with boost-1.85+
LIB_DEPENDS= libboost_iostreams.so:devel/boost-libs
LIB_DEPENDS= libboost_iostreams.so:devel/boost-libs \
liblace.so:devel/lace
USES= cmake:testing
USE_CXXSTD= c++14
USE_GITHUB= yes
GH_ACCOUNT= trolando
GH_TAGNAME= 3327c54
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= trolando
GH_TAGNAME= 32950f2
CMAKE_ON= BUILD_SHARED_LIBS
CMAKE_OFF= OINK_BUILD_NATIVE
# tests as of g20250105: 59% tests passed, 14 tests failed out of 34 # failures are likely from some test running too high in memory, because individual tests all pass when standalone
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1647124747
SHA256 (trolando-oink-g20210710-3327c54_GH0.tar.gz) = 5c4f1658531fcfca394cb46412143ccebc70153953d398942609b18f999a136a
SIZE (trolando-oink-g20210710-3327c54_GH0.tar.gz) = 178207
TIMESTAMP = 1743124350
SHA256 (trolando-oink-g20250105-32950f2_GH0.tar.gz) = 39b42b0aff95217db42e319baba0b18a945ce27794cfbbe96e894e09416045da
SIZE (trolando-oink-g20250105-32950f2_GH0.tar.gz) = 8888495

View file

@ -1,10 +1,11 @@
--- CMakeLists.txt.orig 2021-12-26 00:23:48 UTC
--- CMakeLists.txt.orig 2025-03-28 04:18:13 UTC
+++ CMakeLists.txt
@@ -46,7 +46,6 @@ add_library(oink::oink ALIAS oink)
@@ -24,7 +24,7 @@ find_package(Boost REQUIRED COMPONENTS filesystem iost
find_package(Boost REQUIRED COMPONENTS filesystem iostreams regex system random CONFIG)
# Main library target
-add_library(oink STATIC)
+add_library(oink)
add_library(oink::oink ALIAS oink)
set_target_properties(oink PROPERTIES VERSION ${oink_VERSION} SOVERSION ${oink_VERSION_MAJOR})
target_compile_features(oink PUBLIC c_std_11 cxx_std_11)
target_compile_options(oink PRIVATE -Wall -Wextra)
-target_compile_options(oink PRIVATE "$<$<CONFIG:Release,RelWithDebInfo>:-march=native>")
target_include_directories(oink
PRIVATE
${CMAKE_CURRENT_LIST_DIR}/src

View file

@ -1,27 +0,0 @@
--- src/lace.h.orig 2021-07-10 20:56:55 UTC
+++ src/lace.h
@@ -17,6 +17,11 @@
*/
#include <unistd.h>
+#ifdef __cplusplus
+#include <atomic>
+#else
+#include <stdatomic.h>
+#endif
#include <stdint.h>
#include <stdio.h>
#include <pthread.h> /* for pthread_t */
@@ -293,7 +298,11 @@ void lace_yield(WorkerP *__lace_worker, Task *__lace_d
#endif
#ifndef mfence
-#define mfence() { asm volatile("mfence" ::: "memory"); }
+#ifdef __cplusplus
+#define mfence() std::atomic_thread_fence(std::memory_order_seq_cst)
+#else
+#define mfence() atomic_thread_fence(memory_order_seq_cst)
+#endif
#endif
/* Compiler specific branch prediction optimization */

View file

@ -2,10 +2,15 @@ bin/oink
include/oink/bitset.hpp
include/oink/error.hpp
include/oink/game.hpp
include/oink/libpopcnt.h
include/oink/oink.hpp
include/oink/solver.hpp
include/oink/solvers.hpp
include/oink/uintqueue.hpp
lib/cmake/oink/oink-config-version.cmake
lib/cmake/oink/oink-config.cmake
lib/cmake/oink/oink-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/oink/oink-targets.cmake
lib/liboink.so
lib/liboink.so.1
lib/liboink.so.1.0.0
lib/oink/cmake/OinkConfig-%%CMAKE_BUILD_TYPE%%.cmake
lib/oink/cmake/OinkConfig.cmake