mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
graphics/libultrahdr: Add libultrahdr 1.4.0
libultrahdr is an image compression library that uses gain map technology to store and distribute HDR images. Conceptually on the encoding side, the library accepts SDR and HDR rendition of an image and from these a Gain Map (quotient between the two renditions) is computed. The library then uses backward compatible means to store the base image (SDR), gain map image and some associated metadata. Legacy readers that do not support handling the gain map image and/or metadata, will display the base image. Readers that support the format combine the base image with the gain map and render a high dynamic range image on compatible displays.
This commit is contained in:
parent
7eae8191ec
commit
72501c88d4
6 changed files with 67 additions and 0 deletions
|
@ -511,6 +511,7 @@
|
||||||
SUBDIR += libspiro
|
SUBDIR += libspiro
|
||||||
SUBDIR += libspng
|
SUBDIR += libspng
|
||||||
SUBDIR += libsvgtiny
|
SUBDIR += libsvgtiny
|
||||||
|
SUBDIR += libultrahdr
|
||||||
SUBDIR += libvisual
|
SUBDIR += libvisual
|
||||||
SUBDIR += libvisual04
|
SUBDIR += libvisual04
|
||||||
SUBDIR += libvisual04-plugins
|
SUBDIR += libvisual04-plugins
|
||||||
|
|
37
graphics/libultrahdr/Makefile
Normal file
37
graphics/libultrahdr/Makefile
Normal file
|
@ -0,0 +1,37 @@
|
||||||
|
PORTNAME= libultrahdr
|
||||||
|
PORTVERSION= 1.4.0
|
||||||
|
DISTVERSIONPREFIX= v
|
||||||
|
CATEGORIES= graphics
|
||||||
|
|
||||||
|
MAINTAINER= sunpoet@FreeBSD.org
|
||||||
|
COMMENT= Reference codec for the Ultra HDR format
|
||||||
|
WWW= https://developer.android.com/media/platform/hdr-image-format \
|
||||||
|
https://github.com/google/libultrahdr
|
||||||
|
|
||||||
|
LICENSE= APACHE20
|
||||||
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||||
|
|
||||||
|
USES= cmake jpeg pathfix
|
||||||
|
|
||||||
|
CMAKE_OFF= UHDR_BUILD_BENCHMARK \
|
||||||
|
UHDR_BUILD_DEPS \
|
||||||
|
UHDR_BUILD_FUZZERS \
|
||||||
|
UHDR_BUILD_JAVA \
|
||||||
|
UHDR_BUILD_PACKAGING \
|
||||||
|
UHDR_BUILD_TESTS \
|
||||||
|
UHDR_ENABLE_GLES \
|
||||||
|
UHDR_ENABLE_LOGS \
|
||||||
|
UHDR_ENABLE_WERROR \
|
||||||
|
UHDR_WRITE_XMP
|
||||||
|
CMAKE_ON= BUILD_SHARED_LIBS \
|
||||||
|
BUILD_STATIC_LIBS \
|
||||||
|
UHDR_BUILD_EXAMPLES \
|
||||||
|
UHDR_ENABLE_INSTALL \
|
||||||
|
UHDR_ENABLE_INTRINSICS \
|
||||||
|
UHDR_WRITE_ISO
|
||||||
|
USE_LDCONFIG= yes
|
||||||
|
|
||||||
|
USE_GITHUB= yes
|
||||||
|
GH_ACCOUNT= google
|
||||||
|
|
||||||
|
.include <bsd.port.mk>
|
3
graphics/libultrahdr/distinfo
Normal file
3
graphics/libultrahdr/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
||||||
|
TIMESTAMP = 1738088810
|
||||||
|
SHA256 (google-libultrahdr-v1.4.0_GH0.tar.gz) = e7e1252e2c44d8ed6b99ee0f67a3caf2d8a61c43834b13b1c3cd485574c03ab9
|
||||||
|
SIZE (google-libultrahdr-v1.4.0_GH0.tar.gz) = 1375424
|
10
graphics/libultrahdr/files/patch-CMakeLists.txt
Normal file
10
graphics/libultrahdr/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
--- CMakeLists.txt.orig 2025-01-10 19:31:48 UTC
|
||||||
|
+++ CMakeLists.txt
|
||||||
|
@@ -36,6 +36,7 @@ elseif(${CMAKE_SYSTEM_NAME} MATCHES "Android")
|
||||||
|
if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
|
||||||
|
elseif(${CMAKE_SYSTEM_NAME} MATCHES "Emscripten")
|
||||||
|
elseif(${CMAKE_SYSTEM_NAME} MATCHES "Android")
|
||||||
|
+elseif(${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
|
||||||
|
elseif(WIN32)
|
||||||
|
elseif(APPLE)
|
||||||
|
else()
|
9
graphics/libultrahdr/pkg-descr
Normal file
9
graphics/libultrahdr/pkg-descr
Normal file
|
@ -0,0 +1,9 @@
|
||||||
|
libultrahdr is an image compression library that uses gain map technology to
|
||||||
|
store and distribute HDR images. Conceptually on the encoding side, the library
|
||||||
|
accepts SDR and HDR rendition of an image and from these a Gain Map (quotient
|
||||||
|
between the two renditions) is computed. The library then uses backward
|
||||||
|
compatible means to store the base image (SDR), gain map image and some
|
||||||
|
associated metadata. Legacy readers that do not support handling the gain map
|
||||||
|
image and/or metadata, will display the base image. Readers that support the
|
||||||
|
format combine the base image with the gain map and render a high dynamic range
|
||||||
|
image on compatible displays.
|
7
graphics/libultrahdr/pkg-plist
Normal file
7
graphics/libultrahdr/pkg-plist
Normal file
|
@ -0,0 +1,7 @@
|
||||||
|
bin/ultrahdr_app
|
||||||
|
include/ultrahdr_api.h
|
||||||
|
lib/libuhdr.a
|
||||||
|
lib/libuhdr.so
|
||||||
|
lib/libuhdr.so.1
|
||||||
|
lib/libuhdr.so.1.4.0
|
||||||
|
libdata/pkgconfig/libuhdr.pc
|
Loading…
Add table
Reference in a new issue