mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
libultrahdr is an image compression library that uses gain map technology to store and distribute HDR images. Conceptually on the encoding side, the library accepts SDR and HDR rendition of an image and from these a Gain Map (quotient between the two renditions) is computed. The library then uses backward compatible means to store the base image (SDR), gain map image and some associated metadata. Legacy readers that do not support handling the gain map image and/or metadata, will display the base image. Readers that support the format combine the base image with the gain map and render a high dynamic range image on compatible displays.
10 lines
359 B
Text
10 lines
359 B
Text
--- CMakeLists.txt.orig 2025-01-10 19:31:48 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -36,6 +36,7 @@ elseif(${CMAKE_SYSTEM_NAME} MATCHES "Android")
|
|
if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
|
|
elseif(${CMAKE_SYSTEM_NAME} MATCHES "Emscripten")
|
|
elseif(${CMAKE_SYSTEM_NAME} MATCHES "Android")
|
|
+elseif(${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
|
|
elseif(WIN32)
|
|
elseif(APPLE)
|
|
else()
|