mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
lang/squirrel: Update to 3.2 and take maintainership
* Add LICENSE_FILE
* Report correct version in .cmake files
* Disable static binary and libs
* Adjust port Makefile layout to more closely follow Porters Handbook
* Disable GNU C/C++ extensions
References:
af69eb7084
PR: 284650
This commit is contained in:
parent
23ba39d8e1
commit
707bf5e07d
5 changed files with 29 additions and 1326 deletions
|
@ -1,19 +1,26 @@
|
|||
PORTNAME= squirrel
|
||||
DISTVERSION= 3_1
|
||||
PORTREVISION= 3
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 3.2
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}3/${PORTNAME}%20${PORTVERSION}%20stable
|
||||
DISTNAME= ${PORTNAME}_${DISTVERSION}_stable
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= mclay@astate.edu
|
||||
COMMENT= High level imperative/OO programming language
|
||||
WWW= http://squirrel-lang.org/
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
|
||||
|
||||
USES= cmake compiler:c++11-lang
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= albertodemichelis
|
||||
|
||||
CONFLICTS= squsq
|
||||
|
||||
USES= cmake compiler:c++11-lang dos2unix
|
||||
CMAKE_OFF= CMAKE_C_EXTENSIONS \
|
||||
CMAKE_CXX_EXTENSIONS
|
||||
CMAKE_ON= DISABLE_STATIC
|
||||
CMAKE_ARGS= -DINSTALL_INC_DIR:STRING=include
|
||||
USE_LDCONFIG= yes
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}3
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1487088121
|
||||
SHA256 (squirrel_3_1_stable.tar.gz) = 4845a7fb82e4740bde01b0854112e3bb92a0816ad959c5758236e73f4409d0cb
|
||||
SIZE (squirrel_3_1_stable.tar.gz) = 616961
|
||||
TIMESTAMP = 1739028196
|
||||
SHA256 (albertodemichelis-squirrel-v3.2_GH0.tar.gz) = 02805414cfadd5bbb921891d3599b83375a40650abd6404a8ab407dc5e86a996
|
||||
SIZE (albertodemichelis-squirrel-v3.2_GH0.tar.gz) = 182795
|
||||
|
|
|
@ -1,23 +1,9 @@
|
|||
--- CMakeLists.txt.orig 2017-02-14 16:19:11 UTC
|
||||
--- CMakeLists.txt.orig 2025-02-08 15:24:36 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -11,19 +11,9 @@ project(squirrel C CXX)
|
||||
@@ -1,5 +1,5 @@ cmake_minimum_required(VERSION 3.4)
|
||||
cmake_minimum_required(VERSION 3.4)
|
||||
-project(squirrel VERSION 3.1 LANGUAGES C CXX)
|
||||
+project(squirrel VERSION 3.2 LANGUAGES C CXX)
|
||||
|
||||
include_directories(${CMAKE_SOURCE_DIR}/include)
|
||||
|
||||
-if(CMAKE_COMPILER_IS_GNUCXX)
|
||||
+if(CMAKE_CXX_COMPILER_ID MATCHES GNU OR CMAKE_CXX_COMPILER_ID MATCHES Clang)
|
||||
set(SQ_FLAGS -fno-exceptions -fno-strict-aliasing -Wall -Wextra -pedantic -Wcast-qual)
|
||||
|
||||
- if(CMAKE_BUILD_TYPE STREQUAL "Release")
|
||||
- set(SQ_FLAGS ${SQ_FLAGS} -O3)
|
||||
- elseif(CMAKE_BUILD_TYPE STREQUAL "RelWithDebInfo")
|
||||
- set(SQ_FLAGS ${SQ_FLAGS} -O3 -g)
|
||||
- elseif(CMAKE_BUILD_TYPE STREQUAL "MinSizeRel")
|
||||
- set(SQ_FLAGS ${SQ_FLAGS} -Os)
|
||||
- elseif(CMAKE_BUILD_TYPE STREQUAL "Debug")
|
||||
- set(SQ_FLAGS ${SQ_FLAGS} -pg -pie -gstabs -g3 -Og)
|
||||
- endif()
|
||||
-
|
||||
if(CMAKE_VERSION VERSION_GREATER 3)
|
||||
add_compile_options(${SQ_FLAGS})
|
||||
else()
|
||||
option(DISABLE_STATIC "Avoid building/installing static libraries.")
|
||||
option(LONG_OUTPUT_NAMES "Use longer names for binaries and libraries: squirrel3 (not sq).")
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,5 +1,4 @@
|
|||
bin/sq
|
||||
bin/sq_static
|
||||
include/sqconfig.h
|
||||
include/sqstdaux.h
|
||||
include/sqstdblob.h
|
||||
|
@ -11,8 +10,10 @@ include/squirrel.h
|
|||
lib/libsqstdlib.so
|
||||
lib/libsqstdlib.so.0
|
||||
lib/libsqstdlib.so.0.0.0
|
||||
lib/libsqstdlib_static.a
|
||||
lib/libsquirrel.so
|
||||
lib/libsquirrel.so.0
|
||||
lib/libsquirrel.so.0.0.0
|
||||
lib/libsquirrel_static.a
|
||||
lib/cmake/squirrel/squirrel-config-version.cmake
|
||||
lib/cmake/squirrel/squirrel-config.cmake
|
||||
lib/cmake/squirrel/squirrel-targets.cmake
|
||||
lib/cmake/squirrel/squirrel-targets-release.cmake
|
||||
|
|
Loading…
Add table
Reference in a new issue