ports/lang/squirrel/files/patch-CMakeLists.txt
Mitchell Clay 707bf5e07d lang/squirrel: Update to 3.2 and take maintainership
* Add LICENSE_FILE
* Report correct version in .cmake files
* Disable static binary and libs
* Adjust port Makefile layout to more closely follow Porters Handbook
* Disable GNU C/C++ extensions

References:
af69eb7084

PR:		284650
2025-02-09 13:19:30 +01:00

9 lines
416 B
Text

--- CMakeLists.txt.orig 2025-02-08 15:24:36 UTC
+++ CMakeLists.txt
@@ -1,5 +1,5 @@ cmake_minimum_required(VERSION 3.4)
cmake_minimum_required(VERSION 3.4)
-project(squirrel VERSION 3.1 LANGUAGES C CXX)
+project(squirrel VERSION 3.2 LANGUAGES C CXX)
option(DISABLE_STATIC "Avoid building/installing static libraries.")
option(LONG_OUTPUT_NAMES "Use longer names for binaries and libraries: squirrel3 (not sq).")