mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
lang/rust-nightly: update 1.88.0.20250402 → 1.88.0.20250416
Approved by: rust (implicit)
This commit is contained in:
parent
b3f6f8596d
commit
59a8038760
4 changed files with 24 additions and 38 deletions
|
@ -14,8 +14,8 @@ MASTERDIR= ${.CURDIR}/../rust
|
||||||
PATCHDIR= ${.CURDIR}/files
|
PATCHDIR= ${.CURDIR}/files
|
||||||
DISTINFO_FILE= ${.CURDIR}/distinfo
|
DISTINFO_FILE= ${.CURDIR}/distinfo
|
||||||
|
|
||||||
NIGHTLY_DATE= 2025-04-02
|
NIGHTLY_DATE= 2025-04-16
|
||||||
BOOTSTRAPS_DATE= 2025-02-18
|
BOOTSTRAPS_DATE= 2025-04-02
|
||||||
RUST_BOOTSTRAP_VERSION= beta
|
RUST_BOOTSTRAP_VERSION= beta
|
||||||
|
|
||||||
.include "${MASTERDIR}/Makefile"
|
.include "${MASTERDIR}/Makefile"
|
||||||
|
|
|
@ -1,9 +1,9 @@
|
||||||
TIMESTAMP = 1743681715
|
TIMESTAMP = 1744886442
|
||||||
SHA256 (rust/2025-04-02/rustc-nightly-src.tar.xz) = 93ae6bc04d67dbe3ed8fa28e19331c60115d4848e8f70e21c141e4ff7ffc84d6
|
SHA256 (rust/2025-04-16/rustc-nightly-src.tar.xz) = 316454878d27da6ec89517100b2323ec5a92cde522d0602552e9aae30de8219f
|
||||||
SIZE (rust/2025-04-02/rustc-nightly-src.tar.xz) = 283623996
|
SIZE (rust/2025-04-16/rustc-nightly-src.tar.xz) = 282292384
|
||||||
SHA256 (rust/2025-02-18/rustc-beta-x86_64-unknown-freebsd.tar.xz) = 52ab3212d64b56a8da207fe976cbc8d266e962a61c742e6069137b10ff25c3c1
|
SHA256 (rust/2025-04-02/rustc-beta-x86_64-unknown-freebsd.tar.xz) = c8d0147c625faa5ce0e75c2509827bc4b190ad286e41411bce92023e00eb7a1d
|
||||||
SIZE (rust/2025-02-18/rustc-beta-x86_64-unknown-freebsd.tar.xz) = 85822636
|
SIZE (rust/2025-04-02/rustc-beta-x86_64-unknown-freebsd.tar.xz) = 88062036
|
||||||
SHA256 (rust/2025-02-18/rust-std-beta-x86_64-unknown-freebsd.tar.xz) = 11bae401884cce0306b415bb1202c2c63f81395677057fbbe12e9302951a9d3d
|
SHA256 (rust/2025-04-02/rust-std-beta-x86_64-unknown-freebsd.tar.xz) = 8bef59b74196fa9f7839bb491f6b32d0761a45c8d7178980ee3afd80231b836e
|
||||||
SIZE (rust/2025-02-18/rust-std-beta-x86_64-unknown-freebsd.tar.xz) = 27638072
|
SIZE (rust/2025-04-02/rust-std-beta-x86_64-unknown-freebsd.tar.xz) = 28281300
|
||||||
SHA256 (rust/2025-02-18/cargo-beta-x86_64-unknown-freebsd.tar.xz) = c244ec4f97420c29c690e32bd6d8f14994bf1d990747f31a3dc0f2b37644493e
|
SHA256 (rust/2025-04-02/cargo-beta-x86_64-unknown-freebsd.tar.xz) = eae168df54ddfe95db669c205ae97baa902056722856fa174758ebd058168a95
|
||||||
SIZE (rust/2025-02-18/cargo-beta-x86_64-unknown-freebsd.tar.xz) = 10434836
|
SIZE (rust/2025-04-02/cargo-beta-x86_64-unknown-freebsd.tar.xz) = 10577536
|
||||||
|
|
|
@ -1,14 +0,0 @@
|
||||||
--- src/bootstrap/src/core/config/config.rs.orig 2025-04-01 18:22:03 UTC
|
|
||||||
+++ src/bootstrap/src/core/config/config.rs
|
|
||||||
@@ -3016,9 +3016,9 @@ impl Config {
|
|
||||||
|| source_version.minor == stage0_version.minor + 1)))
|
|
||||||
{
|
|
||||||
let prev_version = format!("{}.{}.x", source_version.major, source_version.minor - 1);
|
|
||||||
- fail(&format!(
|
|
||||||
+ println!(
|
|
||||||
"Unexpected {component_name} version: {stage0_version}, we should use {prev_version}/{source_version} to build source with {source_version}"
|
|
||||||
- ));
|
|
||||||
+ );
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
|
@ -43,19 +43,6 @@ https://reviews.llvm.org/D77776
|
||||||
- (true, _, _, _, false) | (_, _, _, true, false) => Ok(ToolFamily::Clang {
|
- (true, _, _, _, false) | (_, _, _, true, false) => Ok(ToolFamily::Clang {
|
||||||
- zig_cc: is_zig_cc(path, cargo_output),
|
- zig_cc: is_zig_cc(path, cargo_output),
|
||||||
- }),
|
- }),
|
||||||
+ (true, _, _, _, false) | (_, _, _, true, false) => Ok(ToolFamily::Gnu),
|
|
||||||
(false, false, true, _, false) | (_, _, _, _, true) => Ok(ToolFamily::Gnu),
|
|
||||||
(false, false, false, false, false) => {
|
|
||||||
cargo_output.print_warning(&"Compiler family detection failed since it does not define `__clang__`, `__GNUC__`, `__EMSCRIPTEN__` or `__VXWORKS__`, also does not accept cl style flag `-?`, fallback to treating it as GNU");
|
|
||||||
--- vendor/cc-1.2.10/src/tool.rs.orig 2025-04-01 18:22:03 UTC
|
|
||||||
+++ vendor/cc-1.2.10/src/tool.rs
|
|
||||||
@@ -137,9 +137,7 @@ impl Tool {
|
|
||||||
|
|
||||||
match (clang, accepts_cl_style_flags, gcc, emscripten, vxworks) {
|
|
||||||
(clang_cl, true, _, false, false) => Ok(ToolFamily::Msvc { clang_cl }),
|
|
||||||
- (true, _, _, _, false) | (_, _, _, true, false) => Ok(ToolFamily::Clang {
|
|
||||||
- zig_cc: is_zig_cc(path, cargo_output),
|
|
||||||
- }),
|
|
||||||
+ (true, _, _, _, false) | (_, _, _, true, false) => Ok(ToolFamily::Gnu),
|
+ (true, _, _, _, false) | (_, _, _, true, false) => Ok(ToolFamily::Gnu),
|
||||||
(false, false, true, _, false) | (_, _, _, _, true) => Ok(ToolFamily::Gnu),
|
(false, false, true, _, false) | (_, _, _, _, true) => Ok(ToolFamily::Gnu),
|
||||||
(false, false, false, false, false) => {
|
(false, false, false, false, false) => {
|
||||||
|
@ -86,3 +73,16 @@ https://reviews.llvm.org/D77776
|
||||||
(false, false, true, _, false) | (_, _, _, _, true) => Ok(ToolFamily::Gnu),
|
(false, false, true, _, false) | (_, _, _, _, true) => Ok(ToolFamily::Gnu),
|
||||||
(false, false, false, false, false) => {
|
(false, false, false, false, false) => {
|
||||||
cargo_output.print_warning(&"Compiler family detection failed since it does not define `__clang__`, `__GNUC__`, `__EMSCRIPTEN__` or `__VXWORKS__`, also does not accept cl style flag `-?`, fallback to treating it as GNU");
|
cargo_output.print_warning(&"Compiler family detection failed since it does not define `__clang__`, `__GNUC__`, `__EMSCRIPTEN__` or `__VXWORKS__`, also does not accept cl style flag `-?`, fallback to treating it as GNU");
|
||||||
|
--- vendor/cc-1.2.18/src/tool.rs.orig 2025-04-01 18:22:03 UTC
|
||||||
|
+++ vendor/cc-1.2.18/src/tool.rs
|
||||||
|
@@ -141,9 +141,7 @@ impl Tool {
|
||||||
|
|
||||||
|
match (clang, accepts_cl_style_flags, gcc, emscripten, vxworks) {
|
||||||
|
(clang_cl, true, _, false, false) => Ok(ToolFamily::Msvc { clang_cl }),
|
||||||
|
- (true, _, _, _, false) | (_, _, _, true, false) => Ok(ToolFamily::Clang {
|
||||||
|
- zig_cc: is_zig_cc(path, cargo_output),
|
||||||
|
- }),
|
||||||
|
+ (true, _, _, _, false) | (_, _, _, true, false) => Ok(ToolFamily::Gnu),
|
||||||
|
(false, false, true, _, false) | (_, _, _, _, true) => Ok(ToolFamily::Gnu),
|
||||||
|
(false, false, false, false, false) => {
|
||||||
|
cargo_output.print_warning(&"Compiler family detection failed since it does not define `__clang__`, `__GNUC__`, `__EMSCRIPTEN__` or `__VXWORKS__`, also does not accept cl style flag `-?`, fallback to treating it as GNU");
|
||||||
|
|
Loading…
Add table
Reference in a new issue