graphics/h3: Use CMAKE_DISABLE_FIND_PACKAGE_<PackageName>

- Cosmetic change
This commit is contained in:
Po-Chuan Hsieh 2024-09-18 13:56:01 +08:00
parent c41e1ace8e
commit 3d54d5fff7
No known key found for this signature in database
GPG key ID: 9A4BD10F002DD04B
2 changed files with 14 additions and 32 deletions

View file

@ -14,8 +14,20 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake
CMAKE_OFF= BUILD_TESTING ENABLE_COVERAGE ENABLE_DOCS ENABLE_FORMAT ENABLE_LIBFUZZER ENABLE_LINTING H3_FUZZER_NO_MAIN WARNINGS_AS_ERRORS
CMAKE_ON= BUILD_BENCHMARKS BUILD_FILTERS BUILD_FUZZERS BUILD_GENERATORS BUILD_SHARED_LIBS
CMAKE_OFF= BUILD_TESTING \
ENABLE_COVERAGE \
ENABLE_DOCS \
ENABLE_FORMAT \
ENABLE_LIBFUZZER \
ENABLE_LINTING \
H3_FUZZER_NO_MAIN \
WARNINGS_AS_ERRORS
CMAKE_ON= BUILD_BENCHMARKS \
BUILD_FILTERS \
BUILD_FUZZERS \
BUILD_GENERATORS \
BUILD_SHARED_LIBS \
CMAKE_DISABLE_FIND_PACKAGE_Doxygen
USE_GITHUB= yes
GH_ACCOUNT= uber

View file

@ -1,30 +0,0 @@
--- CMakeLists.txt.orig 2020-06-20 00:40:07 UTC
+++ CMakeLists.txt
@@ -274,27 +274,6 @@ elseif(NOT CLANG_TIDY_PATH)
"so source code linting is disabled")
endif()
-# Docs
-find_package(Doxygen)
-option(ENABLE_DOCS "Enable building documentation." ON)
-if(DOXYGEN_FOUND AND ENABLE_DOCS)
- set_property(DIRECTORY APPEND PROPERTY ADDITIONAL_MAKE_CLEAN_FILES "${CMAKE_CURRENT_BINARY_DIR}/dev-docs/_build")
- configure_file(dev-docs/Doxyfile.in
- dev-docs/Doxyfile
- ESCAPE_QUOTES
- )
- add_custom_target(docs
- ALL
- ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/dev-docs/Doxyfile
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/dev-docs
- COMMENT "Generating API documentation with Doxygen" VERBATIM
- )
-else()
- add_custom_target(docs
- echo "Doxygen was not installed when CMake was run or ENABLE_DOCS was OFF. Check that Doxygen is installed and rerun `cmake .`" VERBATIM
- )
-endif()
-
# Metadata for bindings
if (WIN32)
add_custom_target(binding-functions