ports/graphics/h3/files/patch-CMakeLists.txt
Sunpoet Po-Chuan Hsieh 0562c54665 Add h3 3.6.4
H3 is a geospatial indexing system using a hexagonal grid that can be
(approximately) subdivided into finer and finer hexagonal grids, combining the
benefits of a hexagonal grid with S2's hierarchical subdivisions.

WWW: https://github.com/uber/h3
2020-09-12 12:06:59 +00:00

30 lines
1 KiB
Text

--- CMakeLists.txt.orig 2020-06-20 00:40:07 UTC
+++ CMakeLists.txt
@@ -274,27 +274,6 @@ elseif(NOT CLANG_TIDY_PATH)
"so source code linting is disabled")
endif()
-# Docs
-find_package(Doxygen)
-option(ENABLE_DOCS "Enable building documentation." ON)
-if(DOXYGEN_FOUND AND ENABLE_DOCS)
- set_property(DIRECTORY APPEND PROPERTY ADDITIONAL_MAKE_CLEAN_FILES "${CMAKE_CURRENT_BINARY_DIR}/dev-docs/_build")
- configure_file(dev-docs/Doxyfile.in
- dev-docs/Doxyfile
- ESCAPE_QUOTES
- )
- add_custom_target(docs
- ALL
- ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/dev-docs/Doxyfile
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/dev-docs
- COMMENT "Generating API documentation with Doxygen" VERBATIM
- )
-else()
- add_custom_target(docs
- echo "Doxygen was not installed when CMake was run or ENABLE_DOCS was OFF. Check that Doxygen is installed and rerun `cmake .`" VERBATIM
- )
-endif()
-
# Metadata for bindings
if (WIN32)
add_custom_target(binding-functions