databases/memcached: update to 1.4.24

While here, re-generate existing patches
Also, add memcached_post_start to rc script [1]

Submitted by:	Maximilian Boße <Maximilian.Bosse@trivago.com> (private email) [1]
This commit is contained in:
Steve Wills 2015-06-27 20:42:04 +00:00
parent 72b79a6547
commit 3c99d88354
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=390730
6 changed files with 41 additions and 17 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= memcached
PORTVERSION= 1.4.22
PORTVERSION= 1.4.24
CATEGORIES= databases
MASTER_SITES= http://www.memcached.org/files/ \
GOOGLE_CODE \
@ -28,7 +28,8 @@ SASL_DESC= Enable SASL Authentication
USE_RC_SUBR= memcached
SUB_LIST+= RC_SUBR_SUFFIX=${RC_SUBR_SUFFIX}
USES= cpe shebangfix
USES= cpe shebangfix autoreconf:build
USE_AUTOTOOLS= aclocal
SHEBANG_FILES= scripts/memcached-tool
USE_CSTD= c99

View file

@ -1,2 +1,2 @@
SHA256 (memcached-1.4.22.tar.gz) = cfcc470c57079914aca6e565b2daeed1d13356ad492909d9aafd6eefac538c2a
SIZE (memcached-1.4.22.tar.gz) = 346632
SHA256 (memcached-1.4.24.tar.gz) = 08a426c504ecf64633151eec1058584754d2f54e62e5ed2d6808559401617e55
SIZE (memcached-1.4.24.tar.gz) = 354917

View file

@ -16,6 +16,9 @@
# Default is "nobody".
# memcached_profiles (str): Set to "" by default.
# Define your profiles here.
# memcached_post_start (str): Set extra commands that should be executed after memcached was successfully
# started here.
# Default is empty "".
. /etc/rc.subr
@ -33,6 +36,7 @@ if [ -n "$2" ]; then
pidfile="${_piddir}/memcached.${profile}.pid"
eval memcached_enable="\${memcached_${profile}_enable:-${memcached_enable}}"
eval memcached_flags="\${memcached_${profile}_flags:-${memcached_flags}}"
eval memcached_post_start="\${memcached_${profile}_post_start:-${memcached_post_start}}"
else
echo "%%PREFIX%%/etc/rc.d/memcached%%RC_SUBR_SUFFIX%%: extra argument ignored"
fi
@ -70,6 +74,13 @@ else
fi
fi
memcached_poststart()
{
if [ -n "$memcached_post_start" ]; then
eval $memcached_post_start
fi
}
memcached_poststop()
{
if [ -n "${profile}" ]; then
@ -94,6 +105,7 @@ command=%%PREFIX%%/bin/memcached
command_args="-d -u ${memcached_user} -P ${pidfile} "
start_precmd="install -d -o $memcached_user -g $memcached_user -m 755 $_piddir"
start_postcmd="${name}_poststart"
stop_postcmd="${name}_poststop"
run_rc_command "$1"

View file

@ -0,0 +1,11 @@
--- configure.ac.orig 2015-06-27 18:28:54 UTC
+++ configure.ac
@@ -581,7 +581,7 @@ then
elif test "$GCC" = "yes"
then
GCC_VERSION=`$CC -dumpversion`
- CFLAGS="$CFLAGS -Wall -Werror -pedantic -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls"
+ CFLAGS="$CFLAGS -Wall -pedantic -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls"
case $GCC_VERSION in
4.4.*)
CFLAGS="$CFLAGS -fno-strict-aliasing"

View file

@ -1,6 +1,6 @@
--- memcached.c.orig 2014-10-13 03:33:10.000000000 +0000
+++ memcached.c 2015-01-16 16:21:34.000000000 +0000
@@ -280,7 +280,7 @@
--- memcached.c.orig 2015-04-20 05:34:19 UTC
+++ memcached.c
@@ -288,7 +288,7 @@ static int add_msghdr(conn *c)
c->msgbytes = 0;
c->msgused++;
@ -9,7 +9,7 @@
/* Leave room for the UDP header, which we'll fill in later. */
return add_iov(c, NULL, UDP_HEADER_SIZE);
}
@@ -424,7 +424,7 @@
@@ -432,7 +432,7 @@ conn *conn_new(const int sfd, enum conn_
if (init_state == conn_listening) {
fprintf(stderr, "<%d server listening (%s)\n", sfd,
prot_text(c->protocol));
@ -18,7 +18,7 @@
fprintf(stderr, "<%d server listening (udp)\n", sfd);
} else if (c->protocol == negotiating_prot) {
fprintf(stderr, "<%d new auto-negotiating client connection\n",
@@ -523,7 +523,7 @@
@@ -531,7 +531,7 @@ static void conn_cleanup(conn *c) {
c->sasl_conn = NULL;
}
@ -27,7 +27,7 @@
conn_set_state(c, conn_read);
}
}
@@ -593,7 +593,7 @@
@@ -601,7 +601,7 @@ static void conn_close(conn *c) {
static void conn_shrink(conn *c) {
assert(c != NULL);
@ -36,7 +36,7 @@
return;
if (c->rsize > READ_BUFFER_HIGHWAT && c->rbytes < DATA_BUFFER_SIZE) {
@@ -3989,7 +3989,7 @@
@@ -4022,7 +4022,7 @@ static enum transmit_result transmit(con
if (settings.verbose > 0)
perror("Failed to write, and not due to blocking");
@ -45,7 +45,7 @@
conn_set_state(c, conn_read);
else
conn_set_state(c, conn_closing);
@@ -4313,7 +4313,7 @@
@@ -4346,7 +4346,7 @@ static void drive_machine(conn *c) {
break;
case conn_closing:
@ -54,7 +54,7 @@
conn_cleanup(c);
else
conn_close(c);
@@ -4473,7 +4473,7 @@
@@ -4506,7 +4506,7 @@ static int server_socket(const char *int
#endif
setsockopt(sfd, SOL_SOCKET, SO_REUSEADDR, (void *)&flags, sizeof(flags));
@ -63,7 +63,7 @@
maximize_sndbuf(sfd);
} else {
error = setsockopt(sfd, SOL_SOCKET, SO_KEEPALIVE, (void *)&flags, sizeof(flags));
@@ -4528,7 +4528,7 @@
@@ -4561,7 +4561,7 @@ static int server_socket(const char *int
}
}

View file

@ -1,6 +1,6 @@
--- thread.c.orig 2015-01-16 16:22:19.000000000 +0000
+++ thread.c 2015-01-16 16:22:27.000000000 +0000
@@ -409,7 +409,7 @@
--- thread.c.orig 2015-04-20 05:34:19 UTC
+++ thread.c
@@ -402,7 +402,7 @@ static void thread_libevent_process(int
conn *c = conn_new(item->sfd, item->init_state, item->event_flags,
item->read_buffer_size, item->transport, me->base);
if (c == NULL) {