ports/math/py-diffcp/files/patch-pyproject.toml

15 lines
532 B
TOML

--- pyproject.toml.orig 2024-06-19 18:46:39 UTC
+++ pyproject.toml
@@ -2,9 +2,9 @@ requires = [
requires = [
"numpy>=1.15,<1.16; python_version=='3.7'",
"numpy>=1.17,<1.18; python_version=='3.8'",
- "numpy>=1.19,<1.20; python_version=='3.9'",
- "numpy>=1.21,<1.22; python_version=='3.10'",
- "numpy>=1.23,<1.24; python_version=='3.11'",
+ "numpy; python_version=='3.9'",
+ "numpy; python_version=='3.10'",
+ "numpy; python_version=='3.11'",
"scipy>=1.1.0",
"pybind11>=2.4",
"setuptools",