ports/mail/sympa/files/patch-Makefile.am
Kai Knoblich f72d303288 mail/sympa: Update to 6.2.44
Changelog since 6.2.42:

* Indentation of web templates are corrected. Though this change will not
  affect functionality, administrators might have to apply their
  customization to the new templates again.
* WWSympa: TLS client authentication: Now it gets rfc822Name in X.509v3
  subjectAltName, otherwise emailAddress attribute in subject DN. Note
  that earlier efforts getting attribute such as MAIL, Email in subject DN
  are no longer supported.
* ARC: Now Mail-DKIM 0.55 or better is required for ARC support.
* WWSympa: Admin function to bulk unsubscribe which has been provided by
  6.1.x was restored

Fixed bugs:

* "Use of uninitialized value $salt" on --import
* Improve handling of missing sympa/web_tt2 during upgrade

Merged pull requests:

* Support Test::Compile 2.0.0
* Remove all unneeded files from foundation-icons directory

PR:		238784
Submitted by:	Geoffroy Desvernay <dgeo@centrale-marseille.fr> (maintainer)
Reported by:	Daniel <d.stoye@cms.hu-berlin.de>
MFH:		2019Q3
2019-07-26 11:34:50 +00:00

53 lines
2.5 KiB
Text

--- Makefile.am.orig 2019-06-21 03:28:22 UTC
+++ Makefile.am
@@ -132,24 +132,24 @@ installdir:
installconfig: installdir
@echo "Installing basic configuration ..."
- -@if [ ! -f $(DESTDIR)$(confdir)/sympa.conf ]; then \
- echo "installing sympa.conf"; \
- $(INSTALL) -m 640 sympa.conf $(DESTDIR)$(confdir); \
- chown $(USER) $(DESTDIR)$(confdir)/sympa.conf; \
- chgrp $(GROUP) $(DESTDIR)$(confdir)/sympa.conf; \
+ -@if [ ! -f $(DESTDIR)$(confdir)/sympa.conf.sample ]; then \
+ echo "installing sympa.conf.sample"; \
+ $(INSTALL) -m 640 sympa.conf $(DESTDIR)$(confdir)/sympa.conf.sample; \
+ chown $(USER) $(DESTDIR)$(confdir)/sympa.conf.sample; \
+ chgrp $(GROUP) $(DESTDIR)$(confdir)/sympa.conf.sample; \
fi
@echo "Installing configuration template ..."
-@echo "installing sympa.conf-dist"; \
- $(INSTALL) -m 644 -T sympa.conf-dist $(DESTDIR)$(confdir)/sympa.conf-dist; \
+ $(INSTALL) -m 644 sympa.conf-dist $(DESTDIR)$(confdir)/sympa.conf-dist; \
chown $(USER) $(DESTDIR)$(confdir)/sympa.conf-dist; \
chgrp $(GROUP) $(DESTDIR)$(confdir)/sympa.conf-dist
- -@if [ ! -f $(DESTDIR)$(sysconfdir)/data_structure.version ]; then \
+ -@if [ ! -f $(DESTDIR)$(sysconfdir)/data_structure.version.sample ]; then \
cd $(DESTDIR)$(sysconfdir); \
- echo "# automatically created file" >> data_structure.version; \
- echo "# you should not modify it" >> data_structure.version; \
- echo $(VERSION) >> data_structure.version; \
- chown $(USER) data_structure.version; \
- chgrp $(GROUP) data_structure.version; \
+ echo "# automatically created file" >> data_structure.version.sample; \
+ echo "# you should not modify it" >> data_structure.version.sample; \
+ echo $(VERSION) >> data_structure.version.sample; \
+ chown $(USER) data_structure.version.sample; \
+ chgrp $(GROUP) data_structure.version.sample; \
fi
-@for dir in create_list_templates custom_actions custom_conditions \
data_sources families tasks \
@@ -197,10 +197,10 @@ nextstep:
@echo "#######################################################"
uninstall-hook:
- cd $(DESTDIR)$(confdir) && rm -f sympa.conf
+ cd $(DESTDIR)$(confdir) && rm -f sympa.conf.sample
cd $(DESTDIR)$(confdir) && rm -f sympa.conf-dist
- cd $(DESTDIR)$(confdir) && rm -f wwsympa.conf
- cd $(DESTDIR)$(sysconfdir) && rm -f data_structure.version
+ cd $(DESTDIR)$(confdir) && rm -f wwsympa.conf.sample
+ cd $(DESTDIR)$(sysconfdir) && rm -f data_structure.version.sample
cd $(DESTDIR)$(sysconfdir) && rm -f README
DISTCHECK_CONFIGURE_FLAGS = --enable-fhs --with-perl=$(PERL)