ports/mail/mew/files/patch-info__Makefile
Kurt Jaeger 46e9bf7367 mail/mew: update 6.7 -> 6.8
- Mew now supports Emacs 24.3 or later only
- Supporting stunnel 5.
- Supporting GnuPG 2.1.23 or later.
  The command name should be "gpg" instead of "gpg2".
  Put the following to your "~/.gnupg/gpg.conf".
      no-auto-key-retrieve
      auto-key-locate local
- Using LibreOffice (soffice) on Unix by default
- Regenerate patches to fix portlint warnings.

PR:		228861
Submitted by:	Yasuhiro KIMURA <yasu@utahime.org>
Approved by:	hiroto.kagotani@gmail.com (maintainer timeout)
Relnotes:	http://www.mew.org/en/relnote/release.html
2018-07-29 18:41:19 +00:00

37 lines
965 B
Text

--- info/Makefile.orig 2018-06-07 05:48:29 UTC
+++ info/Makefile
@@ -15,7 +15,7 @@
## EDIT THE FOLLOWINGS
##
-prefix=/usr/local
+prefix=${PREFIX}
infodir=$(prefix)/info
EMACS=emacs
@@ -48,20 +48,20 @@ all: info
info:
sed -e 's/@setfilename mew.ja.info/@setfilename mew.info/' \
-e 's/@set ja/@set en/' mew.texi > tmp.texi
- mv tmp.texi mew.texi
$(RM) mew.info*
$(TOUCH) mew.info
$(EMACS) -batch -q -no-site-file -l texinfmt \
- -f batch-texinfo-format mew.texi
+ -f batch-texinfo-format tmp.texi
+ $(RM) tmp.texi
jinfo:
sed -e 's/@setfilename mew.info/@setfilename mew.ja.info/' \
- -e 's/@set en/@set ja/' mew.texi > tmp.texi
- mv tmp.texi mew.texi
+ -e 's/@set en/@set ja/' mew.texi > tmp.ja.texi
$(RM) mew.ja.info*
$(TOUCH) mew.ja.info
$(EMACS) -batch -q -no-site-file -l texinfmt \
- -f batch-texinfo-format mew.texi
+ -f batch-texinfo-format tmp.ja.texi
+ $(RM) tmp.ja.texi
install: install-info
install-info: