mirror of
https://git.freebsd.org/ports.git
synced 2025-05-29 09:26:27 -04:00
Update the referenced master port and included version.mk file. The patches are not relevant for ossec-hids-local, but have to be added there to become effective in ossec-hids-agents.
19 lines
612 B
C
19 lines
612 B
C
--- src/client-agent/agentd.c.orig 2020-02-14 19:46:22 UTC
|
|
+++ src/client-agent/agentd.c
|
|
@@ -15,6 +15,8 @@
|
|
#include "os_dns/os_dns.h"
|
|
#endif //WIN32
|
|
|
|
+struct imsgbuf server_ibuf;
|
|
+
|
|
/* Start the agent daemon */
|
|
void AgentdStart(const char *dir, int uid, int gid, const char *user, const char *group)
|
|
{
|
|
@@ -39,7 +41,6 @@ void AgentdStart(const char *dir, int uid, int gid, co
|
|
merror("starting imsg stuff");
|
|
/* Prepare for os_dns */
|
|
struct imsgbuf osdns_ibuf;
|
|
- extern struct imsgbuf server_ibuf;
|
|
//struct imsgbuf osdns_ibuf;
|
|
int imsg_fds[2];
|
|
merror("Creating socketpair()");
|