mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 15:36:35 -04:00
The option is a linker option but is passed to cc verbatim, and this causes fallout complaints on head i386 (13): --- lemon --- cc -o lemon lemon.o -export-dynamic ld: warning: cannot find entry symbol xport-dynamic; defaulting to 0x4049B0 ===> making all in src --- all --- --- auth-ldap.o --- cc -fPIC -O2 -pipe -fPIC -fstack-protector-strong -DLDAP_DEPRECATED -fno-strict-aliasing -Wno-import -L/usr/local/lib -I/usr/local/include -fPIC -I/usr/local/include -D_THREAD_SAFE -fobjc-exceptions -fno-strict-aliasing -O2 -pipe -fPIC -fstack-protector-strong -DLDAP_DEPRECATED -fno-strict-aliasing -DHAVE_CONFIG_H -Wall -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -c auth-ldap.m -o auth-ldap.o -I. -I../src -I.. -I../src -I. -I../tests -I../tests --- TRConfigParser.m --- ./tools/lemon -T../tools/lempar.c -m -q TRConfigParser.lemon -OTRConfigParser.m Segmentation fault (core dumped) *** [TRConfigParser.m] Error code 139 NOTE! With devel/check exactly at 0.15.1, this fails to build due to a regression in check 0.15.1. 0.15.0 is fine, and the bug is reported here: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=248274 (FreeBSD) https://github.com/libcheck/check/issues/293 (upstream) http://beefy17.nyi.freebsd.org/data/head-i386-default/p543393_s363499/logs/openvpn-auth-ldap-2.0.4.log This is more fallout to permit narrowing down failures: =>> Building security/openvpn-auth-ldap build started at Sun Jul 26 01:01:36 UTC 2020 port directory: /usr/ports/security/openvpn-auth-ldap package name: openvpn-auth-ldap-2.0.4 building for: FreeBSD head-i386-default-job-12 13.0-CURRENT FreeBSD 13.0-CURRENT 1300101 i386 maintained by: mandree@FreeBSD.org Makefile ident: $FreeBSD: head/security/openvpn-auth-ldap/Makefile 527679 2020-03-03 15:11:46Z mat $ Poudriere version: 3.2.8-5-gc81843e5 Host OSVERSION: 1300100 Jail OSVERSION: 1300101 Job Id: 12 !!! Jail is newer than host. (Jail: 1300101, Host: 1300100) !!! !!! This is not supported. !!! !!! Host kernel must be same or newer than jail. !!! !!! Expect build failures. !!! ---Begin Environment--- SHELL=/bin/csh UNAME_p=i386 UNAME_m=i386 OSVERSION=1300101 UNAME_v=FreeBSD 13.0-CURRENT 1300101 UNAME_r=13.0-CURRENT BLOCKSIZE=K MAIL=/var/mail/root STATUS=1 HOME=/root PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin LOCALBASE=/usr/local USER=root LIBEXECPREFIX=/usr/local/libexec/poudriere POUDRIERE_VERSION=3.2.8-5-gc81843e5 MASTERMNT=/usr/local/poudriere/data/.m/head-i386-default/ref POUDRIERE_BUILD_TYPE=bulk PACKAGE_BUILDING=yes SAVED_TERM= PWD=/usr/local/poudriere/data/.m/head-i386-default/ref/.p/pool P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS MASTERNAME=head-i386-default SCRIPTPREFIX=/usr/local/share/poudriere OLDPWD=/usr/local/poudriere/data/.m/head-i386-default/ref/.p SCRIPTPATH=/usr/local/share/poudriere/bulk.sh POUDRIEREPATH=/usr/local/bin/poudriere ---End Environment---
11 lines
270 B
Text
11 lines
270 B
Text
--- platform.m4.orig 2018-07-26 20:17:21 UTC
|
|
+++ platform.m4
|
|
@@ -97,7 +97,7 @@ AC_DEFUN(OD_CONFIG_PLUGIN, [
|
|
PLUGIN_LD="${CC} -shared"
|
|
PLUGIN_LD_FLAGS=""
|
|
PLUGIN_SUFFIX=".so"
|
|
- LDFLAGS="-export-dynamic"
|
|
+ LDFLAGS="-rdynamic"
|
|
;;
|
|
esac
|
|
|