mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 07:26:29 -04:00
Changelog: https://github.com/intel/intel-ipsec-mb/releases/tag/v1.1 Backport upstream commit 3a1c8c1c2c24a9d6cb56439c6aa6bea4d4fb1093 to fix compilation Set MAKE_JOBS_UNSAFE to avoid OOM issues Set rpath to avoid requirement of installing port to run test(s) PR: 260961 Reviewed by: Martin Filla <freebsd@sysctl.cz> (maintainer)
15 lines
442 B
Text
15 lines
442 B
Text
--- test/Makefile.orig 2022-01-05 18:18:41 UTC
|
|
+++ test/Makefile
|
|
@@ -139,10 +139,10 @@ endif
|
|
all: $(TEST_APP) $(XVALID_APP) $(FUZZ_APP)
|
|
|
|
$(TEST_APP): $(OBJECTS)
|
|
- $(CC) $(LDFLAGS) $^ $(LDLIBS) -o $@
|
|
+ $(CC) $(LDFLAGS) $^ $(LDLIBS) -Wl,-rpath,. -o $@
|
|
|
|
$(XVALID_APP): $(XVALID_OBJECTS)
|
|
- $(CC) $(LDFLAGS) $^ $(LDLIBS) -o $@
|
|
+ $(CC) $(LDFLAGS) $^ $(LDLIBS) -Wl,-rpath,. -o $@
|
|
|
|
$(FUZZ_APP): $(FUZZ_SOURCES)
|
|
ifneq (, $(shell which clang))
|