mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 15:36:35 -04:00
378 lines
17 KiB
Text
378 lines
17 KiB
Text
--- Makefile.in.orig 2021-02-09 13:32:54 UTC
|
|
+++ Makefile.in
|
|
@@ -95,11 +95,10 @@ PRE_UNINSTALL = :
|
|
POST_UNINSTALL = :
|
|
build_triplet = @build@
|
|
host_triplet = @host@
|
|
-sbin_PROGRAMS = authtest$(EXEEXT) authenumerate$(EXEEXT) \
|
|
- authpasswd$(EXEEXT)
|
|
-bin_PROGRAMS = courierauthconfig$(EXEEXT)
|
|
-noinst_PROGRAMS = authdaemontest$(EXEEXT) authmksock$(EXEEXT) \
|
|
- authdaemondprog$(EXEEXT)
|
|
+@HAVE_BASE_TRUE@sbin_PROGRAMS = authtest$(EXEEXT) authenumerate$(EXEEXT)
|
|
+@HAVE_BASE_TRUE@bin_PROGRAMS = courierauthconfig$(EXEEXT)
|
|
+@HAVE_BASE_TRUE@noinst_PROGRAMS = authdaemontest$(EXEEXT) authmksock$(EXEEXT) \
|
|
+@HAVE_BASE_TRUE@ authdaemondprog$(EXEEXT)
|
|
subdir = .
|
|
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
|
am__aclocal_m4_deps = $(top_srcdir)/configure.ac
|
|
@@ -220,6 +219,13 @@ libcourierauth_la_DEPENDENCIES = libs/libhmac/libhmac.
|
|
libs/md5/libmd5.la libs/sha1/libsha1.la \
|
|
libs/numlib/libnumlib.la libs/random128/librandom128.la \
|
|
libs/rfc822/libencode.la
|
|
+am_libauthvchkpw_la_OBJECTS = authvchkpw.lo authvchkpwlib.lo \
|
|
+ preauthvchkpw.lo
|
|
+libauthvchkpw_la_OBJECTS = $(am_libauthvchkpw_la_OBJECTS)
|
|
+libauthvchkpw_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC \
|
|
+ $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=link $(CCLD) \
|
|
+ $(AM_CFLAGS) $(CFLAGS) $(libauthvchkpw_la_LDFLAGS) $(LDFLAGS) \
|
|
+ -o $@
|
|
am_libcourierauth_la_OBJECTS = authdaemon.lo authdaemonlib.lo \
|
|
preauthdaemon.lo authmoduser2.lo authmoduser3.lo debug.lo \
|
|
authoption.lo
|
|
@@ -336,7 +342,9 @@ am__depfiles_remade = ./$(DEPDIR)/authconfigfile.Plo \
|
|
./$(DEPDIR)/authsqlite.Plo ./$(DEPDIR)/authsqlitelib.Plo \
|
|
./$(DEPDIR)/authsyschangepwd.Plo ./$(DEPDIR)/authsyscommon.Plo \
|
|
./$(DEPDIR)/authtest.Po ./$(DEPDIR)/authuserdb.Plo \
|
|
- ./$(DEPDIR)/authuserdbpwd.Plo ./$(DEPDIR)/checkpassword.Plo \
|
|
+ ./$(DEPDIR)/authuserdbpwd.Plo \
|
|
+ ./$(DEPDIR)/authvchkpw.Plo ./$(DEPDIR)/authvchkpwlib.Plo \
|
|
+ ./$(DEPDIR)/checkpassword.Plo \
|
|
./$(DEPDIR)/checkpasswordmd5.Plo \
|
|
./$(DEPDIR)/checkpasswordsha1.Plo ./$(DEPDIR)/cramlib.Plo \
|
|
./$(DEPDIR)/cryptpassword.Plo ./$(DEPDIR)/debug.Plo \
|
|
@@ -344,7 +352,7 @@ am__depfiles_remade = ./$(DEPDIR)/authconfigfile.Plo \
|
|
./$(DEPDIR)/preauthldap.Plo ./$(DEPDIR)/preauthmysql.Plo \
|
|
./$(DEPDIR)/preauthpam.Plo ./$(DEPDIR)/preauthpwd.Plo \
|
|
./$(DEPDIR)/preauthshadow.Plo ./$(DEPDIR)/preauthuserdb.Plo \
|
|
- ./$(DEPDIR)/preauthuserdbcommon.Plo
|
|
+ ./$(DEPDIR)/preauthuserdbcommon.Plo ./$(DEPDIR)/preauthvchkpw.Plo
|
|
am__mv = mv -f
|
|
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
|
|
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
|
@@ -387,6 +395,7 @@ SOURCES = $(libauthcustom_la_SOURCES) $(libauthldap_la
|
|
$(libauthpgsql_la_SOURCES) $(libauthpipe_la_SOURCES) \
|
|
$(libauthpwd_la_SOURCES) $(libauthshadow_la_SOURCES) \
|
|
$(libauthsqlite_la_SOURCES) $(libauthuserdb_la_SOURCES) \
|
|
+ $(libauthvchkpw_la_SOURCES) \
|
|
$(libcourierauth_la_SOURCES) \
|
|
$(libcourierauthcommon_la_SOURCES) \
|
|
$(libcourierauthsasl_la_SOURCES) \
|
|
@@ -400,6 +409,7 @@ DIST_SOURCES = $(libauthcustom_la_SOURCES) $(libauthld
|
|
$(libauthpgsql_la_SOURCES) $(libauthpipe_la_SOURCES) \
|
|
$(libauthpwd_la_SOURCES) $(libauthshadow_la_SOURCES) \
|
|
$(libauthsqlite_la_SOURCES) $(libauthuserdb_la_SOURCES) \
|
|
+ $(libauthvchkpw_la_SOURCES) \
|
|
$(libcourierauth_la_SOURCES) \
|
|
$(libcourierauthcommon_la_SOURCES) \
|
|
$(libcourierauthsasl_la_SOURCES) \
|
|
@@ -568,6 +578,7 @@ LIBAUTHPWD = @LIBAUTHPWD@
|
|
LIBAUTHSHADOW = @LIBAUTHSHADOW@
|
|
LIBAUTHSQLITE = @LIBAUTHSQLITE@
|
|
LIBAUTHUSERDB = @LIBAUTHUSERDB@
|
|
+LIBAUTHVCHKPW = @LIBAUTHVCHKPW@
|
|
LIBDB = @LIBDB@
|
|
LIBDL = @LIBDL@
|
|
LIBGDBM = @LIBGDBM@
|
|
@@ -695,7 +706,10 @@ top_builddir = @top_builddir@
|
|
top_srcdir = @top_srcdir@
|
|
userdb = @userdb@
|
|
AUTOMAKE_OPTIONS = dist-bzip2
|
|
-SUBDIRS = libs/gdbmobj libs/bdbobj libs/md5 libs/sha1 libs/libhmac libs/numlib libs/makedat userdb libs/rfc822 libs/random128 libs/liblock liblog
|
|
+SUBDIRS = libs/gdbmobj libs/bdbobj libs/md5 libs/sha1 libs/libhmac libs/numlib
|
|
+@HAVE_USERDB_TRUE@SUBDIRS += libs/makedat userdb
|
|
+SUBDIRS += libs/rfc822 libs/random128
|
|
+@HAVE_BASE_TRUE@SUBDIRS += libs/liblock liblog
|
|
AM_CPPFLAGS = -I liblock $(LTDLINCL)
|
|
BUILT_SOURCES = authdaemonrc.h $(BUILT1) $(GITFILES) \
|
|
$(man3:%.3=%.html) $(man1:%.1=%.html) authsqliterc.h \
|
|
@@ -703,16 +717,18 @@ BUILT_SOURCES = authdaemonrc.h $(BUILT1) $(GITFILES) \
|
|
modules = @LIBAUTHUSERDB@ \
|
|
@LIBAUTHPAM@ @LIBAUTHPWD@ @LIBAUTHSHADOW@ \
|
|
@LIBAUTHPGSQL@ @LIBAUTHLDAP@ @LIBAUTHMYSQL@ @LIBAUTHSQLITE@ \
|
|
- @LIBAUTHCUSTOM@ @LIBAUTHPIPE@
|
|
+ @LIBAUTHCUSTOM@ @LIBAUTHVCHKPW@ @LIBAUTHPIPE@
|
|
|
|
pkglibexec_SCRIPTS = authsystem.passwd
|
|
-pkglib_LTLIBRARIES = libcourierauth.la \
|
|
- libcourierauthcommon.la libcourierauthsasl.la libcourierauthsaslclient.la \
|
|
- $(modules)
|
|
+@HAVE_BASE_TRUE@pkglib_LTLIBRARIES = libcourierauth.la \
|
|
+@HAVE_BASE_TRUE@ libcourierauthcommon.la libcourierauthsasl.la libcourierauthsaslclient.la \
|
|
+@HAVE_BASE_TRUE@ $(modules)
|
|
+@HAVE_BASE_FALSE@pkglib_LTLIBRARIES = $(modules)
|
|
|
|
sbin_SCRIPTS = authdaemond
|
|
EXTRA_LTLIBRARIES = libauthuserdb.la \
|
|
libauthpam.la libauthpwd.la libauthshadow.la \
|
|
+ libauthvchkpw.la \
|
|
libauthpgsql.la \
|
|
libauthldap.la \
|
|
libauthmysql.la \
|
|
@@ -785,6 +801,13 @@ libauthshadow_la_DEPENDENCIES = $(commonlibdep)
|
|
libauthshadow_la_LIBADD = $(commonlibadd) $(libauthshadow_t)
|
|
libauthshadow_la_LDFLAGS = $(commonldflags)
|
|
|
|
+# The authvchkpw module
|
|
+libauthvchkpw_t = @VPOPMAILLIBS@ @LIBM@
|
|
+libauthvchkpw_la_SOURCES = authvchkpw.c authvchkpwlib.c preauthvchkpw.c
|
|
+libauthvchkpw_la_DEPENDENCIES = $(commonlibdep)
|
|
+libauthvchkpw_la_LIBADD = $(commonlibadd) $(libauthvchkpw_t)
|
|
+libauthvchkpw_la_LDFLAGS = $(commonldflags)
|
|
+
|
|
# The authpgsql module
|
|
libauthpgsql_t = @PGSQL_LIBS@ @LIBM@ @NETLIBS@
|
|
libauthpgsql_la_SOURCES = authpgsql.c authpgsqllib.cpp authpgsql.h
|
|
@@ -867,8 +890,8 @@ libcourierauthsaslclient_la_SOURCES = courierauthsaslc
|
|
|
|
libcourierauthsaslclient_la_LIBADD = libcourierauth.la
|
|
libcourierauthsaslclient_la_LDFLAGS = -export-symbols-regex '^auth_sasl_client$$' -version-info @VERSION_INFO@
|
|
-include_HEADERS = courierauth.h courierauthsasl.h \
|
|
- courierauthsaslclient.h courierauthdebug.h courierauthstaticlist.h
|
|
+@HAVE_BASE_TRUE@include_HEADERS = courierauth.h courierauthsasl.h \
|
|
+@HAVE_BASE_TRUE@ courierauthsaslclient.h courierauthdebug.h courierauthstaticlist.h
|
|
|
|
courierauthconfig_SOURCES = authinfo.c
|
|
authpasswd_SOURCES = authpasswd.c
|
|
@@ -914,7 +937,7 @@ man3 = authlib.3 auth_generic.3 auth_login.3 auth_getu
|
|
extraman3 = auth_generic_meta.3 auth_login_meta.3 auth_getuserinfo_meta.3 \
|
|
auth_sasl_ex.3
|
|
|
|
-man1 = authpasswd.1 authtest.1
|
|
+man1 = authtest.1
|
|
man_MANS = $(man1) $(man3) $(extraman3)
|
|
BUILT1 = authlib.html authldaprc.h authmysqlrc.h authpgsqlrc.h authpiperc.h \
|
|
authdaemonrc.h packageversion.h \
|
|
@@ -1174,6 +1197,9 @@ libauthsqlite.la: $(libauthsqlite_la_OBJECTS) $(libaut
|
|
libauthuserdb.la: $(libauthuserdb_la_OBJECTS) $(libauthuserdb_la_DEPENDENCIES) $(EXTRA_libauthuserdb_la_DEPENDENCIES)
|
|
$(AM_V_CCLD)$(libauthuserdb_la_LINK) $(libauthuserdb_la_OBJECTS) $(libauthuserdb_la_LIBADD) $(LIBS)
|
|
|
|
+libauthvchkpw.la: $(libauthvchkpw_la_OBJECTS) $(libauthvchkpw_la_DEPENDENCIES)
|
|
+ $(AM_V_CCLD)$(libauthvchkpw_la_LINK) $(libauthvchkpw_la_OBJECTS) $(libauthvchkpw_la_LIBADD) $(LIBS)
|
|
+
|
|
libcourierauth.la: $(libcourierauth_la_OBJECTS) $(libcourierauth_la_DEPENDENCIES) $(EXTRA_libcourierauth_la_DEPENDENCIES)
|
|
$(AM_V_CCLD)$(libcourierauth_la_LINK) -rpath $(pkglibdir) $(libcourierauth_la_OBJECTS) $(libcourierauth_la_LIBADD) $(LIBS)
|
|
|
|
@@ -1337,6 +1363,8 @@ distclean-compile:
|
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/authtest.Po@am__quote@ # am--include-marker
|
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/authuserdb.Plo@am__quote@ # am--include-marker
|
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/authuserdbpwd.Plo@am__quote@ # am--include-marker
|
|
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/authvchkpw.Plo@am__quote@ # am--include-marker
|
|
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/authvchkpwlib.Plo@am__quote@ # am--include-marker
|
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/checkpassword.Plo@am__quote@ # am--include-marker
|
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/checkpasswordmd5.Plo@am__quote@ # am--include-marker
|
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/checkpasswordsha1.Plo@am__quote@ # am--include-marker
|
|
@@ -1352,6 +1380,7 @@ distclean-compile:
|
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/preauthshadow.Plo@am__quote@ # am--include-marker
|
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/preauthuserdb.Plo@am__quote@ # am--include-marker
|
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/preauthuserdbcommon.Plo@am__quote@ # am--include-marker
|
|
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/preauthvchkpw.Plo@am__quote@ # am--include-marker
|
|
|
|
$(am__depfiles_remade):
|
|
@$(MKDIR_P) $(@D)
|
|
@@ -1921,6 +1950,8 @@ distclean: distclean-recursive
|
|
-rm -f ./$(DEPDIR)/authtest.Po
|
|
-rm -f ./$(DEPDIR)/authuserdb.Plo
|
|
-rm -f ./$(DEPDIR)/authuserdbpwd.Plo
|
|
+ -rm -f ./$(DEPDIR)/authvchkpw.Plo
|
|
+ -rm -f ./$(DEPDIR)/authvchkpwlib.Plo
|
|
-rm -f ./$(DEPDIR)/checkpassword.Plo
|
|
-rm -f ./$(DEPDIR)/checkpasswordmd5.Plo
|
|
-rm -f ./$(DEPDIR)/checkpasswordsha1.Plo
|
|
@@ -1936,6 +1967,7 @@ distclean: distclean-recursive
|
|
-rm -f ./$(DEPDIR)/preauthshadow.Plo
|
|
-rm -f ./$(DEPDIR)/preauthuserdb.Plo
|
|
-rm -f ./$(DEPDIR)/preauthuserdbcommon.Plo
|
|
+ -rm -f ./$(DEPDIR)/preauthvchkpw.Plo
|
|
-rm -f Makefile
|
|
distclean-am: clean-am distclean-compile distclean-generic \
|
|
distclean-hdr distclean-libtool distclean-tags
|
|
@@ -1952,18 +1984,26 @@ info: info-recursive
|
|
|
|
info-am:
|
|
|
|
-install-data-am: install-includeHEADERS install-man
|
|
- @$(NORMAL_INSTALL)
|
|
- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
|
|
+@HAVE_BASE_TRUE@install-data-am: install-includeHEADERS install-man
|
|
+@HAVE_BASE_TRUE@ @$(NORMAL_INSTALL)
|
|
+@HAVE_BASE_TRUE@ $(MAKE) $(AM_MAKEFLAGS) install-data-hook
|
|
+
|
|
+@HAVE_BASE_FALSE@install-data-am:
|
|
+@HAVE_BASE_FALSE@ $(MAKE) $(AM_MAKEFLAGS) install-data-hook
|
|
+
|
|
install-dvi: install-dvi-recursive
|
|
|
|
install-dvi-am:
|
|
|
|
-install-exec-am: install-binPROGRAMS install-pkglibLTLIBRARIES \
|
|
- install-pkglibexecSCRIPTS install-sbinPROGRAMS \
|
|
- install-sbinSCRIPTS
|
|
- @$(NORMAL_INSTALL)
|
|
- $(MAKE) $(AM_MAKEFLAGS) install-exec-hook
|
|
+@HAVE_BASE_TRUE@install-exec-am: install-binPROGRAMS install-pkglibLTLIBRARIES \
|
|
+@HAVE_BASE_TRUE@ install-pkglibexecSCRIPTS install-sbinPROGRAMS \
|
|
+@HAVE_BASE_TRUE@ install-sbinSCRIPTS
|
|
+@HAVE_BASE_TRUE@ @$(NORMAL_INSTALL)
|
|
+@HAVE_BASE_TRUE@ $(MAKE) $(AM_MAKEFLAGS) install-exec-hook
|
|
+
|
|
+@HAVE_BASE_FALSE@install-exec-am: install-pkglibLTLIBRARIES
|
|
+@HAVE_BASE_FALSE@ $(MAKE) $(AM_MAKEFLAGS) install-exec-hook
|
|
+
|
|
install-html: install-html-recursive
|
|
|
|
install-html-am:
|
|
@@ -2105,13 +2145,16 @@ uninstall-man: uninstall-man1 uninstall-man3
|
|
|
|
.PRECIOUS: Makefile
|
|
|
|
+authvchkpw.lo: authvchkpw.c vpopmail_config.h
|
|
+preauthvchkpw.lo: preauthvchkpw.c vpopmail_config.h
|
|
+
|
|
+vpopmail_config.h:
|
|
+ echo '#include "@vpopmail_home@/include/config.h"' >vpopmail_config.h
|
|
|
|
@HAVE_AUTHPGSQL_TRUE@install-authpgsqlrc:
|
|
@HAVE_AUTHPGSQL_TRUE@ $(mkinstalldirs) $(DESTDIR)`dirname @authpgsqlrc@` || :
|
|
@HAVE_AUTHPGSQL_TRUE@ $(INSTALL_DATA) -m 660 $(srcdir)/authpgsqlrc \
|
|
@HAVE_AUTHPGSQL_TRUE@ $(DESTDIR)@authpgsqlrc@.dist
|
|
-@HAVE_AUTHPGSQL_TRUE@ -chown @mailuser@ $(DESTDIR)@authpgsqlrc@.dist
|
|
-@HAVE_AUTHPGSQL_TRUE@ -chgrp @mailgroup@ $(DESTDIR)@authpgsqlrc@.dist
|
|
|
|
@HAVE_AUTHPGSQL_TRUE@uninstall-authpgsqlrc:
|
|
@HAVE_AUTHPGSQL_TRUE@ rm -f $(DESTDIR)@authpgsqlrc@.dist
|
|
@@ -2129,8 +2172,6 @@ authpgsqlrc.h:
|
|
@HAVE_LDAP_TRUE@ $(mkinstalldirs) $(DESTDIR)`dirname @authldaprc@` || :
|
|
@HAVE_LDAP_TRUE@ $(INSTALL_DATA) -m 660 $(srcdir)/authldaprc \
|
|
@HAVE_LDAP_TRUE@ $(DESTDIR)@authldaprc@.dist
|
|
-@HAVE_LDAP_TRUE@ -chown @mailuser@ $(DESTDIR)@authldaprc@.dist
|
|
-@HAVE_LDAP_TRUE@ -chgrp @mailgroup@ $(DESTDIR)@authldaprc@.dist
|
|
|
|
@HAVE_LDAP_TRUE@uninstall-authldaprc:
|
|
@HAVE_LDAP_TRUE@ rm -f $(DESTDIR)@authldaprc@.dist
|
|
@@ -2141,6 +2182,18 @@ authpgsqlrc.h:
|
|
@HAVE_LDAP_FALSE@uninstall-authldaprc:
|
|
@HAVE_LDAP_FALSE@ @:
|
|
|
|
+@HAVE_LDAP_TRUE@install-ldapschema:
|
|
+@HAVE_LDAP_TRUE@ $(mkinstalldirs) ${DESTDIR}${sysconfdir}/openldap/schema
|
|
+@HAVE_LDAP_TRUE@ $(INSTALL_DATA) -m 0444 $(srcdir)/authldap.schema \
|
|
+@HAVE_LDAP_TRUE@ ${DESTDIR}${sysconfdir}/openldap/schema/authldap.schema.dist
|
|
+@HAVE_LDAP_TRUE@# if test ! -f ${sysconfdir}/openldap/schema/authldap.schema ; then \
|
|
+@HAVE_LDAP_TRUE@# $(INSTALL_DATA) -m 0444 $(srcdir)/authldap.schema \
|
|
+@HAVE_LDAP_TRUE@# ${sysconfdir}/openldap/schema/authldap.schema ; \
|
|
+@HAVE_LDAP_TRUE@# fi
|
|
+
|
|
+@HAVE_LDAP_FALSE@install-ldapschema:
|
|
+@HAVE_LDAP_FALSE@ @:
|
|
+
|
|
authldaprc.h:
|
|
echo "#define AUTHLDAPRC \"@authldaprc@\"" >authldaprc.h
|
|
|
|
@@ -2148,8 +2201,6 @@ authldaprc.h:
|
|
@HAVE_AUTHMYSQL_TRUE@ $(mkinstalldirs) $(DESTDIR)`dirname @authmysqlrc@` || :
|
|
@HAVE_AUTHMYSQL_TRUE@ $(INSTALL_DATA) -m 660 $(srcdir)/authmysqlrc \
|
|
@HAVE_AUTHMYSQL_TRUE@ $(DESTDIR)@authmysqlrc@.dist
|
|
-@HAVE_AUTHMYSQL_TRUE@ -chown @mailuser@ $(DESTDIR)@authmysqlrc@.dist
|
|
-@HAVE_AUTHMYSQL_TRUE@ -chgrp @mailgroup@ $(DESTDIR)@authmysqlrc@.dist
|
|
|
|
@HAVE_AUTHMYSQL_TRUE@uninstall-authmysqlrc:
|
|
@HAVE_AUTHMYSQL_TRUE@ rm -f $(DESTDIR)@authmysqlrc@.dist
|
|
@@ -2167,8 +2218,6 @@ authmysqlrc.h:
|
|
@HAVE_AUTHSQLITE_TRUE@ $(mkinstalldirs) $(DESTDIR)`dirname @authsqliterc@` || :
|
|
@HAVE_AUTHSQLITE_TRUE@ $(INSTALL_DATA) -m 660 $(srcdir)/authsqliterc \
|
|
@HAVE_AUTHSQLITE_TRUE@ $(DESTDIR)@authsqliterc@.dist
|
|
-@HAVE_AUTHSQLITE_TRUE@ -chown @mailuser@ $(DESTDIR)@authsqliterc@.dist
|
|
-@HAVE_AUTHSQLITE_TRUE@ -chgrp @mailgroup@ $(DESTDIR)@authsqliterc@.dist
|
|
|
|
@HAVE_AUTHSQLITE_TRUE@uninstall-authsqliterc:
|
|
@HAVE_AUTHSQLITE_TRUE@ rm -f $(DESTDIR)@authsqliterc@.dist
|
|
@@ -2187,17 +2236,21 @@ authpipelib.lo: authpipelib.c authpipelib.h authpiperc
|
|
authpiperc.h:
|
|
echo "#define PIPE_PROGRAM \"@authProg@\"" >authpiperc.h
|
|
|
|
-install-authdaemonrc:
|
|
- $(mkinstalldirs) $(DESTDIR)`dirname @authdaemonrc@` || :
|
|
- sed 's/@ALLMODULES@/$(modules:lib%.la=%)/' <authdaemonrc >authdaemonrc.tmp
|
|
- $(INSTALL_DATA) -m 660 authdaemonrc.tmp $(DESTDIR)@authdaemonrc@.dist
|
|
- rm -f authdaemonrc.tmp
|
|
- -chown @mailuser@ $(DESTDIR)@authdaemonrc@.dist
|
|
- -chgrp @mailgroup@ $(DESTDIR)@authdaemonrc@.dist
|
|
+@HAVE_BASE_TRUE@install-authdaemonrc:
|
|
+@HAVE_BASE_TRUE@ $(mkinstalldirs) $(DESTDIR)`dirname @authdaemonrc@` || :
|
|
+@HAVE_BASE_TRUE@ sed 's/@ALLMODULES@/$(modules:lib%.la=%)/' <authdaemonrc >authdaemonrc.tmp
|
|
+@HAVE_BASE_TRUE@ $(INSTALL_DATA) -m 660 authdaemonrc.tmp $(DESTDIR)@authdaemonrc@.dist
|
|
+@HAVE_BASE_TRUE@ rm -f authdaemonrc.tmp
|
|
|
|
-uninstall-authdaemonrc:
|
|
- rm -f $(DESTDIR)@authdaemonrc@.dist
|
|
+@HAVE_BASE_FALSE@install-authdaemonrc:
|
|
+@HAVE_BASE_FALSE@ @:
|
|
+
|
|
+@HAVE_BASE_TRUE@uninstall-authdaemonrc:
|
|
+@HAVE_BASE_TRUE@ rm -f $(DESTDIR)@authdaemonrc@.dist
|
|
|
|
+@HAVE_BASE_FALSE@uninstall-authdaemonrc:
|
|
+@HAVE_BASE_FALSE@ @:
|
|
+
|
|
authdaemonrc.h:
|
|
echo "#define AUTHDAEMONRC \"@authdaemonrc@\"" >authdaemonrc.h
|
|
echo "#define AUTHDAEMONVAR \"@authdaemonvar@\"" >>authdaemonrc.h
|
|
@@ -2248,24 +2301,24 @@ dist-hook:
|
|
# automake still a bit stupid...
|
|
|
|
install-data-hook: install-authdaemonrc install-authpgsqlrc \
|
|
- install-authldaprc install-authmysqlrc install-authsqliterc
|
|
+ install-authldaprc install-ldapschema install-authmysqlrc install-authsqliterc
|
|
:
|
|
|
|
install-exec-hook:
|
|
- $(mkinstalldirs) $(DESTDIR)$(bindir) || :
|
|
- $(mkinstalldirs) $(DESTDIR)$(sbindir) || :
|
|
- $(mkinstalldirs) $(DESTDIR)$(pkglibexecdir) || :
|
|
- chmod 755 $(DESTDIR)$(pkglibexecdir)
|
|
- -chown @mailuser@ $(DESTDIR)$(pkglibexecdir)
|
|
- -chgrp @mailgroup@ $(DESTDIR)$(pkglibexecdir)
|
|
- $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) authdaemondprog $(DESTDIR)$(pkglibexecdir)/authdaemond
|
|
- $(mkinstalldirs) $(DESTDIR)@authdaemonvar@ || :
|
|
- chmod 750 $(DESTDIR)@authdaemonvar@
|
|
- -chown @mailuser@ $(DESTDIR)@authdaemonvar@
|
|
- -chgrp @mailgroup@ $(DESTDIR)@authdaemonvar@
|
|
+@HAVE_BASE_TRUE@ $(mkinstalldirs) $(DESTDIR)$(bindir) || :
|
|
+@HAVE_BASE_TRUE@ $(mkinstalldirs) $(DESTDIR)$(sbindir) || :
|
|
+@HAVE_BASE_TRUE@ $(mkinstalldirs) $(DESTDIR)$(pkglibexecdir) || :
|
|
+@HAVE_BASE_TRUE@ chmod 755 $(DESTDIR)$(pkglibexecdir)
|
|
+@HAVE_USERDB_TRUE@ $(mkinstalldirs) $(DESTDIR)$(pkglibexecdir) || :
|
|
+@HAVE_USERDB_TRUE@ chmod 755 $(DESTDIR)$(pkglibexecdir)
|
|
+@HAVE_BASE_TRUE@ $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) authdaemondprog $(DESTDIR)$(pkglibexecdir)/authdaemond
|
|
+@HAVE_BASE_TRUE@ $(mkinstalldirs) $(DESTDIR)@authdaemonvar@ || :
|
|
+@HAVE_BASE_TRUE@ chmod 750 $(DESTDIR)@authdaemonvar@
|
|
test "@LIBAUTHUSERDB@" = "" && exit 0 ;\
|
|
$(INSTALL_PROGRAM_ENV) $(INSTALL_PROGRAM) libs/makedat/makedatprog \
|
|
$(DESTDIR)$(pkglibexecdir)/makedatprog ; \
|
|
+ $(INSTALL_SCRIPT) userdb/vchkpw2userdb \
|
|
+ $(DESTDIR)$(sbindir)/vchkpw2userdb ; \
|
|
$(INSTALL_SCRIPT) userdb/pw2userdb \
|
|
$(DESTDIR)$(sbindir)/pw2userdb ; \
|
|
$(INSTALL_SCRIPT) userdb/makeuserdb \
|
|
@@ -2278,9 +2331,10 @@ install-exec-hook:
|
|
$(DESTDIR)$(sbindir)/userdb-test-cram-md5
|
|
|
|
uninstall-hook: uninstall-authldaprc uninstall-authdaemonrc uninstall-authmysqlrc uninstall-authpgsqlrc uninstall-authsqliterc
|
|
- rm -f $(DESTDIR)$(pkglibexecdir)/authdaemond
|
|
+@HAVE_BASE_TRUE@ rm -f $(DESTDIR)$(pkglibexecdir)/authdaemond
|
|
test "@AUTHUSERDB@" = "" && exit 0 ;\
|
|
rm -f $(DESTDIR)$(pkglibexecdir)/makedatprog \
|
|
+ $(DESTDIR)$(sbindir)/vchkpw2userdb \
|
|
$(DESTDIR)$(sbindir)/pw2userdb \
|
|
$(DESTDIR)$(sbindir)/makeuserdb \
|
|
$(DESTDIR)$(sbindir)/userdb \
|
|
@@ -2291,7 +2345,7 @@ authlib.html: authlib.html.in
|
|
$(SHELL) ./config.status --file=authlib.html
|
|
|
|
authlib.3: authlib.3.in
|
|
- $(SHELL) ./config.status --file=authlib.3
|
|
+@HAVE_BASE_TRUE@ $(SHELL) ./config.status --file=authlib.3
|
|
|
|
@HAVE_SGML_TRUE@authpasswd.html: authpasswd.sgml libs/docbook/sgml2html
|
|
@HAVE_SGML_TRUE@ libs/docbook/sgml2html authpasswd.sgml authpasswd.html
|