ports/lang/python310/files/patch-configure
Po-Chuan Hsieh fe8ed96054
lang/python310: Fix disabling uuid.h detection and stage-qa error
- Bump PORTREVISION for package change

====> Running Q/A tests (stage-qa)
Error: /usr/local/lib/python3.10/lib-dynload/_uuid.cpython-310.so is linked to /usr/local/lib/libuuid.so.1 from misc/e2fsprogs-libuuid but it is not declared as a dependency
Warning: you need LIB_DEPENDS+=libuuid.so:misc/e2fsprogs-libuuid
...
Warning: Possible REINPLACE_CMD issues:
- - REINPLACE_CMD ran, but did not modify file contents: setup.py
2022-08-27 18:26:11 +08:00

32 lines
964 B
Text

Disable the detection of includes and library from e2fsprogs-libuuid, which
introduces hidden dependency and breaks build
--- configure.orig 2022-08-01 20:25:27 UTC
+++ configure
@@ -6625,7 +6625,7 @@ fi
if test "$Py_LTO" = 'true' ; then
case $CC in
- *clang*)
+ *clang*|cc)
if test -n "$ac_tool_prefix"; then
# Extract the first word of "${ac_tool_prefix}llvm-ar", so it can be a program name with args.
@@ -10123,7 +10123,7 @@ fi
# Dynamic linking for HP-UX
# checks for uuid.h location
-for ac_header in uuid/uuid.h uuid.h
+for ac_header in uuid.h
do :
as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
ac_fn_c_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"
@@ -10141,7 +10141,7 @@ done
$as_echo_n "checking for uuid_generate_time_safe... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-#include <uuid/uuid.h>
+#include <uuid.h>
int
main ()
{