mirror of
https://git.freebsd.org/ports.git
synced 2025-04-29 01:56:37 -04:00
33 lines
1 KiB
Text
33 lines
1 KiB
Text
--- src/CMakeLists.txt.orig 2023-04-02 15:54:17 UTC
|
|
+++ src/CMakeLists.txt
|
|
@@ -25,6 +25,11 @@ if ( PULSE_SUPPORT )
|
|
set ( fluid_pulse_SOURCES drivers/fluid_pulse.c )
|
|
endif ( PULSE_SUPPORT )
|
|
|
|
+if ( SNDIO_SUPPORT )
|
|
+ set ( fluid_sndio_SOURCES drivers/fluid_sndio.c )
|
|
+ set ( SNDIO_LIBRARIES sndio )
|
|
+endif ( SNDIO_SUPPORT )
|
|
+
|
|
if ( ALSA_SUPPORT )
|
|
set ( fluid_alsa_SOURCES drivers/fluid_alsa.c )
|
|
endif ( ALSA_SUPPORT )
|
|
@@ -244,6 +249,7 @@ add_library ( libfluidsynth-OBJ OBJECT
|
|
${fluid_oss_SOURCES}
|
|
${fluid_portaudio_SOURCES}
|
|
${fluid_pulse_SOURCES}
|
|
+ ${fluid_sndio_SOURCES}
|
|
${fluid_dsound_SOURCES}
|
|
${fluid_wasapi_SOURCES}
|
|
${fluid_waveout_SOURCES}
|
|
@@ -362,6 +368,10 @@ endif()
|
|
if ( PULSE_SUPPORT )
|
|
target_include_directories( libfluidsynth-OBJ PRIVATE ${PULSEAUDIO_INCLUDE_DIRS} )
|
|
target_link_libraries ( libfluidsynth-OBJ PUBLIC ${PULSEAUDIO_LIBRARIES} )
|
|
+endif()
|
|
+
|
|
+if ( SNDIO_SUPPORT)
|
|
+ target_link_libraries ( libfluidsynth-OBJ PUBLIC ${SNDIO_LIBRARIES} )
|
|
endif()
|
|
|
|
if ( TARGET ALSA::ALSA AND ALSA_SUPPORT )
|