mirror of
https://git.freebsd.org/ports.git
synced 2025-05-28 17:06:32 -04:00
This is a partial revert of commit 60955c0a09
which removed transcode
and ports depending on it for not building with -fno-common.
multimedia/transcode: Revert removal of port
The transcode port has been fixed to build with -fno-common by adding
1 "extern" and 3 "static" keywords to prevent some global symbols to
be defined in multiple files that are linked into one binary.
While here fix a few issues reported by "make stage-qa".
multimedia/dvdrip: remove DEPRECATED
multimedia/mkxvcd: remove DEPRECATED
multimedia/subtitleripper: remove DEPRECATED
While here add TIMESTAMP to distinfo of these ports and make portlint
and portclippy happy.
multimedia/transcode: Add TIMESTAMP to distinfo
31 lines
1.4 KiB
Diff
31 lines
1.4 KiB
Diff
--- ./import/probe_ffmpeg.c.original 2013-04-22 20:04:51.058081388 +0200
|
|
+++ ./import/probe_ffmpeg.c 2013-04-22 20:05:25.744081897 +0200
|
|
@@ -109,7 +109,7 @@ void probe_ffmpeg(info_t *ipipe)
|
|
return;
|
|
}
|
|
|
|
- ret = av_find_stream_info(lavf_dmx_context);
|
|
+ ret = avformat_find_stream_info(lavf_dmx_context, NULL);
|
|
if (ret < 0) {
|
|
tc_log_error(__FILE__, "unable to fetch informations from '%s'"
|
|
" (libavformat failure)",
|
|
--- ./import/decode_lavc.c.original 2013-04-22 20:06:17.260082652 +0200
|
|
+++ ./import/decode_lavc.c 2013-04-22 20:07:47.564083975 +0200
|
|
@@ -170,7 +170,7 @@ void decode_lavc(decode_t *decode)
|
|
|
|
// Set these to the expected values so that ffmpeg's decoder can
|
|
// properly detect interlaced input.
|
|
- lavc_dec_context = avcodec_alloc_context();
|
|
+ lavc_dec_context = avcodec_alloc_context3(NULL);
|
|
if (lavc_dec_context == NULL) {
|
|
tc_log_error(__FILE__, "Could not allocate enough memory.");
|
|
goto decoder_error;
|
|
@@ -186,7 +186,7 @@ void decode_lavc(decode_t *decode)
|
|
lavc_dec_context->error_concealment = 3;
|
|
lavc_dec_context->workaround_bugs = FF_BUG_AUTODETECT;
|
|
|
|
- if (avcodec_open(lavc_dec_context, lavc_dec_codec) < 0) {
|
|
+ if (avcodec_open2(lavc_dec_context, lavc_dec_codec, NULL) < 0) {
|
|
tc_log_error(__FILE__, "Could not initialize the '%s' codec.",
|
|
codec->name);
|
|
goto decoder_error;
|