ports/multimedia/transcode/files/patch-import_extract__pcm.c
Stefan Eßer 9df78543e0 multimedia: Revert removal of transcode and dependent ports
This is a partial revert of commit 60955c0a09 which removed transcode
and ports depending on it for not building with -fno-common.

multimedia/transcode: Revert removal of port

The transcode port has been fixed to build with -fno-common by adding
1 "extern" and 3 "static" keywords to prevent some global symbols to
be defined in multiple files that are linked into one binary.

While here fix a few issues reported by "make stage-qa".

multimedia/dvdrip: remove DEPRECATED
multimedia/mkxvcd: remove DEPRECATED
multimedia/subtitleripper: remove DEPRECATED

While here add TIMESTAMP to distinfo of these ports and make portlint
and portclippy happy.

multimedia/transcode: Add TIMESTAMP to distinfo
2021-05-01 20:48:53 +02:00

11 lines
256 B
C

--- import/extract_pcm.c.orig 2011-11-19 16:50:27 UTC
+++ import/extract_pcm.c
@@ -33,7 +33,7 @@
#include "tc.h"
#define MAX_BUF 4096
-char audio[MAX_BUF];
+static char audio[MAX_BUF];
#define BUFFER_SIZE 262144
static uint8_t buffer[BUFFER_SIZE];