mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
23 lines
933 B
Text
23 lines
933 B
Text
--- Makefile.orig 2017-02-04 18:14:54 UTC
|
|
+++ Makefile
|
|
@@ -16,6 +16,7 @@ all:
|
|
@echo "Please specify target:"
|
|
@echo "(For example, type \"make linux\" for a Linux system.)"
|
|
@(cd makefiles && ls -C Makefile* | sed -e 's/Makefile.//g')
|
|
+ @(cd doc; $(MAKE) man)
|
|
|
|
.DEFAULT:
|
|
@- (cd Microline/XmL; if [ -f ../../makefiles/Makefile.$@ -a ! -f ./Makefile.$@ ];\
|
|
@@ -42,6 +43,12 @@ docs:
|
|
# We need a "dev-all" target that builds the docs plus binaries, but
|
|
# that doesn't work since we require the user to specify the target. More
|
|
# thought is needed
|
|
+
|
|
+install::
|
|
+ (cd source; make -f Makefile.freebsd install)
|
|
+ ${INSTALL} ${COPY} -m 644 doc/nedit.man $(DESTDIR)${PREFIX}/share/man/man1/nedit.1
|
|
+ ${INSTALL} ${COPY} -m 644 doc/nc.man $(DESTDIR)${PREFIX}/share/man/man1/nclient.1
|
|
+ ${INSTALL} ${COPY} -m 644 NEdit.ad $(DESTDIR)${LOCALBASE}/lib/X11/app-defaults/NEdit.ad
|
|
|
|
clean:
|
|
(cd util; $(MAKE) -f Makefile.common clean)
|