mirror of
https://git.freebsd.org/ports.git
synced 2025-05-01 02:56:39 -04:00
The original configure script attempted to detect the presence of
Heimdal, but it failed with LLVM 15+ due to a type casting bug.
commit 515552b2d2
fixed the bug with
LLVM 15+, but inadvertently broke the build for earlier versions.
This commit corrects the configure syntax, fixing the build on 12.4 and
13.2.
PR: 270465
Approved by: mikael (ports)
Sponsored by: Axcient
MFH: 2023Q4
48 lines
1.6 KiB
Text
48 lines
1.6 KiB
Text
--- configure.in.orig 2009-11-06 10:28:08 UTC
|
|
+++ configure.in
|
|
@@ -97,11 +97,15 @@ esac
|
|
linux*) nss_ldap_so_LDFLAGS="-shared -Wl,-Bdynamic -Wl,--version-script,\$(srcdir)/exports.linux" ;;
|
|
*) nss_ldap_so_LDFLAGS="-shared -Wl,-Bdynamic" ;;
|
|
esac
|
|
+case "$target_os" in
|
|
+freebsd*) TARGET_OS=FreeBSD ;;
|
|
+esac
|
|
|
|
AM_CONDITIONAL(GCC, test "$GCC" = "yes")
|
|
AM_CONDITIONAL(GLIBC, test "$target_os" = "linux" -o "$target_os" = "linux-gnu")
|
|
AM_CONDITIONAL(AIX, test "$TARGET_OS" = AIX)
|
|
AM_CONDITIONAL(HPUX, test "$TARGET_OS" = HPUX)
|
|
+AM_CONDITIONAL(FreeBSD, test "$TARGET_OS" = FreeBSD)
|
|
|
|
AM_CONDITIONAL(USE_NATIVE_LINKER, test -n "$nss_ldap_so_LD")
|
|
|
|
@@ -153,7 +157,6 @@ case "$target_os" in
|
|
aix*) AC_CHECK_HEADERS(irs.h usersec.h) ;;
|
|
hpux*) AC_CHECK_HEADERS(nsswitch.h) ;;
|
|
*) AC_CHECK_HEADERS(nss.h)
|
|
- AC_CHECK_HEADERS(nsswitch.h)
|
|
AC_CHECK_HEADERS(irs.h) ;;
|
|
esac
|
|
AC_CHECK_HEADERS(thread.h)
|
|
@@ -188,6 +191,13 @@ AC_CHECK_HEADERS(krb5.h)
|
|
AC_CHECK_HEADERS(gssapi/gssapi_krb5.h gssapi.h)
|
|
AC_CHECK_HEADERS(krb5.h)
|
|
|
|
+AC_MSG_CHECKING([if Kerberos is Heimdal])
|
|
+AC_TRY_LINK([#include <krb5.h>],
|
|
+ [const char *hv = heimdal_version;],
|
|
+ [AC_MSG_RESULT(yes)
|
|
+ AC_DEFINE(HEIMDAL,1,[Define if Kerberos is Heimdal])],
|
|
+ [AC_MSG_RESULT(no)])
|
|
+
|
|
AC_CHECK_LIB(resolv, main)
|
|
AC_CHECK_LIB(nsl, main)
|
|
AC_CHECK_LIB(socket, main)
|
|
@@ -230,7 +240,6 @@ AC_CHECK_LIB(pthread_nonshared, main)
|
|
AC_CHECK_FUNCS(gethostbyname)
|
|
AC_CHECK_FUNCS(nsdispatch)
|
|
AC_CHECK_LIB(pthread_nonshared, main)
|
|
-AC_CHECK_FUNCS(pthread_atfork)
|
|
AC_CHECK_FUNCS(pthread_once)
|
|
AC_CHECK_FUNCS(ether_aton)
|
|
AC_CHECK_FUNCS(ether_ntoa)
|