ports/devel/pure-stllib/files/patch-Makefile
Rusmir Dusko cef3506f49 pure-stllib is an "umbrella" package that contains a pair of Pure addons,
pure-stlvec and pure-stlmap. These addons provide Pure interfaces to a
selection of containers provided by the C++ Standard Library, specialized
to hold pointers to arbitrary Pure expressions.

WWW: http://docs.pure-lang.googlecode.com/hg/pure-stllib.html

PR:		ports/165865
Submitted by:	Zhihao Yuan <lichray@gmail.com>
Approved by:	wg (mentor)
2013-11-07 13:44:01 +00:00

19 lines
599 B
Text

--- ./Makefile.orig 2013-08-28 18:17:41.000000000 +0200
+++ ./Makefile 2013-10-16 22:49:25.000000000 +0200
@@ -17,12 +17,12 @@
MOD_CXXFLAGS = $(PIC) $(shell pkg-config pure --cflags) $(CFLAGS) $(CPPFLAGS)
MOD_LDFLAGS = $(shell pkg-config pure --libs) $(LDFLAGS)
-CFLAGS = -g -O2 -Wall -Wextra
+CFLAGS ?= -g -O2 -Wall -Wextra
-ifeq "$(DLL)" ".dylib"
+#ifeq "$(DLL)" ".dylib"
# OSX may need this (untested)
-DLL_FLAGS = -install_name "$(libdir)/pure/$@"
-endif
+#DLL_FLAGS = -install_name "$(libdir)/pure/$@"
+#endif
# Basic rules to build the module, clean, check, install and uninstall.