mirror of
https://git.freebsd.org/ports.git
synced 2025-05-19 18:43:13 -04:00
Among changes: - Switch KDE4_PREFIX to ${LOCALBASE} - Remove now needless misc/kde4-shared-mime-info port - Add stage support - Remove ancient CONFLICTS (KDE 4.9 and less) and LATEST_LINK - Squeeze MASTER_SITES/MASTER_SITE_SUBDIR - Convert LIB_DEPENDS to new style - Use options helpers - Drop support for FreeBSD 7.x - Remove Qt/KDE 3 related workarounds - Remove local patches and use upstream version scheme for libraries - sysutils/kdeadmin4, net/kdenetwork4, devel/kdesdk4, and x11-clocks/kdetoys4 ports have been split. - devel/kcachegrind is now a part of KDE SC [1] - more logs in area51 repo... New ports: devel/kde-dev-scripts: KDE development scripts devel/kde-dev-utils: KDE development utilities games/klickety: Tetris themed solitaire games/picmi: Single player logic-based puzzle game textproc/libkomparediff2: Library to compare files and strings The area51 repository features commits by Schaich Alonso, avilla, rakuco and myself. PR: ports/186491 Exp-run: by bdrewery Approved by: beat (former maintainer) [1]
16 lines
828 B
Text
16 lines
828 B
Text
--- CMakeLists.txt.orig 2013-07-09 23:19:54.000000000 +0000
|
|
+++ CMakeLists.txt 2013-08-12 23:11:31.141329406 +0000
|
|
@@ -8,10 +8,10 @@
|
|
|
|
## Compiler flags
|
|
if(CMAKE_COMPILER_IS_GNUCXX)
|
|
- set(CMAKE_C_FLAGS "-std=c99") ## ALSA no longer compiles with -std=c90, see https://bugzilla.novell.com/show_bug.cgi?id=817077
|
|
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99") ## ALSA no longer compiles with -std=c90, see https://bugzilla.novell.com/show_bug.cgi?id=817077
|
|
endif()
|
|
-find_package(Alsa)
|
|
-alsa_configure_file(${CMAKE_CURRENT_BINARY_DIR}/config-alsa.h)
|
|
+find_file(CONFIG_ALSA_H_CMAKE config-alsa.h.cmake ${CMAKE_MODULE_PATH})
|
|
+configure_file(${CONFIG_ALSA_H_CMAKE} ${CMAKE_BINARY_DIR}/config-alsa.h)
|
|
|
|
include_directories(${KDE4_INCLUDES})
|
|
include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR})
|