ports/java/jdk15/files/patch-j2se-motif21-Makefile
Greg Lewis 9b25f12760 . Fix the build after the openmotif port upgrade:
. Add xft to USE_XORG [1]
  . Teach the appropriate Makefile where to look for the FreeType headers.
. Bumping PORTREVISION for paranoia's sake since I have some concerns about
  runtime linkage issues with regards to this.  Normally that wouldn't be
  necessary but I think we're better being safe here.

Submitted by:	Mikhail Tsatsenko <m.tsatsenko@gmail.com> [1]
2011-05-09 08:50:20 +00:00

15 lines
470 B
Text

$FreeBSD$
--- ../../j2se/make/sun/motif21/Makefile.orig 2008-05-28 00:06:43.000000000 -0700
+++ ../../j2se/make/sun/motif21/Makefile 2011-05-08 23:39:31.000000000 -0700
@@ -19,6 +19,10 @@
ifdef BUILD_MOTIF21
include $(BUILDDIR)/sun/awt/mawt.gmk
+
+ ifeq ($(PLATFORM), bsd)
+ OTHER_INCLUDES += -I%%LOCALBASE%%/include/freetype2
+ endif
else
all optimized debug clean clobber ::
# do nothing case if older OS and new motif 2.1 not found in the boot dir